EIGRP vs Static routing issue

Unanswered Question
Apr 4th, 2007

I have certain /30 blocks that I need to be static routed through a particluar SVI on my core router. This router participates in my EIGRP AS on another SVI. When I add the static route for the /30 block...10.194.14.44/30 for instance and then do a sho ip route for that block, .44,.45, & .47 show up correctly. It is the .46 address which is which is a VOIP gateway hanging off my DS3 router, that is being redistributed by EIGRP. My DS3 router also participates in my EIGRP AS, but that /30 network is not configured to be advertised on it.

Basically, I don't want certain interface IP address's on my DS3 router to be advertised in my EIGRP AS, because I need them to take a different route from the core.

I know this is just a brief explanation of what is happening, I just figured I am probably missing somthing simple.I can be more detailed about my configurations if I have to. Any help would be apprecaited! Thanks!

Core:

ip route 10.194.14.44 255.255.255.252 10.194.15.42

interface Vlan10

description VLAN10 Flex-T1

ip address 10.194.15.41 255.255.255.248

no ip redirects

no ip unreachables

no ip proxy-arp

CT3 Router:

interface FastEthernet0/0.2

description Vlan 10 - SONET Flex-T1 Subnet to Core

encapsulation dot1Q 10

ip address 10.194.15.42 255.255.255.248

no ip unreachables

no snmp trap link-status

interface Serial1/0/8:0

description ####

bandwidth 1544

ip address 10.194.14.45 255.255.255.252

encapsulation ppp

ip policy route-map Flex-T1

fair-queue

route-map Flex-T1 permit 10

set default interface FastEthernet0/0.2

set ip default next-hop 10.194.15.41

show commands:

sho ip route 10.194.14.44

Routing entry for 10.194.14.44/30

Known via "static", distance 1, metric 0

Routing Descriptor Blocks:

* 10.194.15.42

Route metric is 0, traffic share count is 1

sho ip route 10.194.14.45

Routing entry for 10.194.14.44/30

Known via "static", distance 1, metric 0

Routing Descriptor Blocks:

* 10.194.15.42

Route metric is 0, traffic share count is 1

****sho ip route 10.194.14.46****

Routing entry for 10.194.14.46/32

Known via "eigrp 100", distance 90, metric 2170112, type internal

Redistributing via eigrp 100

Last update from x.x.x.x on Vlan15, 4d22h ago

Routing Descriptor Blocks:

* x.x.x.x, from x.x.x.x, 4d22h ago, via Vlan15

Route metric is 2170112, traffic share count is 1

Total delay is 20010 microseconds, minimum bandwidth is 1544 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 96/255, Hops 1

sho ip route 10.194.14.47

Routing entry for 10.194.14.44/30

Known via "static", distance 1, metric 0

Routing Descriptor Blocks:

* 10.194.15.42

Route metric is 0, traffic share count is 1

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
sundar.palaniappan Wed, 04/04/2007 - 11:57

The problem lies here..

****sho ip route 10.194.14.46****

Routing entry for 10.194.14.46/32 --> Host route takes precedence over the route with a /30 bit mask.

Last update from x.x.x.x on Vlan15, 4d22h ago --> Check the device connected via Vlan 15 why is it advertising a /32 (host) route for 10.194.14.46.

A workaround solution while you work on fixing the source of the issue is to put a distribute list and block the host route in the core switch.

router eigrp 100

distribute-list 10 in vlan 15 --> where 10 is the access list #. Make sure access list isn't already being used in the switch and if it is use a different #.

access-list 10 deny 10.194.14.46

access-list 10 permit any

Also, make sure there's no inbound distribute list applied under eigrp process for vlan 15. If there's one then you can modify the existing distribute list to deny this host route from being learnt via vlan15.

HTH

Sundar

eknell Wed, 04/04/2007 - 12:14

I do have a static route on my DS3 router, but it is routing another another block to 10.194.14.46.

ip route X.X.X.X 255.255.255.252 10.194.14.46

10.194.14.46 is bound to my equipment on the end of that T1. It is just basically an Ethernet rail between .45 (Serial Int) and .46 (VOIP IAD). I have to route a public /30 to that device as that is also the internet gateway for my cleint.

Any ideas?? Thanks for the ACL by the way..

sundar.palaniappan Wed, 04/04/2007 - 12:26

I see the problem.

Try adding this command on the CT3 Router and post the results;

CT3 Router:

interface Serial1/0/8:0

no peer neighbor-route --> add this command

HTH

Sundar

eknell Wed, 04/04/2007 - 12:58

Sorry...No go??

interface Serial1/0/8:0

description

bandwidth 1544

ip address 10.194.14.45 255.255.255.252

encapsulation ppp

ip policy route-map Flex-T1

no peer neighbor-route

fair-queue

"show ip route 10.194.14.46" on Core:

Routing entry for 10.194.14.46/32

Known via "eigrp 100", distance 90, metric 2170112, type internal

Redistributing via eigrp 100

Last update from x.x.x.x on Vlan15, 00:06:55 ago

Routing Descriptor Blocks:

* x.x.x.x, from x.x.x.x, 00:06:55 ago, via Vlan15

Route metric is 2170112, traffic share count is 1

Total delay is 20010 microseconds, minimum bandwidth is 1544 Kbit

Reliability 255/255, minimum MTU 1500 bytes

Loading 96/255, Hops 1

"show ip route 10.194.14.46" on DS3 Router

Routing entry for 10.194.14.46/32

Known via "connected", distance 0, metric 0 (connected, via interface)

Redistributing via eigrp 100

Advertised by eigrp 100

Routing Descriptor Blocks:

* directly connected, via Serial1/0/8:0

Route metric is 0, traffic share count is 1

Just an FYI though.... I did try your first suggestion using the ACL and the distribute-list command and that worked great!!!! I did change it up a little though, instead of blocking "in" on my core, I blocked it "out" on my DS3 router.

DS3 config:

access-list 15 deny 10.194.14.46

access-list 15 permit any

router eigrp 100

redistribute static

network x.x.x.x 0.0.3.255

network x.x.x.x 0.0.0.255

network x.x.x.x 0.0.0.7

network x.x.x.x 0.0.0.31

network x.x.x.x 0.0.0.7

network x.x.x.x 0.0.0.7

network x.x.x.x 0.0.0.31

network x.x.x.x 0.0.0.31

network x.x.x.x 0.0.0.31

network x.x.x.x 0.0.0.31

network x.x.x.x 0.0.0.31

network x.x.x.x 0.0.0.31

network x.x.x.x 0.0.0.31

network x.x.x.x 0.0.0.127

network x.x.x.x 0.0.0.7

network x.x.x.x 0.0.0.3

network x.x.x.x 0.0.0.7

network x.x.x.x 0.0.0.7

network x.x.x.x 0.0.0.3

network x.x.x.x 0.0.0.3

network x.x.x.x 0.0.0.7

network x.x.x.x 0.0.0.3

network x.x.x.x 0.0.0.3

network x.x.x.x 0.0.0.3

network x.x.x.x 0.0.0.3

network x.x.x.x 0.0.0.3

network x.x.x.x 0.0.0.3

network x.x.x.x 0.0.0.3

network x.x.x.x 0.0.31.255

network x.x.x.x 0.0.0.127

distribute-list 15 out FastEthernet0/0.15

no auto-summary

"sho ip route 10.194.14.46" on Core

Routing entry for 10.194.14.44/30

Known via "static", distance 1, metric 0

Routing Descriptor Blocks:

* 10.194.15.42

Route metric is 0, traffic share count is 1

Man, I really appreciate your help!! That has been driving me crazy! If you happen to have a chance, you might let me know why that was happening. I didn't think there was anything wrong with my initial configs, but? Again, I apprecaite your help!

sundar.palaniappan Wed, 04/04/2007 - 13:06

oops, that was my fault..

Configure the 'no peer neighbor-route' on the device that's connected to Serial1/0/8:0 on the DS3 router and that should take care of the problem.

HTH

Sundar

eknell Wed, 04/04/2007 - 13:15

Sorry...I wish I could man, but the device on the end of that Serial Int is an Adtran unit.. It is not a Cisco device.

Did you read my prior post though? Your previous solution worked for me! Do you not suggest me using the ACL and distribution-list?

sundar.palaniappan Wed, 04/04/2007 - 13:46

Yes, I did read your last post and glad it helped :)

Distribute-list should be fine. In fact, applying the distribute list on the DS3 router is more appropriate as that's closer to the source.

HTH

Sundar

Actions

This Discussion