Simple OSPF config

Unanswered Question
Apr 4th, 2007
User Badges:

I am trying to recreate a config I had at a previous employer (which I lost my docs for).


I want a simple ospf config with only redistributing connected and static subnets on core routers and switches. Below is what I have now, but I am having issues getting the loopbacks to talk to each other.


R1

interface Loopback0

ip address 123.234.40.1 255.255.255.255


router ospf 10

router-id 123.234.40.1

log-adjacency-changes

redistribute connected subnets

redistribute static subnets


R2

interface Loopback0

ip address 123.234.40.2 255.255.255.255


router ospf 10

router-id 123.234.40.2

log-adjacency-changes

redistribute connected subnets

redistribute static subnets



It doesn't appear that the loopback0 addresses can see each other.


I have tried adding the following and it didn't work either. The routers are connected via fa1/0 on each router which has subinterfaces which seem to see each other fine over their vlans.


network 123.234.40.0 0.0.0.255 area 0

network 123.234.41.0 0.0.0.255 area 0

network 123.234.42.0 0.0.0.255 area 0


I know I am missing something simple here.. maybe it is just old age kicking in.


Thanks


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
nz-ipv6 Wed, 04/04/2007 - 19:14
User Badges:

hi there,


what is the ip address on the f1/0 interfaces ?


Cheers

paarlberg Wed, 04/04/2007 - 19:29
User Badges:

R1

fa1/0.100

123.234.41.1 255.255.255.0

fa1/0.300

123.234.42.1 255.255.255.0


R2

fa1/0.100

123.234.41.2 255.255.255.0

fa1/0.300

123.234.42.2 255.255.255.0


Thanks

nz-ipv6 Wed, 04/04/2007 - 19:42
User Badges:

and Can you please paste the show ip ospf neig details


And if possible Could you please paste the running config on R1 and R2


Cheers

paarlberg Wed, 04/04/2007 - 20:01
User Badges:

CR001#sh ip ospf neighbor


Neighbor ID Pri State Dead Time Address Interface

123.234.40.2 1 FULL/DR 00:00:35 123.234.42.2 FastEthernet1/0.300

123.234.40.2 1 FULL/DR 00:00:35 123.234.41.2 FastEthernet1/0.100

**********************************************


CR002#sh ip ospf neighbor


Neighbor ID Pri State Dead Time Address Interface

123.234.40.1 1 2WAY/DROTHER 00:00:38 123.234.42.1 FastEthernet1/0.300

123.234.40.1 1 2WAY/DROTHER 00:00:38 123.234.41.1 FastEthernet1/0.100




Attachment: 
paarlberg Wed, 04/04/2007 - 20:10
User Badges:

I updated it to show these and it works, not sure why it didn't last time. I have done it before without specifying all the networks and let it discover the connected and static and it worked better without additional tuning.


router ospf 10

router-id 123.234.40.1

log-adjacency-changes

redistribute connected subnets

redistribute static subnets

network 10.40.0.0 0.0.255.255 area 1

network 123.234.40.0 0.0.0.255 area 0

network 123.234.41.0 0.0.0.255 area 0

network 123.234.42.0 0.0.0.255 area 0


As a test on R2 I shut down its internal interfaces and it is not reachable now. So the config is missing the outside network info which is causing it not to route.


My main reason for using it on the router is if an internal interface craps out killing all the vlans, VRRP will take over for the inside, but the R1 router will not know how to get to the internal VRRP interface on R2.


Should I rethink my design? There are 2x 3640 at the border with distribution switches (L3)behind them and switches (L2) connected to the servers and to both distribution switches.

Actions

This Discussion