DHCP configuration

Unanswered Question
Apr 4th, 2007

I have a Cisco 3725 Router with 16 port FE switching NM, acting as DHCP Server with 2 different DHCP Pools 10.10.10.0 and 192.168.1.0 configured.

My requirement is, when I connect SERVER-A on my Cisco 3725 Router's NM Port FastEthernet 1/10, Router should assign IP (10.10.10.100) and default Gateway to SERVER-A

and IF I connect same SERVER-A to my Cisco 3725 Router's NM Port FastEthernet 1/11, Router should assign IP (192.168.1.100) and default gateway to SERVER-A.

Please how can I accomplish this task.

thanx.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
shivlu jain Thu, 04/05/2007 - 01:41

ip dhcp pool 1

network 10.10.10.0 /24

default-router

!

ip dhcp pool 2

network 192.168.1.0 /24

default-router

After that you can use automatic DHCP in your lan.

shivlu

abdalians Thu, 04/05/2007 - 02:04

Dear Shivlu

thank you for your interest.

I'm sorry, coz I think I could not make my Point clear. Actually SERVER-A is a DHCP Client and Cisco3725 Router is a DHCP Server and internet gateway too.

Configuration presented by you is perfect and according to your advice my config will b as follows

!

ip dhcp pool-1

network 10.10.10.0 /24

default-router 10.10.10.1

!

ip dhcp pool-2

network 192.168.1.0 /24

default-router 192.168.1.1

Now according to the config given above, IF I connect SERVER-A(DHCP Client) to FastEthernet 1/10 of my Router(DHCP Server), the router shold assign IP 10.10.10.100 and default gateway 10.10.10.1 to SERVER-A(DHCP Client) from Pool-1.

AND IF I connect SERVER-A(same DHCP Client) to FastEthernet 1/11 of my Router(DHCP Server), the router shold assign IP 192.168.1.100 and default gateway 192.168.1.1 to SERVER-A(DHCP Client) from Pool-2.

Please help me, how can I accomplish this task.

Thanking you in advance.

Amit Singh Thu, 04/05/2007 - 08:06

Hello,

As you already have the DHCp pools defined for the respective vlans.Create two vlan on the FE module, For example Vlan 10 for 10.X and Vlan 192 for Vlan192 and create the respective SVI's for the vlans on the FE module. Assign the ports to their respective vlans.

This will work for you.

-amit singh

abdalians Sun, 04/08/2007 - 20:11

Dear Amit,

Yes I have created 2 vlans in Router's VLAN Database, VLAN 10 for 10.0.10.x/24 & VLAN 192 for 192.168.1.x/24 Networks. And assigned FE 1/10 to VLAN 10 and FE 1/11 to VLAN 192. Now my Router's config looks like the following.

!

ip dhcp pool-1

network 10.10.10.0 /24

default-router 10.10.10.1

!

ip dhcp pool-2

network 192.168.1.0 /24

default-router 192.168.1.1

!

!

interface FastEthernet1/10

switchport access vlan 10

no ip address

!

interface FastEthernet1/11

switchport access vlan 192

no ip address

!

interface Vlan10

ip address 10.10.10.1 255.255.255.0

!

interface Vlan192

ip address 192.168.1.1 255.255.255.0

!

Now What happens is, when I connect SERVER-A(DHCP Client) to FE 1/10, router assigns IP from DHCP pool-1 (10.10.10.x) to SERVER-A.

When I unplug cable of SERVER-A(DHCP Client) from FE 1/10 and plug in to FE 1/11 Router assignes the same ip from DHCP Pool-1 where as I want when I connect SERVER-A to FE 1/11 router should assign ip from DHCP Pool-2 (192.168.1.x).

How can I resolve this issue.

Thanking you in advance.

Actions

This Discussion