STP -problem ?

Unanswered Question
Apr 5th, 2007

Hi all,

I had wierd (for me) behavior in my network yesterday. I connect sw2 (2950C) to sw1 (6000) and it generates STP blocking and broadcast storm to the network, whole network was down because of that. There was no hosts connected to sw2. Network is flat. There is just basic spanning-tree configuration on switches.

sw1

interface FastEthernet3/9

duplex full

switchport

switchport access vlan 100

switchport mode access

switchport nonegotiate

end

sw2

interface FastEthernet0/25

switchport trunk native vlan 199

switchport mode trunk

no ip address

end

I know that another side was access port (sw1) and another side was trunk (sw2). So that is not acceptable configuration, but I'm keen to now why it generates broadcast storm and that kind of BPDU messages.

I attach file, where is log from sw2. I don't have log from sw1.

Thanks in Advance,

Teemu

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2 (3 ratings)
Loading.
mahmoodmkl Thu, 04/05/2007 - 02:24

Hi

This could happen when u connect a spanning-tree portfast configured port to a trunk port.

As u have said that u r having a flat network i assume that u r having a single vlan,this might cause due to the in-compatiable vtp databases on the swithes.

Thanks

Mahmood

surojitmitra Thu, 04/05/2007 - 03:22

Too many misconfiguration

1. A trunk port most probably cannot be part of any vlan--- pls confirm

2. A trunk port can be conneted to trunk so that it can understands the bpdu( though it works sometimes)

3. Both the vlans are different vlan 100 and 199 does not make sense

Solution:

Create trunk ports on both switches, duplex full on both, and speed 100. Logically it should work

tvaris Thu, 04/05/2007 - 04:20

I know that it was a misconfiguration, but I'm just keen to know why it generates broadcast storm and put all network down.

After that I get it work when I configured both sides "mode trunk" and same native vlan.

linnea.wren Sat, 04/07/2007 - 08:30

Hi,

One thing is that both sides of a trunk must have the same native vlan ID. Go here: http://www.cisco.com/pcgi-bin/Support/Errordecoder/index.cgi, click the link for Registered Users, and paste

%SPANTREE-2-RECV_PVID_ERR

(from the errors you provided in your first post).

And, since ports can negotiate whether or not to become a trunk, the fact that one end was configured as an access port wouldn't prevent STP from caring about the mismatch (when an access port is negotiated into becoming a trunk port, the configured access vlan is used for the trunk's native vlan). See this doc for DTP & negotiating: http://www.cisco.com/en/US/tech/tk389/tk390/technologies_tech_note09186a008017f86a.shtml

Here's another doc on Spanning Tree - The description near the bottom on Forwarding state is relevant. http://www.cisco.com/univercd/cc/td/doc/product/rtrmgmt/sw_ntman/cwsimain/cwsi2/cwsiug2/vlan2/stpapp.htm

milan.kulik Thu, 04/12/2007 - 00:44

Hi,

where did you notice the broadcast storm?

AFAIK, the port should be shutted down while native VLAN mismatch detected but no broadcast storm should apear while no devices attached to sw2 (and I suppose sw2 not connected to the network via any other port?).

Best regards,

Milan Kulik

Actions

This Discussion