setting 1242 speed and duplex

Unanswered Question
Apr 6th, 2007

I have 8 1242 WAP's being controlled y a 4402 wireless lan controller. I was looking at the switch ports on my core switches and noticed that they are setting at 100 meg. I always set my switch ports manually to gig full especially when connecting to other gear like this. My question is how do I force the WAP's into gig full. I can find no where to set this manually. Auto seems to only go 100 half.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
scottmac Fri, 04/06/2007 - 05:50

The APs are 100meg Ethernet.

Aside form that, when a connection falls back to a slower speed, or fails to function when forced to the higher rate (assuming both ends support the higher rate), then the problem is the cabling.

If the cabling is not terminated properly, (not using the correct pair order for example), or is is bent, kinked, twisted, or otherwise damaged, then the switch will downshift the speed to minimize errors.

In the case of a 100/Full port that only works at 10meg (or half duplex only), then it's usually a pair order issue, usually a split pair on pins 3&6.

10/100 Ethernet uses pair 3 (pins 1&2) and pair 2 (pins 3&6).

The most frequent cause for that is terminating the ends as pair> instead of the EIA/TIA spec (568a = green-whitet, green, orange-white, BLUE, Blu/Wht, orange, brown-white, brown ... 568b swap the orange and green pair).

If you map it out on paper, you'll see that pair> give you pin 3 as one color and pin 6 as another color ... meaning you no longer would be using "twisted pair" ... and the crosstalk spec (critical for high-speed signaling) goes right out the window.

Half duplex works with pair> because only one side is talking at a time, the crosstalk has no other signal to conflit with.

Check your in-wall cabling, use commercially created jumpers.

Good Luck

Scott

b.julin Fri, 04/06/2007 - 06:43

You have to live with auto/auto

The WLC is the only thing that can permanently alter the config on a LWAPP, and it has no setting for speed/duplex on the hardwire. (And they are 100M anyway, as already pointed out.) If you try setting 100/full the LWAPP will often come up half duplex so you have to set auto/auto on the switch and just hope.

You can hack around that on the serial console port access ("debug lwapp console cli" then "config term") but you cannot save the configuration (doing so will corrupt things and you'll have to do some acrobatics to get the AP back up and running.) Since the setting really is most important on device reboot, that's kinda pointless to do though.

b.julin Mon, 04/09/2007 - 07:33

An ammendment -- it is possible to alter the LWAPP configuration without console access.

On the WLC, execute:

config ap remote-debug enable

config ap remote-debug exc-command "debug lwapp console cli"

config ap remote-debug exc-command "copy tftp://a.tftp.server/file.with.ios.commands.text running-config"

config ap remote-debug disable

You can even activate telnet into the device this way.

However do not try to write any config changes or the AP will go belly-up and require complicated restoration from the console bootloader.

fredn Mon, 04/09/2007 - 08:00

The 1242 utilizes a 10/100 port.

Although the radio datarate on the 1242 (for each radio) supports up to 54M the reality here is that is the actual RADIO DATA RATE is not the same as the actual Ethernet data rate.

The actual Ethernet data rate is typically half the radio data rate, therefore more then a 10/100 does little good until radio data rate actually exceeds 54M per radio and you are using two radios, only then does gigE starts to make more sense.

b.julin Mon, 05/07/2007 - 09:02

This is now (4.1.171) possible

In the lastest WLC software you can execute the "config ap ethernet" command to set the speed and duplex of the AP uplink port. It does not appear to have a GUI equivalent.

I don't know if that setting takes effect if the AP cannot talk to the WLC, but as long as the ethernet works well enough to talk to the WLC to get the config, it should work regardless.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode