2800 with NDM-36-ESW Vlan problem

Unanswered Question
Apr 6th, 2007
User Badges:

I am setting up the above for Avaya phones. The sites with separate router/switch combos work fine.


The FA port settings are as follows:


!

interface FastEthernet1/2

description * Data/Voice Vlan's *

switchport access vlan 20

switchport voice vlan 852

mls qos trust dscp

spanning-tree portfast


We have 2 Vlan interfaces set up - 1 for voice and one for data. (20 is data and 852 is voice.


If I plug a laptop in, I get an IP address from the off-site DHCP server.

If I plug the phone in, it get the Vlan number (852) from the scope option properly.


If I change the port to


switchmode access vlan 852


and plug the laptop in, I get a voice IP address.


If I plug the phone in, it gets it's voive IP address and loads it's config. But I can't get a data IP for the PC.


I do a show vlan-sw and see that all of the ports are assigned to Vlan 20 but none are co-assigned to Vlan 852.


The 3550's, 3750's, etc. at other sites have both Vlan's assigned to each port.


What am I missing?


Thanks,


Tom


But on this setup, when I do a sho vlan-sw,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (2 ratings)
Loading.
Brandon Buffin Fri, 04/06/2007 - 13:00
User Badges:
  • Purple, 4500 points or more

Try a config such as the following:


interface FastEthernet1/2

description * Data/Voice Vlan's *

switchport trunk encapsulation dot1q

switchport mode trunk

switchport trunk native vlan 20

switchport voice vlan 852

mls qos trust dscp

spanning-tree portfast


Hope this helps. If so, please rate the post.


Brandon

gregoryt Mon, 04/09/2007 - 05:32
User Badges:

Thanks.


I loaded this config this morning remotely. I still do not see the interface in the vlan table. It is now in VLAN 1


VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa1/2

20 VLAN_20 active Fa1/1, Fa1/3, Fa1/4, Fa1/5, Fa1/6, Fa1/7, Fa1/8, Fa1/9, Fa1/10

Fa1/11, Fa1/12, Fa1/13, Fa1/14, Fa1/15, Fa1/16, Fa1/18, Fa1/19

Fa1/20, Fa1/21, Fa1/22, Fa1/23, Fa1/24, Fa1/25, Fa1/26, Fa1/27

Fa1/28, Fa1/29, Fa1/30, Fa1/31, Fa1/32, Fa1/33, Fa1/34, Fa1/35

852 VLAN_852 active Fa1/0


Doing a show int fa 1/2 trunk gives me this:


Port Mode Encapsulation Status Native vlan

Fa1/2 on 802.1q not-trunking 20


Port Vlans allowed on trunk

Fa1/2 none


Port Vlans allowed and active in management domain

Fa1/2 none


Port Vlans in spanning tree forwarding state and not pruned

Fa1/2 none


The site is an hour or so away. I am heading over ther now to see if the phone works in spite of not seeing the voice vlan on the interface.


Any ideas on why this is?


Thanks,


Tom





gregoryt Mon, 04/09/2007 - 17:23
User Badges:

All is working .. Thanks. Still not sure why it shows in Vlan 1 though.



Hieu Cao Fri, 04/06/2007 - 13:11
User Badges:

When you use the command "switchportmode access vlan 852", you basically assign that port to have access to vlan 852 ONLY - that's why you get the voice's ip address when you plugged your laptop in this port.


You should use this config:

switchport mode access

switchport access vlan 20

switchport voice vlan 852


hth,

hieu

Actions

This Discussion