displaying a number

Unanswered Question
Apr 8th, 2007
User Badges:

i have configured a CME in connection with PBX via FXO ports, but i have a little problem, when i'm calling from the PXB telephone to IP pone of the CME, the IP phone is not displaying the extention number of the PBX telephone. Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
pacameron Sun, 04/08/2007 - 03:24
User Badges:
  • Silver, 250 points or more

This depends on the PBX being able to provide standard Caller ID (CLID) on it's handset ports towards the router's FXO ports. You can do a debug VPM signal to check if the CLID is being passed.


The issue is with the PBX being able to pass the CLID, not with the router being able to recieve it.


If this is a needed feature, you may need to consider using ISDN BRI, which supports direct inward dial for the Called number as well as Caller number (CLID).

a.rayen83 Sun, 04/08/2007 - 05:17
User Badges:

thanks, now i'm sure that the problem is not in my router.

a.rayen83 Mon, 04/09/2007 - 01:39
User Badges:

hi, i have a panasonic PBX, than between pbx phones the CLID is enable, than i want to know what can i do to resolve this problem, i think that the PBX send the CLID but the switch can't interpret this data. Thanks again.

paolo bevilacqua Mon, 04/09/2007 - 04:25
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Are you panasonic phones standard analog or digital units ?

If the latter the signaling is proprietary so you cannot make comparison with an analog phone.

if an analog phone connected to the PBX is able to display CLID, check that you have configure caller-id correctly in the router.


Anyway as pacameron said, the best way to connect router and PBX is ISDN and not FXS/FXO that always cause problems. For example right now I'm not sure how you can have single-stage dialing in both directions, most likey you can't.

a.rayen83 Mon, 04/09/2007 - 04:42
User Badges:

hi, we don't have a panasonic phones, we have a standard analog phones, and i'm sure that the analog phones display CLID, i think that the problem is in the router configuration, for the caller-id, i apply this command to the FXO port " caller-id enable", is it sufficient to display CLID on the IP phone? thanks

paolo bevilacqua Mon, 04/09/2007 - 04:57
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

You also need to configure cptone under voice-port to make sure that the CLID standard is correct for you country, have you done that?

Then as suggested before you can do "debug vpm signal" and check if caller ID is being received.

a.rayen83 Mon, 04/09/2007 - 05:04
User Badges:

no, i did not do this command, please can you explain me this more. thanks

paolo bevilacqua Mon, 04/09/2007 - 05:20
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

There is not much to explain.

Under voice-port x/y, configure cptone XX where XX is your two-letters contry code. A list is given if you type ?

Also wehn you are not sure about a command, you can look it in the manual that is on CCO, documentaion section. Aften, it is enough that you type the command alone in the search box.

a.rayen83 Mon, 04/09/2007 - 05:48
User Badges:

hi, my conutry don't figure in the list, i can't have the code of cptone, i try many of codes but the problem persist. i can also access to the cco decumentation, can you give me the link. thanks

Actions

This Discussion