Routing question

Unanswered Question
Apr 9th, 2007

Hello,

I have a LAN that is 10.20/16. I have connected a router (2621) to this LAN and assigned 10.20.1.120 to the f0/0 interface.

I have assigned the F0/1 interface the ip address of 10.40.1.1/24. I have 1 server sitting on the 10.40.1.0/24 network.

I am able to ping this server from the 10.20 network and also connect using remote desktop. However, from this server I cannot ping or initiate any connections to stuff on the 10.20 network.

I was able to get it to ping my workstation by putting in a static route that said 10.20.0.103 255.255.255.255 10.20.1.120. My workstation is 10.20.0.103 and that is on the 10.20.0.0/16 network. With this route in I was able to ping it from the server on the 10.40/24 network.

I know that I should not have to put in static routes like this but cannot figure out what I'm missing. Any help would be appreciated.

Below is the config:

Current configuration : 697 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

enable secret xxx

!

memory-size iomem 10

no aaa new-model

ip subnet-zero

ip cef

!

!

no ip domain lookup

!

!

!

!

!

!

interface FastEthernet0/0

ip address 10.20.1.120 255.255.0.0

duplex auto

speed auto

!

interface Serial0/0

no ip address

shutdown

!

interface FastEthernet0/1

ip address 10.40.1.1 255.255.255.0

duplex auto

speed auto

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 10.20.1.1

!

!

!

line con 0

line aux 0

line vty 0 4

password xxx

login

!

!

end

Thanks,

Mike

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sundar.palaniappan Mon, 04/09/2007 - 12:10

Can you tell us what's the IP address/subnet mask and default gateway of your workstation and the Server?

On which device did you add the static (host) route?

mikeh1111 Mon, 04/09/2007 - 12:25

I've done some further research and the problem looks to be caused by the firewall. I ran Ethereal on my workstation and saw that traffic from the 10.40.1 network was actually reaching it and my box was sending replies to the ping.

I just went through the firewall logs and saw that my ping replies were being dropped.

I'll have to look a bit closer at the firewall for now.

I will post an update.

Richard Burts Mon, 04/09/2007 - 18:32

Mike

When I first read your post my reaction was to suspect an issue with addressing or gateway definition as Sundar asks about. But then I read more carefully and noticed this:

"I am able to ping this server from the 10.20 network and also connect using remote desktop" and it tells me that there is appropriate two way routing and proper gateway definition. Your discovery of the firewall makes good sense and is consistent with the symptoms that you discovered. Good catch for you :)

HTH

Rick

Actions

This Discussion