H323 Cannot make outbound calls, OK Inbound

Unanswered Question
Apr 9th, 2007
User Badges:

I cannot make outbound calls, but inbound call is ok. We are installing 2 new T1's and have the first 5 channels up for testing, we have a test number 2580 coming in but when I make a call from the inside I get an error. Here's the dubug and the config:



*Nov 28 06:58:50.090: ISDN Se1/0:23 Q931: pak_private_number: Invalid type/plan

0x0 0x0 may be overriden; sw-type 2

*Nov 28 06:58:50.090: ISDN Se1/0:23 Q931: Applying typeplan for sw-type 0x2 is 0

x2 0x1, Calling num 8702

*Nov 28 06:58:50.094: ISDN Se1/0:23 Q931: Applying typeplan for sw-type 0x2 is 0

x0 0x0, Called num 16307909496

*Nov 28 06:58:50.098: ISDN Se1/0:23 Q931: TX -> SETUP pd = 8 callref = 0x0085

Bearer Capability i = 0x8090A2

Standard = CCITT

Transer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xE9808385

Exclusive, Interface 0, Channel 5

Net Specific Fac i = 0x00E3

Calling Party Number i = 0x2181, '8702'

Plan:ISDN, Type:National

Called Party Number i = 0x80, '16307909496'

Plan:Unknown, Type:Unknown

*Nov 28 06:58:50.166: ISDN Se1/0:23 Q931: RX <- CALL_PROC pd = 8 callref = 0x80

85

Channel ID i = 0xE9808385

Exclusive, Interface 0, Channel 5

*Nov 28 06:58:50.182: ISDN Se1/0:23 Q931: RX <- PROGRESS pd = 8 callref = 0x808

5

Cause i = 0x8381 - Unallocated/unassigned number

Progress Ind i = 0x8381 - Call not end-to-end ISDN, may have in-band inf

o

*Nov 28 06:59:09.030: ISDN Se1/0:23 Q931: RX <- DISCONNECT pd = 8 callref = 0x8

085

Cause i = 0x8390 - Normal call clearing

*Nov 28 06:59:09.038: ISDN Se1/0:23 Q931: TX -> RELEASE pd = 8 callref = 0x0085

*Nov 28 06:59:09.090: ISDN Se1/0:23 Q931: RX <- RELEASE_COMP pd = 8 callref = 0

x8085




no network-clock-participate slot 1

no network-clock-participate wic 0

no aaa new-model

ip subnet-zero

ip cef

!

!

!

!

no ftp-server write-enable

isdn switch-type primary-4ess

voice-card 1

!

!

password encryption aes

!

voice call send-alert

!

!

!

!

controller T1 1/0

framing esf

linecode b8zs

pri-group timeslots 1-24 nfas_d primary nfas_int 0 nfas_group 1

!

controller T1 1/1

framing esf

linecode b8zs

pri-group timeslots 1-24 nfas_d backup nfas_int 1 nfas_group 1

!

!

!

interface FastEthernet0/0

description Connection_to_Data_Vlan

ip address 10.XX.0.XXX 255.255.0.0

speed 100

full-duplex

standby 1 preempt

!

interface FastEthernet0/1

ip address 10.129.0.104 255.255.0.0

speed 100

full-duplex

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.129.0.104

!

interface Serial1/0:23

ip address 10.1.1.1 255.255.255.0

no logging event link-status

dialer map ip 10.1.1.2 name megamap class megaplan megaplan

isdn switch-type primary-4ess

isdn incoming-voice voice

isdn T306 60000

isdn nsf-service megacom

no cdp enable

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.129.0.1

ip http server

!

!

!

map-class dialer megaplan

dialer voice-call

dialer outgoing mega

!

!

control-plane

!

!

!

voice-port 1/0:23

!

voice-port 1/1:23

!

!

dial-peer voice 100 voip

tone ringback alert-no-PI

preference 1

destination-pattern 2580

session target ipv4:10.129.1.1

incoming called-number .

dtmf-relay h245-alphanumeric

codec g711ulaw bytes 80

no vad

!

dial-peer voice 1 pots

tone ringback alert-no-PI

description PSTNpots

destination-pattern .T

incoming called-number .

direct-inward-dial

port 1/0:23

forward-digits all

!

gateway

emulate cisco h323 bandwidth

!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gogasca Mon, 04/09/2007 - 17:25
User Badges:
  • Green, 3000 points or more

Called Party Number i = 0x80, '16307909496'

Plan:Unknown, Type:Unknown


isdn nsf-service megacom


*Nov 28 06:58:50.182: ISDN Se1/0:23 Q931: RX <- PROGRESS pd = 8 callref = 0x808

5

Cause i = 0x8381 - Unallocated/unassigned number


Telco is disconnecting the call, I see that you are using NSF, could you please confirm with them that correct NSF is sent and switch is correct (isdn switch-type primary-4ess ) or what they are expecting from us in order to no disconnect the call?


BTW why you have dialer map ip configured under the serial?


tony.hanson Mon, 04/09/2007 - 18:27
User Badges:

I have verified that they are using NSF, when I remove it I get the following error:

Called Party Number i = 0x80, '16307909496'

Plan:Unknown, Type:Unknown

*Nov 28 08:45:42.290: ISDN Se1/0:23 Q931: RX <- RELEASE_COMP pd = 8 callref = 0

x80B1

Cause i = 0x83E020 - Mandatory information element missing



I removed the dialer map, I don't know why the customer had it in there.

paolo bevilacqua Tue, 04/10/2007 - 00:28
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hi,


more likely the problem is in the number format, have you tried local calls with seven digits? You are sending out a four digit extension, is that what they want? Also ask what type/plan they want in the setup message.

Actions

This Discussion