VTP Communication Problem

Unanswered Question
Apr 10th, 2007
User Badges:

I have a 6509 switch with VTP mode as server. There are 20 no's of 2970 switches connected to it with VTP mode set to client and all switches are in the same domain. All the switches are trunked using dot1Q encapsulation and are communicating good under vlan 1.

There are 25 Vlans deployed in 6509 switch. Out of 20 no.s of 2970 switches only 16 switches are able to replicate all the 25 vlans from 6509 switch. There are no Vlans found in remaining 4 switches. What might be the problem? How to resolve it?


Helpful posts will be rated..!!


Thanks in Advance

Sridhar

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.8 (8 ratings)
Loading.
Amit Singh Tue, 04/10/2007 - 02:12
User Badges:
  • Cisco Employee,

Sridhar,


1. Please check the VTP configuration on the reamining 4 switches. Make sure that you dont have any VTP password mismatch between the server and the client switches.


Please paste the show VTP counters from both core and the problematic 2970 switches


2. Make sure that you have the proper trunk connection between the switches and is up.


Please foollow the link below for VTP troubleshooting on the network:


http://www.cisco.com/en/US/tech/tk389/tk689/technologies_tech_note09186a0080094c52.shtml#vtp_ts_cav


HTH,Please rate if it does.

-amit singh


Craig Balfour Tue, 04/10/2007 - 02:25
User Badges:
  • Bronze, 100 points or more

What happens if you set the VTP mode to transparent and then back to client again on the four switches refusing to pick up the VLANs? This sometimes helps jump-start VTP.


Failing that, compare the output of show vtp status on the Catalyst 6509 and one of the switches which fails to get its VLANs.


Make sure that:

- Configuration Revision on the Catalyst 2970 is not higher than on Catalyst 6509. If the clients configuration revision is higher than the servers, the clients VLAN database won't be updated.


- VTP Operating Mode is set to Server on the Cat 6509 and Client on the Cat 2970


- VTP Domain Name matches on both switches


Also make sure that if you are using VTP passwords the password is the same on both ends, or if you are not using passwords that the password is not set on both sides. Use show vtp password to check this.



Please recheck the following:


1. Are you trunked between the switches you want to exchange VTP messages. Do a "show int trunk" command on the switches on both sides of the trunk.


2. Are you in the (exact) same VTP domain with the exact same password, if any - capitalization and spelling are critical. Do a "show vtp status" command.


3. You have to be running the same version of VTP (version 1 & 2 are incompatible. Most think they are running version 2, in fact they are running version 1 - you know because it says VTP V2 Mode: Disabled - this is the factory default. Where it says VTP Version 2 - that simply means you are V2 capable). This is usually not a problem because it is not changed (you would use V2 with token ring vlans). Do a "show vtp status" command.


Hope this helps


Rody

sridharpoola Wed, 04/18/2007 - 08:52
User Badges:

Thanks to all wo have replied. My problem is solved. Thanks again and your replies have been rated.!!!

Actions

This Discussion