Play music instead of ring tone when CAD in Reserved state

Answered Question
Apr 10th, 2007

Incoming call to a CSQ. An agent is available. Agent phone start ringing. Agent Desktop state change from Ready to Reserved. However, the caller hear music, not ring tone. When Agent pick up the phone, conversation can start properly. If the agent does not pickup the phone within timeout period, call is queued.

The music is from Music On Hold. My understanding is that the call terminated at one CTI port while waiting for the agent to pick up the phone. It seems that the ring tone is not passed to the caller. Instead the CTI port is in Call Hold state and music stream be passed to the caller.

Anyone knows how to pass the ring tone to caller?

Thanks

I have this problem too.
0 votes
Correct Answer by lpezj about 9 years 8 months ago

Hi,

When call is waiting for the agent answer, the caller hears the MoH set up for the CTI Ports managed by IPCC Express.

I had got the same problem in a customer and my solution was to configuere the MoH for the CTI Route Points with the 'wav' ringtone files in IPCC Express.

You will have to set up a new MoH source in Callmanager, create a new device pool for the IPCC Express CTI Ports and associate that Device Pool to the CTI Ports, or if you prefer you can set up in each CTI Port the new MoH.

Hope this helps,

Juan Luis

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
lpezj Tue, 04/10/2007 - 06:36

Hi,

When call is waiting for the agent answer, the caller hears the MoH set up for the CTI Ports managed by IPCC Express.

I had got the same problem in a customer and my solution was to configuere the MoH for the CTI Route Points with the 'wav' ringtone files in IPCC Express.

You will have to set up a new MoH source in Callmanager, create a new device pool for the IPCC Express CTI Ports and associate that Device Pool to the CTI Ports, or if you prefer you can set up in each CTI Port the new MoH.

Hope this helps,

Juan Luis

wenqianyu Tue, 04/10/2007 - 23:35

Thanks Juan,

I will check with Cisco to see if there is any settings to avoid this problem. I will post here if I can get anything back. If not, I will try your method.

Wenqian

wenqianyu Wed, 04/11/2007 - 20:02

Hi Juan,

Cisco's response about this issue was exactly the same as what you suggested. looks like that is the only option I have.

Thanks

lpezj Wed, 04/11/2007 - 23:10

Please, don't forget to rate helpful posts ;-).

Juan Luis

Actions

This Discussion