problems reverse telnetting

Unanswered Question
Apr 10th, 2007

I have a 2620 being used as a console server. I have an async 32A card in it with two octal cables connected to my deivces. When trying to reverse telnet to any of the lines, all I get is:

% Connection refused by remote host

Here is the configuration:

!

no network-clock-participate slot 1

no network-clock-participate wic 0

aaa new-model

!

!

aaa authentication password-prompt Local_Password:

aaa authentication username-prompt Local_Username:

aaa authentication login default group tacacs+ local

aaa authentication enable default group tacacs+ enable

aaa accounting update newinfo

aaa accounting exec default stop-only group tacacs+

aaa accounting commands 15 default stop-only group tacacs+

aaa session-id common

ip subnet-zero

ip cef

!

interface FastEthernet0/0

ip address 10.20.1.6 255.255.255.0

duplex auto

speed auto

!

interface Async1

no ip address

async default routing

async mode interactive

!

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 10.20.1.1

!

line con 0

line 1

modem InOut

transport input all

stopbits 1

speed 115200

flowcontrol hardware

line 33 64

no exec

transport input telnet

stopbits 1

line aux 0

line vty 0 4

exec-timeout 0 0

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
5aschulz Tue, 04/10/2007 - 10:26

Here is the output of show line:

DDRTS1001# sh line

Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int

0 CTY - - - - - 0 0 0/0 -

I 1 TTY 115200/115200- inout - - - 0 0 0/0 -

33 TTY 9600/9600 - - - - - 0 0 0/0 -

34 TTY 9600/9600 - - - - - 0 0 0/0 -

35 TTY 9600/9600 - - - - - 0 0 0/0 -

36 TTY 9600/9600 - - - - - 0 1 0/0 -

37 TTY 9600/9600 - - - - - 0 0 0/0 -

38 TTY 9600/9600 - - - - - 0 1 0/0 -

39 TTY 9600/9600 - - - - - 0 0 0/0 -

40 TTY 9600/9600 - - - - - 0 0 0/0 -

41 TTY 9600/9600 - - - - - 0 3 1/0 -

42 TTY 9600/9600 - - - - - 0 3 1/0 -

43 TTY 9600/9600 - - - - - 0 0 0/0 -

44 TTY 9600/9600 - - - - - 0 3 0/0 -

45 TTY 9600/9600 - - - - - 0 0 0/0 -

46 TTY 9600/9600 - - - - - 0 0 0/0 -

47 TTY 9600/9600 - - - - - 0 0 0/0 -

48 TTY 9600/9600 - - - - - 0 0 0/0 -

49 TTY 9600/9600 - - - - - 0 0 0/0 -

50 TTY 9600/9600 - - - - - 0 0 0/0 -

51 TTY 9600/9600 - - - - - 0 0 0/0 -

52 TTY 9600/9600 - - - - - 0 0 0/0 -

53 TTY 9600/9600 - - - - - 0 0 0/0 -

54 TTY 9600/9600 - - - - - 0 0 0/0 -

55 TTY 9600/9600 - - - - - 0 0 0/0 -

56 TTY 9600/9600 - - - - - 0 0 0/0 -

57 TTY 9600/9600 - - - - - 0 0 0/0 -

58 TTY 9600/9600 - - - - - 0 0 0/0 -

59 TTY 9600/9600 - - - - - 0 0 0/0 -

60 TTY 9600/9600 - - - - - 0 0 0/0 -

61 TTY 9600/9600 - - - - - 0 0 0/0 -

62 TTY 9600/9600 - - - - - 0 0 0/0 -

63 TTY 9600/9600 - - - - - 0 0 0/0 -

64 TTY 9600/9600 - - - - - 0 0 0/0 -

65 AUX 9600/9600 - - - - - 0 0 0/0 -

* 66 VTY - - - - - 3 0 0/0 -

67 VTY - - - - - 2 0 0/0 -

68 VTY - - - - - 0 0 0/0 -

69 VTY - - - - - 0 0 0/0 -

70 VTY - - - - - 0 0 0/0 -

Line(s) not in async mode -or- with no hardware support:

2-32

What am I missing??

scottmac Tue, 04/10/2007 - 10:36

You can probably lose the "flowcontrol hardware" statement: Most devices (other than modems, and virtually all Cisco gear does not use hardware handshake (no handshake at all most of the time).

The "refused" message is likely because the harware handshake is not happening (the TermServ thinks the client is refusing the connection because it can't raise the handshake line).

Modems and connections to AUX ports will use the hardware handshake.

Give it a hot and let us know.

Good Luck

Scott

5aschulz Tue, 04/10/2007 - 12:15

the flowcontrol statement is on line 1 which is a modem. The lines 33 to 64 are the async lines I'm using for the console connections and I do not have that configured for those lines.

Actions

This Discussion