Internal WIC-1AM Modem

Unanswered Question
Apr 10th, 2007

We have gone with the WIC-1AM modem module for our console routers. However, upon dialing in, I get a quick hangup by the WIC-1AM, debugs show the following:

*Apr 10 08:35:29.775: Modem (0/0) DCD Asserted

*Apr 10 08:35:29.799: Modem (0/0) DCD UnAsserted

My config is here:

router#sh run | begin line aux 0

line aux 0

exec-timeout 30 0

password 7 XXXXXXXX

script reset sportster

login authentication modem

modem Dialin

modem autoconfigure discovery

transport input all

stopbits 1

speed 300

flowcontrol hardware

line 0/0/0

stopbits 1

speed 115200

flowcontrol hardware

Thanks in advance for any suggestions!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
zahmed Wed, 04/11/2007 - 21:27

Hi Dan,

WIC-xAMs are sensitive to line voltage. So you might want to try a different phone line on it and see how that works.

By the way, if you are reverse-telnetted into the WIC, and now you dial in, do you see RING ?

Also try to dialout from reverse-telnet mode and see if that works.

Thanks and Regards,

~Zulfiqar

dasmith Thu, 04/12/2007 - 04:40

Thanks for reply. I was able to do as you suggested, using atdt command to dial my desk phone, and observed RING, when an incoming call was placed. Still investigating, but no progress yet.

dasmith Thu, 04/12/2007 - 04:55

I went to another router with WIC-1AM installed and performed a 'debug modem' on that device while attempting a dial in. Here is what I collected:

Apr 12 08:51:18.318: Modem (0/2) DCD Asserted

Apr 12 08:51:18.658: TTY0/2/0: DSR came up

Apr 12 08:51:18.658: Modem 0/2/0 WIC-AM: in modem state 'Connect'

dte = modulation= Unkn protocol = compression_type = NONE tx_speed = rx_speed =

Apr 12 08:51:19.657: tty0/2/0: Modem: IDLE->(unknown)

Apr 12 08:51:19.661: TTY0/2/0: EXEC creation

Apr 12 08:51:19.677: TTY0/2/0: create timer type 10, 30 seconds

Apr 12 08:51:19.709: Modem (0/2) CTS UnAsserted

Apr 12 08:51:19.749: Modem (0/2) CTS Asserted

Apr 12 08:51:19.765: Modem (0/2) CTS UnAsserted

Apr 12 08:51:19.801: Modem (0/2) CTS Asserted

Apr 12 08:51:23.965: Modem (0/2) DCD UnAsserted

Apr 12 08:51:24.657: TTY0/2/0: DSR was dropped

Apr 12 08:51:24.657: TTY0/2/0: Quickly dropping DTR

Apr 12 08:51:24.657: tty0/2/0: Modem: READY->HASPROC

Apr 12 08:51:24.657: TTY0/2/0: pause timer type 10 (OK)

Apr 12 08:51:26.657: TTY0/2/0: Line reset by "Exec"

Apr 12 08:51:26.657: CHAT0/2/0: Attempting line reset script

Apr 12 08:51:26.657: CHAT0/2/0: Asserting DTR

Apr 12 08:51:26.657: TTY0/2/0: Modem: HASPROC->HANGUP

Apr 12 08:51:26.657: TTY0/2/0: no timer type 0 to destroy

Apr 12 08:51:26.657: TTY0/2/0: no timer type 1 to destroy

Apr 12 08:51:26.657: TTY0/2/0: no timer type 3 to destroy

Apr 12 08:51:26.657: TTY0/2/0: no timer type 4 to destroy

Apr 12 08:51:26.657: TTY0/2/0: destroy timer type 10

Apr 12 08:51:26.657: TTY0/2/0: no timer type 2 to destroy

Apr 12 08:51:27.657: TTY0/2/0: dropping DTR, hanging up

Apr 12 08:51:27.657: tty0/2/0: Modem: HANGUP->IDLE

Apr 12 08:51:29.656: TTY0/2/0: restoring DTR

Apr 12 08:51:29.656: TTY0/2/0: Modem get info started

Apr 12 08:51:32.164: TTY0/2/0: Modem: ATS86? -> 021OK

Apr 12 08:51:34.764: TTY0/2/0: Modem: ATZ -> OK

Apr 12 08:51:36.748: TTY0/2/0: Modem: AT&F\V1S0=1 -> NO CARRIER

The 'Unkn protocol' at the top may be the key.

Actions

This Discussion