Having problems adding 3750 stacks into LMS 2.5.1 Common Services

Answered Question
Apr 10th, 2007


I'm having some issues adding stacks into the CS inventory.

I've looked at the documentation for it, but it is pretty vague. Basically I need some pointers on how to get these implemented correctly. I'll try to explain it as clear as I can.

For example I have one stack with 3 switches (called Switch-A (master), Switch-B and Switch-C in this example). Since these are 3750's (WS-C3750-24P

to be exact) with the Stackwise backplane cables, they only have one IP address for the entire stack.

I've tried creating the Device Type: Cisco Cluster Management Suite, naming it Switch-A Cluster, and giving it proper hostname (Switch-A in DNS), IP, and credentials.

Then I'd try creating Switch A as a Cluster Managed Switch. Display Name is Switch-A, I specify Switch-A Cluster as the cluster, and member number 1 (stack master). I leave everything else blank (can't enter the IP address as it'll come up with an error saying it's already being used (Switch-A Cluster)).

When I save, and check the inventory - it doesn't get collected. When I try looking at Device Center for 'Switch-A' (not Switch-A Cluster), it says "Failed as HostName and IP Address not configured in DCA" beside Device IP Address. This happens when I configure Switch-B and Switch-C as well (member numbers 2 and 3, respectively).

So that's my predicament. I checked the forums for any previous problems like this and found one, but I had misplaced the link - either way there was no resolution found for it.

Would anyone be able to point me in the right direction please? I hope it's not just that these switches aren't supported.

Thanks in advance.

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 9 years 6 months ago

LMS 2.6 is a free downloadable update from 2.5.1 (see http://www.cisco.com/cgi-bin/tablebuild.pl/lms26). LMS 2.6 is really more like 2.5.2.

However, this bug is not fixed in LMS 2.6. But after you upgrade to 2.6, the TAC can provide my patch which will fix this problem.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Joe Clarke Tue, 04/10/2007 - 17:20

Adding the stack is easy. First, add a Standard device with device type of "Cisco Cluster Management Suite". This "device" should have the IP address and hostname of your cluster. Give it a display name of something like "3750 Switch Cluster". Next, add a Cluster Managed device to DCR. This device should have the display name of Switch-A, member number of 0, and Cluster of "3750 Switch Cluster". Repeat this process for Switch-B and Switch-C (Switch-B will have member number 1 and Switch-C member number 2).

That will get your cluster correctly added to DCR. Then starts the bad news. I filed a bug, CSCsg50511 that cluster managed devices do not get their inventory collected. The good news is, I wrote a patch for it that is available by opening a service request with TAC.

jpeterson6 Wed, 04/11/2007 - 05:59

Alright, so the only thing I did differently was starting the member number at 1 instead of 0.

I'm still getting the same error though in Device Center, or is that the actual bug where it's looking for an IP address on the devices within the stack?

Joe Clarke Wed, 04/11/2007 - 06:17

You can only open the device with the IP address in Device Center. So you will need to open the cluster itself, and not the individual devices.

jpeterson6 Wed, 04/11/2007 - 10:09

Do you know if this bug is fixed for LMS 2.6?

We're looking into upgrading to that but have yet to find any viable reasoning behind it since we will have to purchase a new license.


This Discussion