Seeing error message in log of a 2801 running 12.4(7)

Unanswered Question
Apr 11th, 2007

%C5510-1-NO_RING_DESCRIPTORS: No more ring descriptors available on slot 0 dsp 1.

version is 12.4(7)

FOund 2 bugs with no work around, CSCsq12931 or CSCsh63265

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Paolo Bevilacqua Wed, 04/11/2007 - 09:05


Can't find the first bug mentioned, and second is "unreproducible" (that doesn't mean it isn't very real).

I would upgrade the router to latest 12.4 before contacting the TAC.

Aaron Harrison Wed, 04/18/2007 - 01:25

I've seen this error a few times - can you post sh diag and configuration?


johnnylingo Fri, 04/20/2007 - 14:52

Same thing there. 2821 w/ IOS 12.4(7e) and also 12.4(9)T3. It seems to happen a lot more with 12.4(9)T3, and results in the MGCP PRI being reset. Never saw these until starting to convert over from MGCP to H.323 and moved from IOS 12.3(11)T10.

What protocol are you using?

Tim Smith Wed, 01/23/2008 - 12:14

Hi Johnny,

Seeing the same thing on 12.4(3g) 3845..


All the other circuits on the box are working fine.

We see a DSP crash error message then the router reloads the dsp and restarts the voice port.

I'm suspecting hardware, but did you get any further with your investigation?



Paolo Bevilacqua Wed, 01/23/2008 - 14:01

If you are willing to continue in "good IOS hunting", try 12.4(3j), or 12.4(11)XJ4. Both are know to have stable ISDN, although admittedly MGCP is a different beast.


This Discussion