CallerID Outbound to PSTN

Unanswered Question

We have a PRI for our trunk to the PSTN. It seems that whenever anyone calls out from any IP Phone to the PSTN the number that shows up on the recipients call display is the primary number of our T1 trunk. I want to override this so that the DID number associated with individual IP phones is the number that is displayed at the recipients phone on the PSTN when they have call display.

I have filled in the "External Phone Number Mask" field in the "Line Settings for this Device" section of the IP Phone configuration but it does not seem to work.

My Route Patterns are all configured such that the "Use Calling Party's External Phone Number Mask" is checked off.

Is there some other place I should be looking or am I missing something?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
paolo bevilacqua Wed, 04/11/2007 - 08:33
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member


are you using H.323 or MGCP ? if the first, on the router please do "term mon" and "debug isdn q931", if the latter, "term mon" and "debug mgcp packet". This will show which calling number are you actually sending for the call.

thisisshanky Wed, 04/11/2007 - 08:51
User Badges:
  • Purple, 4500 points or more

If phones are using Ext ph mask then you should select the Use ext pask in route pattern or if using route lists, you should set the Calling party mask to Default or On. Remember to manipulate outbound caller id either at

a. route pattern level

b. or at route list level.

Definitely dont do the manipulation at route pattern and route list level. (Also route list level overrides the route pattern setting).

user-cisco Wed, 04/11/2007 - 12:08
User Badges:

hi guys

what if i want all my internal ip phones when calling pstn to appear on the called party display with just one number, i read that this could be accomplished by specifying the unique number in the caller DN field under the gateway configuration in ccm i did this but the number did not appear, i think there is something missing can someone help in this regard


jbarcena Wed, 04/11/2007 - 11:44
User Badges:
  • Red, 2250 points or more

Please see below the places in callmanager administration where you can configure caller ID:


1) "Directory Number Configuration" page.

Scroll down to "External Phone Number Mask". Enter here the number that you want to send to the PSTN. Then click on "update" at the top of the page. You have to repeat this same procedure for the other extensions configured for this IP Phone (if you want to send those numbers also to the PSTN).


2) "Route Pattern Configuration" page.

Locate the route pattern that you are using for doing calls to the PSTN.

Scroll down to the "Calling Party Transformations" section.

- If you check the "Use Calling Party's External Phone Number Mask" checkbox, you will use the number that you configured in the "Directory Number Configuration" page as caller ID.

- If you uncheck that checkbox, then you can configure the "Calling Party Transform Mask". Just enter here a number like, as an example, 978858xxxx (callmanager will fill out the xxxx with phone's 4-digit extension).


3) "Route List Detail Configuration" page.

Go to the "Calling Party Transformations" section.

"Use Calling Party's External Phone Number Mask" > if you set it to "on", you will use the number that you configured in the "Directory Number Configuration" page as caller ID. If you set it to "off", then you need to configure the "Calling Party Transform Mask" (next line on this same page). The setting that you use here will override the settings that you configured in the "Route Pattern Configuration" page.

You configure the "Calling Party Transform Mask" here in the same way as explained for the "Route Pattern Configuration" page.


4) "Gateway Configuration" page.

Go to the Gateway and select the PRI that you are using for outgoing calls. Under 'Outbound Calls' you should see the Caller ID DN field. In here you can configure also the Caller ID.


In other words Caller ID works as follows:

- Gateway configuration overrides everything else.

- Route List configuration overrides the Route Pattern and the Directory Number Configuration.

- Route Pattern overrides only the Directory Number configuration.

user-cisco Wed, 04/11/2007 - 12:22
User Badges:

thanks jbarcena for this really nice clarification but i have read somewhere that u need additionally to require from the pstn carrier to activate this feature (to appear outside as unique number) i actually added caller id number under pri gateway config in ccm but it did not take effect i mean the number i specified did not appear in the called party display

do u have any idea

jbarcena Wed, 04/11/2007 - 12:32
User Badges:
  • Red, 2250 points or more

You need to take a CCM detailed trace on the server were the phone is registered and also were the GW is registered to track the call and see if the q931CallingIE that we are sending is the digits that you want then you can take a debug isdn q931 on the GW to see also if the GW sends the correct caller ID to the Telco, if yes, then Telco is overriding the information.

5mgagnon Tue, 08/21/2007 - 19:13
User Badges:

Great answer, however, Cisco must be planning to implement the same kind of "feature" for the calling name. As this causing issues for most of my customer, that want to have their compagny name appear for all call.

jsailers Mon, 09/17/2007 - 04:54
User Badges:

Calling Name is a different beast of it's own. Even if CallManager did allow you to specify and override the Calling name value, you would still have issues with support of this feature on the PSTN.

At this point in time, it is typically best to work with your telco provider to add listings to the National Listings Database. Our provider, Qwest, allows us to specify the Caller ID name associated with a specific phone number for this very reason. This isn't anything we do with CallManager, but a form we submit to the telco.

5mgagnon Sat, 09/29/2007 - 10:48
User Badges:

I understand. but this is only availaible with Ni2 protocol. And here in Canada, None of the provider have the NLD implemented.

This is a service we asked for.


This Discussion