Failover over to another H.323 Gateway when all lines busy

Answered Question
Apr 12th, 2007

I have two H.323 Gateways setup, both with VIC-4FXO cards, working fine. What I'd like to do is if all 4 POTS lines on Gateway A is filled up, route the call to Gateway B and vice-versa. It's my understanding that with H.323, CallManager is unable to detect when a port or trunk-ground is full, so it must be handled through dial-peers on the Gateway itself via a higher preference.

With this config, the calls route to alternate gateway correctly and the call dials out, but drop as soon as the remote side answers. It looks like the are failing to properly negotiate a codec. Suggestions?

Gateway A:

voice service voip

allow-connections h323 to h323

h323

no h225 timeout keepalive

session transport udp

!

!

!

voice class codec 711

codec preference 1 g711ulaw

codec preference 2 g729r8

!

interface GigabitEthernet0/0

ip address 1.2.3.4 255.255.255.0

h323-gateway voip interface

h323-gateway voip h323-id VG-1

h323-gateway voip bind srcaddr 1.2.3.4

!

dial-peer voice 1 voip

incoming called-number .

!

dial-peer voice 100 pots

trunkgroup POTS

description Outbound calls

destination-pattern .T

!

dial-peer voice 101 voip

description Outbound Calls Overflow

preference 1

destination-pattern .T

voice-class codec 711

session target ipv4:5.6.7.8

!

Gateway B:

voice service voip

allow-connections h323 to h323

h323

no h225 timeout keepalive

session transport udp

!

!

!

voice class codec 711

codec preference 1 g711ulaw

codec preference 2 g729r8

!

interface GigabitEthernet0/0

ip address 5.6.7.8 255.255.255.0

h323-gateway voip interface

h323-gateway voip h323-id VG-2

h323-gateway voip bind srcaddr 5.6.7.8

!

dial-peer voice 1 voip

incoming called-number .

!

dial-peer voice 100 pots

trunkgroup POTS

description Outbound calls

destination-pattern .T

!

dial-peer voice 101 voip

description Outbound Calls Overflow

preference 1

destination-pattern .T

voice-class codec 711

session target ipv4:1.2.3.4

!

I have this problem too.
0 votes
Correct Answer by Aaron Harrison about 9 years 7 months ago

Hi

There are simpler ways to do this...

One is to edit the callmanager service parameters 'stop routing on user busy' and 'stop routing on unallocated number'. The gateway sends back one of these messages when it can't route the call, and by default callmanager will stop hunting at that.

Regards

Aaron

Please rate helpful posts...

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (2 ratings)
Loading.
Paolo Bevilacqua Thu, 04/12/2007 - 15:32

Hi Johnny,

when the call comes in and the GW A is full, it should redirect to the other GW, not take the call. I don't know how to configure this, perhaps with a GK and CAC, or with max-connections and preferences on the calling GW.

On the other hand, if GW A takes the call and open another call-leg to GW vi VoIP, this is effectively an IP-to-IP call that requires such an image, filename ends with _isv.

Fianlly since yuor DP 1 seems to be the incoming one, I would configure the same voice-class under it.

johnnylingo Thu, 04/12/2007 - 16:15

Well, according to the GWGK book, it is expected that overflow be configured on the Gateway, and the line "allow-connections h323 to h323" does this in my config. Calls seem to be re-routing to the backup gateway properly, but somethings's getting messed up in either the codec negotiation or routing. Both Gateways are running 12.3(11)T10

I added the following:

dial-peer voice 1 voip

codec transparent

no vad

!

That caused the incoming calls to use G711 and no VAD (they had been using G729/w VAD), but still having the same problem. They connect, but the remote gateway never negotiates a Codec and the call drops.

Correct Answer
Aaron Harrison Fri, 04/13/2007 - 00:32

Hi

There are simpler ways to do this...

One is to edit the callmanager service parameters 'stop routing on user busy' and 'stop routing on unallocated number'. The gateway sends back one of these messages when it can't route the call, and by default callmanager will stop hunting at that.

Regards

Aaron

Please rate helpful posts...

johnnylingo Fri, 04/13/2007 - 12:27

Yep, those are the default settings in CCM 4.1 and I haven't changed them.

It seems that the book is a little off. On page 64, it says that if a PRI line on an H.323 gateway is full, CallManager will not redirect it to an alternate gateway so you must create a dial-peer with higher preference value. This doesn't appear to be true. I created a Route Group with both gateways, and when one filled up it rolled over to the next no problem.

Paolo Bevilacqua Fri, 04/13/2007 - 01:53

Hi,

Yes "codec transparent" is what usually is needed in IP-to-IP calls. But you have to define it in both incoming and outgoing DPs.

Other than that I would upgrade IOS perhaps to lates 12.4 mainline.

Hope this helps, if so please rate post!

Actions

This Discussion