virtual templates

Unanswered Question
Apr 12th, 2007
User Badges:

we have a 3845 cisco router , we are using 2 virtual templates (we are using ppp over frame relay)interfaces to bundle our internet and vpn connection .

the internet virtual template is bundling 8 serial interfaces , and it is working fine .


the vpn virtual template is bundling 4 serial interfaces (we are using ppp over frame relay ) , the output traffic from the router is load balanced but there is a problem in load balancing the input traffic to the router , the input traffic is on one serial interface and no traffic on the other 3 serial interfaces , when trying to use another router for the vpn virtual template it works fine and the input traffic is load balanced , is there a problem to have multiple virtual templates on the same router



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
amitpalsinghbatra Thu, 04/12/2007 - 19:44
User Badges:

the outbound load balancing is easy to achieve . CEf automatically takes care of that. but inbound is pretty tough. coz when u send a request its outbound . load balanced. but response can be very big file. example downloads.


if both routers r in ur control try enabling ip cef per packet.


hope that helps u.


regards


royalblues Fri, 04/13/2007 - 02:27
User Badges:
  • Green, 3000 points or more

A better way to do this would be to create multilink interfaces and make these virtual templates part of the multilink.


We have this setup in our network and the load is balanced more or less equally


regards

Narayan

mostafaammar Fri, 04/13/2007 - 04:57
User Badges:

Dear royalblues ,


thx for ur fast reply ,may you verify that the following configuration are correct ( correct me if i am wrong ), i am configuring 2 multilink interfaces one for internet and the other for the vpn .

should i configure frame-relay traffic shapping under the serial interfaces ?

should i configure ip cef per packet on my router and the service provider router ?

configuration :


! the internet virtual template

interface virtual-template 1

description internet virtual template

no ip address

ppp multilink group 1

ppp multilink fragment delay 20

ppp multilink interleave

end


! internet multilink interface

interface multilink 1

description internet multilink group

ip address ip-address mask [secondary]

ppp multilink fragment delay 20

ppp multilink interleave


!vpn virtual template

interface virtual-template 2

description vpn virtual template

no ip address

ppp multilink group 2

ppp multilink fragment delay 20

ppp multilink interleave


!vpn multilink interface

interface multilink 2

description vpn multilink group

ip address ip-address mask [secondary]

ppp multilink fragment delay 20

ppp multilink interleave


!internet serial interface

inter serial 0/1/0

description internet

no ip address

encapsulation frame-relay

frame-relay lmi-type q933a


interface serial 0/1/0.1

ip address

frame-relay interface-dlci 16 ppp Virtual-Template1


!vpn serial interface

inter serial 0/2/0

description vpn

no ip address

encapsulation frame-relay

frame-relay lmi-type q933a


interface serial 0/1/0.1

ip address

frame-relay interface-dlci 16 ppp Virtual-Template2





royalblues Fri, 04/13/2007 - 06:12
User Badges:
  • Green, 3000 points or more

Using per packet will give you equal load sharing of the links but if the latencies across these links differ then packets can arrive out of sequence at the other end


Here's a sample config i have


interface Serial0/0/0:0

bandwidth 1536

no ip address

encapsulation frame-relay IETF

keepalive 1

frame-relay lmi-type ansi

!

interface Serial0/0/0:0.1 point-to-point frame-relay interface-dlci 755 ppp Virtual-Template1



!

interface Serial0/0/1:0

bandwidth 1536

no ip address

encapsulation frame-relay IETF

keepalive 1

frame-relay lmi-type ansi

!

interface Serial0/0/1:0.1 point-to-point

bandwidth 1536

keepalive 1

no cdp enable

frame-relay interface-dlci 312 ppp Virtual-Template2



!

interface Serial0/1/0:0 bandwidth 1536

no ip address

encapsulation frame-relay IETF

load-interval 30

keepalive 1

frame-relay lmi-type ansi

!

interface Serial0/1/0:0.1 point-to-point keepalive 1

no cdp enable

frame-relay interface-dlci 555 ppp Virtual-Template3


interface Virtual-Template1

bandwidth 1536

no ip address

keepalive 1

ppp multilink

ppp multilink group 1

!

interface Virtual-Template2

bandwidth 1536

no ip address

keepalive 1

ppp multilink

ppp multilink group 1

!

interface Virtual-Template3

bandwidth 1536

no ip address

keepalive 1

ppp multilink

ppp multilink group 1


interface Multilink1

ip address 172.16.2.13 255.255.255.252 load-interval 30

keepalive 1

no cdp enable

ppp multilink

ppp multilink group 1


HTH, rate if it does

Narayan

amitpalsinghbatra Sat, 04/14/2007 - 03:16
User Badges:

my dear friends,


ppp multilink will not help the inbound load balancing.since ur u have configured ppp multilink means that ISP end is also configured for the same. so if possible get ur isp to configure the ip cef per packet.


outbound will be load balanced from ur end inbound will be load balanced by ISP..


hope this help.


regards

mostafaammar Sun, 04/15/2007 - 03:41
User Badges:

Dear All ,


when using virtual templates , can i bundle more than one serial interface to the same virtual template or every serial interface should be bundled to one virtual template interface ?

amitpalsinghbatra Sun, 04/15/2007 - 13:09
User Badges:

hi,


if you wanna bundle serial links use ppp multilink and interface multilink. rather than using virtual template.


regards


royalblues Sun, 04/15/2007 - 21:20
User Badges:
  • Green, 3000 points or more

Mostafa,


You can associate serial links to the same virtual interface. It is possible to do that. But it is always recommended to have each of serial links associated with a different virtual template.


Amit, you cannot use normal PPP multilink when you have a frame-relay cloud. you have to either configure MFR or MLPPoFR which will introduce virtual templeates


HTH, rate if it does

Narayan

mohammedmahmoud Mon, 04/16/2007 - 07:32
User Badges:
  • Green, 3000 points or more

Hi Amit,


Please allow me to interrupt and ask a question here, what is the reason behind preferring interface multilink over using virtual-template with ppp multilink configuration ?


Thanks in advance,

Mohammed Mahmoud.



mostafaammar Thu, 04/19/2007 - 01:18
User Badges:

Hi Mohamed ,


the interface virtual template is always down down (however it is working )and it creates virtual access interfaces for every serial interface bundled and 2 more virtual access interfaces than the serial interfaces .these 2 virtual access interfaces one for management of the bundle and the other one is for aggregating the links . the multilink interface aggregates the traffic itself so when u issue the command show interface multilink 1 u see the aggregated bandwidth of the bundle . and it is up u so u can track the interface and use a backup interface .


best regards,


Mostafa Ammar

Actions

This Discussion