Enabling cdp on GRE tunnel..

Unanswered Question
Apr 13th, 2007
User Badges:

Hi,

I am issuing the command "cdp enable" on tunnel interface of routers. On some of the routers its accepting the command and I can see it in the "sh run" but on some of the routers its giving the error "% CDP is not supported on this interface, or for this encapsulation". I have checked the encapsulation on every gre tunnel interface and its "tunnel" no matter cdp can be enabled or no. Pls help me to know why am I getting this error. Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.9 (9 ratings)
Loading.
paolo bevilacqua Sat, 04/14/2007 - 02:57
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Sorry, you can't have CDP on GRE.

CDP is not IP hence cannot be carried by GRE.


Hope this helps, if so please rate post!

Edison Ortiz Sat, 04/14/2007 - 15:38
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

CDP only runs over Layer2 interfaces, in other words, physical interfaces.


A GRE tunnel is a logical interface hence the lack of support for this feature/service.

minumathur Sun, 04/15/2007 - 13:34
User Badges:
  • Bronze, 100 points or more

Hi


i agree with your point, i have check up in 7200 serial router , in tunnel configuration, cdp enable is there , but unfortunely my envirement is live , so i could not try too much , but atleast i can say in 7200 series router, this feature is available, may be other router do not have this feature.


i hope this will help , please rate this post.


-Minu

paolo bevilacqua Sun, 04/15/2007 - 14:24
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

The fact that you can configure cdp under a tunnel interface does not mean it will work, for the reasons explained above.

In IOS there are many commands that are configurable, but without effect and no warning is given.


Richard Burts Sun, 04/15/2007 - 16:12
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 LAN, WAN

Paolo


Your logic sounds convincing and used to be true but is in fact not correct any longer. It is a release dependent behavior. I have a lot of routers running 12.3T code and 12.4 code that are successfully running CDP over GRE tunnels. I am confident that if Syed will look at the routers where it works (is accepted) and the ones where it does not work (is not accepted) that he will find differences in the versions of code.


I speak from direct personal experience when I say that in at least some versions of code that CDP does work over GRE tunnels.


HTH


Rick

royalblues Mon, 04/16/2007 - 01:18
User Badges:
  • Green, 3000 points or more

Rick is right.


I did a quick test to find this out.


The CDP does not show any information when i run a GRE tunnel between a ISR and a 2621XM router. There is no support for the smae


MS_VTR_PUN_R01(config)#int tunnel 3

MS_VTR_PUN_R01(config-if)#cd

MS_VTR_PUN_R01(config-if)#cdp en

MS_VTR_PUN_R01(config-if)#cdp enable

% CDP is not supported on this interface, or for this encapsulation


But when i tried the same between 2 ISR 2811 routers it does work


MS_M6_MPLS_TATA#sh cdp neighbors

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

S - Switch, H - Host, I - IGMP, r - Repeater


Device ID Local Intrfce Holdtme Capability Platform Port ID

M5 Tunnel0 176 R S I 2811 Tunnel0


Interface are shown as tunnel 0


Narayan


Please rate useful posts


paolo bevilacqua Mon, 04/16/2007 - 02:38
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Good to know, so it appears this feature has been added at some point in IOS. Certainly it does not depend by the hardware.

Thanks to those that have pointed out and tried.

royalblues Mon, 04/16/2007 - 03:06
User Badges:
  • Green, 3000 points or more

Even i didn't knew about it


Rick deserves a rating.


Narayan

royalblues Mon, 04/16/2007 - 06:47
User Badges:
  • Green, 3000 points or more

Thanks harold.


Ya i got to know that only when tried configuring it


Narayan

Harold Ritter Mon, 04/16/2007 - 06:34
User Badges:
  • Cisco Employee,

Before CSCec01500, configuring CDP on a tunnel interface would lead to the following message:


RouterC(config-if)#cdp enable

% CDP is not supported on this interface, or for this encapsulation



Hope this helps,

Actions

This Discussion