Echo on IP Phone through PRI

Unanswered Question
Apr 16th, 2007

We are getting sporadic issues from users on IP phones who are hearing echo on external calls. From this document is would suggest that echo on IP Phones is caused by hybrid echo and not any local acoustic echo.


http://www.cisco.com/warp/public/788/voice-qos/echo_ipphone_gateway.html


The MGCP-controlled voice gateways are all running 12.3(14)T7 with DSP firmware 4.4.708. In CallManager (4.1(3)SR2), echo cancellation is on for each port, with a "default" echo cancellation coverage of 64ms. Input gain and output attenuation are set to 0dB.


I have seen suggestions to include the "echo-cancel erl worst-case 3" command on the voice ports. Can this help in situations of occasional echo?


Are there any other parameters changes which could help? Could it be a code/DSP firmware issue? I haven't found a specific echo-related bug relating to this particular IOS and its embedded DSP firmware.




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mmelbourne Mon, 04/16/2007 - 13:00

Thanks. What's your thinking behind this? We have had one report of echo where the user on the IP phone hears their own voice, and the echo started about a minute into the call; it was fine to begin with.

Hieu Cao Mon, 04/16/2007 - 16:51

From Cisco "Use the echo-cancel coverage command to adjust the coverage size of the EC. This command enables cancellation of voice that is sent out the interface and received on the same interface within the configured amount of time. If the local loop (the distance from the interface to the connected equipment that is producing the echo) is greater than this amount of time, the configured value of this command should be increased.


If you configure a greater value for this command, the EC takes longer to converge. In this case, you might hear a slight echo when the connection is initially set up. If the configured value for this command is too short, you might hear some echo for the duration of the call because the EC is not canceling the longer delay echoes.


See the commands info from this link.

http://www.cisco.com/en/US/products/sw/iosswrel/ps1839/products_command_reference_chapter09186a00800b3502.html#wp998290


My routers have the echo-cancel coverage set at 24 and it's been working fine for quite sometime... you might want to try a different setting from the default to see how it works out in your enviroment.


You might want to check out this document.

http://www.cisco.com/en/US/tech/tk652/tk698/technologies_tech_note09186a0080149a1f.shtml#ipphoneecho


good luck.

hieu



John Tan Thu, 05/17/2007 - 12:33

Hi I am running into the same issue with you. Echo with this IOS. Did you find out what is wrong? i am thinking more of a DSP firmware issue with CSCsd54344 Bug . Although the bugs says first found in 12.4(7).


mmelbourne Thu, 05/17/2007 - 14:33

I have upgraded all our voice gateways to 12.4(13b) which includes DSPware 4.4.24 which is a fixed version according to CSCsd54344. We were running DSPware 4.4.7(08) as part of IOS 12.3(14)T. We haven't had any further reports of echo but it's still probably too early to say that the problem has been fixed as the original echo problem was intermittent.


I have also added the command "echo-cancel erl worst-case 3" to the voice ports.


Please rate helpful posts.

Actions

This Discussion