Hot Standby/Load Balancing for Internet using HSRP

Unanswered Question
Apr 16th, 2007
User Badges:
  • Silver, 250 points or more

Hi,

juz got an idea, having 2 different routerz, each routerz pointing to 2 different ISP's & configured HSRP on to it, so will it work fine i mean load balance & hot standby, even if 1 router failz, still the otherz routerz routez the internet packetz?

----------------------------------------------

Router-A

interface serial 0/1

description Connected to ISP-1

ip address x.x.x.x 255.255.255.252


interface ethernet 0/1

no ip address


interface ethernet 0/1.1

encapsulation dot1q 1

ip address 192.168.1.1 255.255.255.0

standby 2 ip 192.168.1.254

standby 2 preempt

standby 2 priority 109

standby 2 timers 5 15


ip route 0.0.0.0 0.0.0.0 serial 0/1


Router-B

interface serial 0/1

description Connected to ISP-2

ip address x.x.x.x 255.255.255.252


interface ethernet 0/1

no ip address


interface ethernet 0/1

encapsulation dot1q 1

ip address 192.168.1.2 255.255.255.0

standby 2 ip 192.168.1.254

standby 2 preempt

standby 2 priority 108

standby 2 timers 5 15


ip route 0.0.0.0 0.0.0.0 serial 0/1

----------------------------------------------


ofcourse all the workstationz will be having their gateway IP address 192.168.1.254 which is the virtual gateway IP address.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Anand Narayana Mon, 04/16/2007 - 23:33
User Badges:
  • Silver, 250 points or more

thankz prem,

but if i want to achieve the load balancing, the only possibility is through PBR isn't?

regarding NAT ofcourse i require that, which i forgot to type that.

nsirin Mon, 04/16/2007 - 23:46
User Badges:

hi it's impossible. When you connect two diffrent ISP , it means you connect two diffrent AS. Each ISP has own real ip blocks and if you want to connect internet from ISP-1 you have to use one of ISP-1 registered ip address. In this scenerio you use one local ip block (it is private block but you can't use it on internet even if you use NAT your lan must be in same subnet).

Anand Narayana Mon, 04/16/2007 - 23:50
User Badges:
  • Silver, 250 points or more

Hi NSIRIN,

it is possible as this workz according to the priority, bcoz not 2 routerz r going 2 route the packetz at a time. only when you say a static NAT ofcourse it might be a probz. but not for redundancy.


but my question is, i wanted load balancing where the internet should be used with both the ISP's.

spremkumar Tue, 04/17/2007 - 00:23
User Badges:
  • Red, 2250 points or more

hi


I didnt look at the word 2 different isp as mentioned in your first post yes its possible to have 2 different overload statements riding with 2 different default gateways in your router but you can have outgoing load distributed on both the links but the incoming traffic may not be that evenly distributed in nature.


Because of the same you may experience performance degradation too which we have tested in few cases..


regds


Anand Narayana Tue, 04/17/2007 - 00:27
User Badges:
  • Silver, 250 points or more

thankz prem once again,

can you juz post a sample configuration, so that i can under clearly.

Actions

This Discussion