problem with pix console connection

Unanswered Question
Apr 17th, 2007


I?ve got a pix appliance that was used by the students in our company. Unfortunately now I can?t connect to it via the console port. No mather what I press there is nothing showing on the console.

Please, let me know if there is any command by which you can restrict access to the console port (e.g. you have to press some key to see the console output).

Thanks in advance

Best regards


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
baydata Tue, 04/17/2007 - 02:14

As per my knowledge there are no such shortcut key are available in cisco pix



Bay DataCom Solutions pvt., Ltd.

mwardinterpub Tue, 04/17/2007 - 07:59


It is best practices NEVER to allow clear text access to your PIX, even in a learning environment.

You will have to create a local AAA database with usernames and passwords, generate a rsa-key, and only allow ssh access from a confirmed PC and or terminal interface.

You can use the folowing configuration:


crypto key generate rsa modulus modulus_size

interface Ethernet0

nameif outside

security-level 0

ip address


interface Ethernet1

nameif inside

security-level 100

ip address

username ciscouserstudent password xxx

aaa authentication ssh console LOCAL

ssh outside

ssh inside

ssh timeout 60

lukaszkhalil Tue, 04/17/2007 - 22:42


I believe you misunderstood me. I agree with you that it is good practice to secure the communication even in the lab environment, but in my case I was`t necessary.

The students practiced on the stand-alone box. Now I need to use this appliance in different place with new configuration but I can?t connect via console port.



mark.hodge Tue, 04/17/2007 - 08:44

1st Check your hyperterminal ( or whatever ) and cable works on an other device.

2nd Connect to the console port and reboot the PIX, see if the POST and boot sequence is visible.

lukaszkhalil Tue, 04/17/2007 - 22:26

Hello Mark

1)I`ve already checked the cable and the terminal software and it worked.

2)When I reboot the PIX there is no POST information showing on the terminal.

What is why i suspect one of two issues:

A) the console port failure

B) something that is blocking access to the console port

mark.hodge Wed, 04/18/2007 - 05:18

As far as I know there is nothing that can be done in the config that will stop POST displaying on the console port.

Therefore I would say this is a hardware issue, sorry.


This Discussion