H.323 Gateway on CCM 4.2(3)

Unanswered Question
Apr 18th, 2007

Can someone drop me a sample configuration for an h.323 PSTN gateway?

We have a 2821 with 2 4xFXO ports on it. I have configured the gateway as per various examples, I can dial out, however dial in the system get's a fast busy as soon as the system answers (if i use connection PLAR) or I get constant ringing (if I use connection PLAR opx)

In traces the most I can see is some sort of an h.323 reason code 21.

I would simply use MGCP -- however the customer has CallerID

Any thoughts?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
kelvin.blair Wed, 04/18/2007 - 19:24

You need to make sure you bind the h323 traffic to an interface. For example;

interface faste 0/0

ip address X.X.X.X

h323-gateway voip interface

h323-gateway voip bind src X.X.X.X

Once that is done, you need to configure it in call manager as a h323 gateway with the correct CSS for inbound calls.

The next thing is to configure your dialpeers and voice ports. Here is an example. All calls from FXO port 1 should go to extension 3000. This extension 3000 is either a shared line or huntgroup in CM. Here is the basic voice-port configuration:

voice-port 0/0/0

connection plar 3000

caller-id enable

Now a dialpeer needs to be setup to match the extension that is being dialed so that it can be forward to Call Manager.

dial-peer voice 3000 voip

destination-pattern 3000

session target ipv4:X.X.X.X

dtmf-relay h245-alphanumeric

codec g711

no vad

and that is it. But again MAKE SURE CM GATEWAY DEVICE CONFIG FOR INBOUND CALLS is placed in the right CSS or else you get a fast busy no matter what you do.

If that doesn't help, please post your config. It will help in solving your issue.

If this post was useful, please be sure to rate it.

justincohen Wed, 04/18/2007 - 20:04

So far everything you say matches what i've been doing. That config matches mine exactly.

I've bound the interfaces, and confirmed through sniffer and traces that it's sourceing the traffic from the correct IP.

The CCS is correct -- it's the same assigned to another telephone -- and it can call the DN no problem.

ip domain name ABC.com

!

trunk group PSTN

description PSTN ACCESS

hunt-scheme sequential both up

!

voice-card 0

dspfarm

dsp services dspfarm

!

voice call send-alert

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

!

!

voice class h323 1

h225 timeout tcp establish 3

h225 timeout setup 2

call start slow

interface GigabitEthernet0/0

description MPLS CKT# aaaaaaaaaa

bandwidth 10000000

ip address x.x.x.x 255.255.0.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

description LocalVlanAccess

no ip address

duplex full

speed 100

!

interface GigabitEthernet0/1.111

description DataVlan

encapsulation dot1Q 111

ip address x.x.1.1 255.255.255.0

!

interface GigabitEthernet0/1.112

description VoiceVlanWired

encapsulation dot1Q 112

ip address x.x.2.1 255.255.255.0

ip pim sparse-mode

h323-gateway voip interface

h323-gateway voip bind srcaddr x.x.2.1

!

router eigrp 1

redistribute static

network x.x.1.0 0.0.0.255

network x.x.2.0 0.0.0.255

network x.x.0.0 0.0.255.255

no auto-summary

!

!

voice-port 0/0/0

trunk-group PSTN

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-out 500

connection plar 6012

description 905-1234567

caller-id enable

!

voice-port 0/0/1

trunk-group PSTN

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-out 500

connection plar 6012

description 905-1234567

caller-id enable

!

voice-port 0/0/2

trunk-group PSTN

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-out 500

connection plar 6012

description 905-1234567

caller-id enable

!

voice-port 0/0/3

trunk-group PSTN

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-out 500

connection plar opx 6012

description 905-1234567

caller-id enable

dial-peer voice 13 pots

trunkgroup PSTN

description 10 Digit Dialing

destination-pattern 9[2-9].........

forward-digits 10

!

dial-peer voice 15 pots

trunkgroup PSTN

description Noth American Long Distance

destination-pattern 91[2-9].........

direct-inward-dial

forward-digits 11

!

dial-peer voice 16 pots

trunkgroup PSTN

description International LD

destination-pattern 9011T

forward-digits all

!

dial-peer voice 600 voip

destination-pattern 60..

session target ipv4:x.x.2.3

dtmf-relay h245-alphanumeric

codec g711ulaw

!

dial-peer voice 601 voip

destination-pattern 60..

session target ipv4:x.x.2.2

dtmf-relay h245-alphanumeric

codec g711ulaw

kelvin.blair Thu, 04/19/2007 - 05:04

Change the following information

trunk group PSTN

description PSTN ACCESS

hunt-scheme sequential both up

!

voice-card 0

dspfarm

dsp services dspfarm

!

voice call send-alert

voice rtp send-recv

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

h323

!

!

voice class h323 1

h225 timeout tcp establish 3

h225 timeout setup 2

call start fast

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g729r8

interface GigabitEthernet0/0

description MPLS CKT# aaaaaaaaaa

bandwidth 10000000

ip address x.x.x.x 255.255.0.0

duplex auto

speed auto

!

interface GigabitEthernet0/1

description LocalVlanAccess

no ip address

duplex full

speed 100

!

interface GigabitEthernet0/1.111

description DataVlan

encapsulation dot1Q 111

ip address x.x.1.1 255.255.255.0

!

interface GigabitEthernet0/1.112

description VoiceVlanWired

encapsulation dot1Q 112

ip address x.x.2.1 255.255.255.0

ip pim sparse-mode

h323-gateway voip interface

h323-gateway voip bind srcaddr x.x.2.1

!

router eigrp 1

redistribute static

network x.x.1.0 0.0.0.255

network x.x.2.0 0.0.0.255

network x.x.0.0 0.0.255.255

no auto-summary

!

!

voice-port 0/0/0

trunk-group PSTN

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-out 500

connection plar 6012

description 905-1234567

caller-id enable

!

voice-port 0/0/1

trunk-group PSTN

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-out 500

connection plar 6012

description 905-1234567

caller-id enable

!

voice-port 0/0/2

trunk-group PSTN

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-out 500

connection plar 6012

description 905-1234567

caller-id enable

!

voice-port 0/0/3

trunk-group PSTN

timeouts call-disconnect 3

timeouts wait-release 3

timing hookflash-out 500

connection plar opx 6012

description 905-1234567

caller-id enable

dial-peer voice 13 pots

trunkgroup PSTN

description 10 Digit Dialing

destination-pattern 9[2-9].........

forward-digits 10

!

dial-peer voice 15 pots

trunkgroup PSTN

description Noth American Long Distance

destination-pattern 91[2-9].........

direct-inward-dial

forward-digits 11

!

dial-peer voice 16 pots

trunkgroup PSTN

description International LD

destination-pattern 9011T

forward-digits all

!

dial-peer voice 600 voip

destination-pattern 60..

voice-class h323 1

voice-class codec 1

session target ipv4:x.x.2.3

dtmf-relay h245-alphanumeric

no codec g711ulaw

!

dial-peer voice 601 voip

preference 1

destination-pattern 60..

voice-class h323 1

voice-class codec 1

session target ipv4:x.x.2.2

dtmf-relay h245-alphanumeric

no codec g711ulaw

Run these debugs to be sure the call is going to ccm.

debug voip dialpeer inout

debug voice dialpeer inout

debug voice ccapi inout

debug cch323 h225

debug cch323 h245

Do a detailed CCM trace and look for the extension that is being called.

justincohen Thu, 04/19/2007 - 06:50

Thanks for your help Kevin.

I will do those tests and get back to you, unfortunatly the customer has to sit on MGCP for now - until we can work this out, so i have to do these test in the evenings (EST)

tahiryasin Wed, 08/15/2007 - 18:02

I have the sxact same situation 2811 with 4FXO and in bound gets a fast busy ? Did Anyone solve this issue.

Thanks

Actions

This Discussion