DHCP relay for a 3750 VLAN port

Unanswered Question
Apr 19th, 2007
User Badges:

When I connect a certain network into a port setup for a specific VLAN on my CAt 3750, I cannot access the DHCP scope that I setup on the router for that subnet. I put in an IP Help-address statement, but DHCP is still not working. Should I be doing something on the 3750 to tell it to relay DHCP?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Iain Thu, 04/19/2007 - 12:11
User Badges:

Could you post the output for


show run int vlan X



X = the vlan interface which has the IP Helper statement

jweldin Thu, 04/19/2007 - 12:33
User Badges:

Router: for VLAN6

!

interface FastEthernet0/0.6

description Private Classroom -Line C

encapsulation dot1Q 6

ip address 192.168.6.1 255.255.255.0

ip access-group Internal-hacks in

ip helper-address 192.168.6.2

no ip redirects

no ip unreachables

ip directed-broadcast

no ip proxy-arp

ip nat inside

no ip virtual-reassembly

no snmp trap link-status

no cdp enable






_____________________________________


Switch config

!

interface FastEthernet1/0/3

description Private Classroom 'C line'

switchport access vlan 6

switchport mode access

spanning-tree portfast

end



Iain Thu, 04/19/2007 - 12:46
User Badges:

OK, I'm confused. Do you have a diagram? It is my understanding that the IP Helper feature is used to relay DHCP requests from clients in one subnet (VLAN) to another subnet (VLAN) where the DHCP server resides. From this configuration it looks like your ip helper statement is pointing to an address which is in the same subnet as your client(s).


You need to have the ip helper statement on the VLAN interface which has the default-gateway IP for the clients which you are trying to configure for DHCP.

jweldin Thu, 04/19/2007 - 13:22
User Badges:

Ok. So I know 192.168.1.1 passes out ip addresses for 192.168.1.x addresses. So should it be my ip help-address? I have a scope setup for 192.168.6.x

jweldin Thu, 04/19/2007 - 13:32
User Badges:

192.168.1.1 as a helper does not work.

jweldin Thu, 04/19/2007 - 13:47
User Badges:

By the way my router is the DHCP server. It has a scope for the 192.168.6.x network.

glen.grant Thu, 04/19/2007 - 13:58
User Badges:
  • Purple, 4500 points or more

might want to check out that acl and see if it is blocking dhcp request on the .6 subinterface on the router. Also verify your trunk between the 3750 and the router is working correctly. You can harcode a address on a workstation and verify you can ping both router subinterfaces , if not trunking probably is not working correctly. Not sure if you would need a helper address or not seeing the router itself is doing the dhcp as ooposed to a server . This might help for router setup .


http://cisco.com/en/US/products/sw/iosswrel/ps1835/products_configuration_guide_chapter09186a00800ca75c.html#wp1000879

jweldin Thu, 04/19/2007 - 14:01
User Badges:

I just removed it. Which ip forward address would you recommend? 192.168.1.1?

Iain Thu, 04/19/2007 - 19:54
User Badges:

One more question. Are you doing any routing on the 3750, or is all the inter-vlan routing taking place on that other router?


Do you mind posting configs for both devices?


I have an idea, but would need to look at the configs to confirm.

Actions

This Discussion