Different BGP output in show run

Unanswered Question
Apr 19th, 2007

Hi All,


I have these two 3745 identical router. RouterA has existing config while RouterB has no config. Both has 12.3(21) Enterprise Plus IOS, I upgrade them to 12.4(10b) Advanced Enterprise. When I execute "show run" in RouterA, the BGP configuration part shows the same when it has the old IOS after reboot. However, when I paste the config to RouterB, the BGP configuration part shows different. Why is it so?


RouterA BGP config after upgrading from 12.3(21) Enterprise Plus IOS to 12.4(10b) Advanced Enterprise and reboot.

!

router bgp 1

no synchronization

bgp router-id 192.168.160.252

no bgp fast-external-fallover

bgp log-neighbor-changes

network 192.168.160.0 mask 255.255.240.0

aggregate-address 192.168.160.0 255.255.240.0 summary-only

neighbor 192.168.160.253 remote-as 1

neighbor 192.168.160.253 password 7 -secret-

neighbor 192.168.160.253 update-source Loopback0

neighbor 192.168.160.253 version 4

neighbor 192.168.160.253 next-hop-self

neighbor 192.168.160.253 soft-reconfiguration inbound

neighbor 192.168.160.253 prefix-list bogons in

neighbor 192.168.160.254 remote-as 1

neighbor 192.168.160.254 password 7 -secret-

neighbor 192.168.160.254 update-source Loopback0

neighbor 192.168.160.254 version 4

neighbor 192.168.160.254 next-hop-self

neighbor 192.168.160.254 soft-reconfiguration inbound

neighbor 192.168.160.254 prefix-list bogons in

neighbor 192.168.41.153 remote-as 2

neighbor 192.168.41.153 description BGP with ISP-A

neighbor 192.168.41.153 password 7 -secret-

neighbor 192.168.41.153 version 4

neighbor 192.168.41.153 soft-reconfiguration inbound

neighbor 192.168.41.153 prefix-list bogons in

neighbor 192.168.41.153 filter-list 1 out

no auto-summary


RouterB BGP config after upgrading from 12.3(21) Enterprise Plus IOS to 12.4(10b) Advanced Enterprise, reboot, and paste RouterA config.

!

router bgp 1

bgp router-id 192.168.160.252

no bgp fast-external-fallover

bgp log-neighbor-changes

neighbor 192.168.160.253 remote-as 1

neighbor 192.168.160.253 password 7 -secret-

neighbor 192.168.160.253 update-source Loopback0

neighbor 192.168.160.253 version 4

neighbor 192.168.160.254 remote-as 1

neighbor 192.168.160.254 password 7 -secret-

neighbor 192.168.160.254 update-source Loopback0

neighbor 192.168.160.254 version 4

neighbor 192.168.41.153 remote-as 2

neighbor 192.168.41.153 description BGP with ISP-A

neighbor 192.168.41.153 password 7 -secret-

neighbor 192.168.41.153 version 4

maximum-paths 2

!

address-family ipv4

neighbor 192.168.160.253 activate

neighbor 192.168.160.253 next-hop-self

neighbor 192.168.160.253 soft-reconfiguration inbound

neighbor 192.168.160.253 prefix-list bogons in

neighbor 192.168.160.254 activate

neighbor 192.168.160.254 next-hop-self

neighbor 192.168.160.254 soft-reconfiguration inbound

neighbor 192.168.160.254 prefix-list bogons in

neighbor 192.168.41.153 activate

neighbor 192.168.41.153 soft-reconfiguration inbound

neighbor 192.168.41.153 prefix-list bogons in

neighbor 192.168.41.153 filter-list 1 out

maximum-paths 2

no auto-summary

no synchronization

network 192.168.160.0 mask 255.255.240.0

aggregate-address 192.168.160.0 255.255.240.0 summary-only

exit-address-family

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
Harold Ritter Thu, 04/19/2007 - 19:33

RouterB shows the new MBGP cli format. I'm not sure why it upgraded the configuration by default. You usually need to enter the "bgp upgrade-cli" command under "router bgp" for the upgrade to take place.


Can you provide a "show ver" from both routers.



Hope this helps,

Danilo Dy Thu, 04/19/2007 - 19:57

Hi Harold,


Thank you for your reply. Similar symptoms happen when I paste RouterA config to 3845 router with 12.4(10b) Adv Ent IOS. Here is the "sh ver" output from RouterA and RouterB. BTW, I don't see "bgp upgrade-cli" command option under "router bgp".



RouterA#sh ver

Cisco IOS Software, 3700 Software (C3745-ADVENTERPRISEK9-M), Version 12.4(10b),

RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Fri 19-Jan-07 19:16 by prod_rel_team


ROM: System Bootstrap, Version 12.3(6r) [cmong 6r], RELEASE SOFTWARE (fc1)


RouterA uptime is 1 week, 1 day, 8 hours, 44 minutes

System returned to ROM by reload at 08:02:31 SG Fri Mar 1 2002

System image file is "flash:c3745-adventerprisek9-mz.124-10b.bin"



This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.


A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html


If you require further assistance please contact us by sending email to

[email protected].


Cisco 3745 (R7000) processor (revision 2.0) with 499712K/18432K bytes of memory.

Processor board ID JPE071611NP

R7000 CPU at 350MHz, Implementation 39, Rev 3.3, 256KB L2, 2048KB L3 Cache

4 FastEthernet interfaces

DRAM configuration is 64 bits wide with parity disabled.

151K bytes of NVRAM.

125184K bytes of ATA System CompactFlash (Read/Write)


Configuration register is 0x2102


RouterA#


RouterB#sh ver

Cisco IOS Software, 3700 Software (C3745-ADVENTERPRISEK9-M), Version 12.4(10b),

RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2007 by Cisco Systems, Inc.

Compiled Fri 19-Jan-07 19:16 by prod_rel_team


ROM: System Bootstrap, Version 12.3(6r) [cmong 6r], RELEASE SOFTWARE (fc1)


RouterB uptime is 1 hour, 50 minutes

System returned to ROM by reload at 08:41:49 SG Fri Mar 1 2002

System image file is "flash:c3745-adventerprisek9-mz.124-10b.bin"



This product contains cryptographic features and is subject to United

States and local country laws governing import, export, transfer and

use. Delivery of Cisco cryptographic products does not imply

third-party authority to import, export, distribute or use encryption.

Importers, exporters, distributors and users are responsible for

compliance with U.S. and local country laws. By using this product you

agree to comply with applicable laws and regulations. If you are unable

to comply with U.S. and local laws, return this product immediately.


A summary of U.S. laws governing Cisco cryptographic products may be found at:

http://www.cisco.com/wwl/export/crypto/tool/stqrg.html


If you require further assistance please contact us by sending email to

[email protected].


Cisco 3745 (R7000) processor (revision 2.0) with 243712K/18432K bytes of memory.

Processor board ID JPE071611NQ

R7000 CPU at 350MHz, Implementation 39, Rev 3.3, 256KB L2, 2048KB L3 Cache

4 FastEthernet interfaces

DRAM configuration is 64 bits wide with parity disabled.

151K bytes of NVRAM.

125184K bytes of ATA System CompactFlash (Read/Write)


Configuration register is 0x2102

RouterB#

Actions

This Discussion