Cisco 803 and ISDN

Unanswered Question
Apr 20th, 2007

Hello everybody!

I must configure a CISCO 803 for it to comunicate with a CISCO CL3620 via ISDN.

Both routers have different IPs. The CL3620 is connected to an primary ISDN line, while the 803 is connected to a Basic ISDN line.

If I ping from the 3620 to the 803, I can see the orange light (ISDN) in the front pannel of the 803, and the ISDN channel activates and I receive the replies. But if I ping from the 803 to the 3620, the channel doesn't activate.

I paste the configuration of the 803, in case you can help me out.

Thanks in advance!

-----------------

803 config.

-----------------

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname router803

!

boot-start-marker

boot-end-marker

!

enable secret xxx

!

username xxx password xxx

username xxx password xxx

!

!

aaa new-model

!

!

aaa authentication login default local

aaa authentication ppp default if-needed local

aaa session-id common

ip subnet-zero

no ip source-route

ip domain name domain.es

ip name-server x.x.x.x

ip name-server x.x.x.x

!

isdn switch-type basic-net3 /* I'm from Spain) */

!

!

!

interface Ethernet0

ip address x.x.x.x 255.255.255.0

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

ppp authentication chap

!

interface Dialer1

ip unnumbered Ethernet0

encapsulation ppp

dialer pool 1

dialer remote-name 3620

dialer idle-timeout 300

dialer string 93XXXXXXX

dialer-group 1

compress stac

no cdp enable

ppp authentication chap

ppp chap hostname router803

ppp chap password xxx

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 1.0.0.0 255.0.0.0 Dialer1 permanent

ip http server

!

dialer-list 1 protocol ip permit

!

line con 0

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
clabsaclabsa Fri, 04/20/2007 - 02:23

Here there are:

--------------------------------

router#show isdn active

--------------------------------------------------------------------------------

ISDN ACTIVE CALLS

--------------------------------------------------------------------------------

Call Calling Called Remote Seconds Seconds Seconds Charges

Type Number Number Name Used Left Idle Units/Currency

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------

router#show isdn status

Global ISDN Switchtype = basic-net3

ISDN BRI0 interface

dsl 0, interface ISDN Switchtype = basic-net3

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 65, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0x80000003

Total Allocated ISDN CCBs = 0

spremkumar Fri, 04/20/2007 - 02:31

Hi

Can you change the ip addressing scheme which you are using currently out there ?

can you assign a /30 ip address on both the ends of your dialer so that you can avoid ip unnumbered command from the dialer.

Also would like know the idea behind having one more static route in addition to the default route..

can you also get the logs once you enable debug isdn q931 with logging or term mon ??

regds

clabsaclabsa Fri, 04/20/2007 - 02:47

Hi

"Can you change the ip addressing scheme which you are using currently out there ?

can you assign a /30 ip address on both the ends of your dialer so that you can avoid ip unnumbered command from the dialer."

I can't change this scheme since it has been used during months in my company. What I can do is try to remove the 'ip unnumbered' command. Just tried it and doesn't work yet.

"Also would like know the idea behind having one more static route in addition to the default route.. "

Yes, maybe it is unnecessary, but I'm a little newbie. One is to allow traffic to the internet, and the other one is to allow traffic to the LAN in the offices.

"can you also get the logs once you enable debug isdn q931 with logging or term mon ??"

OK. I activate the debug, try to ping the 3620 and I get the following for each ping:

-----------------------------------------------------

00:01:17: ISDN BR0 Q931: TX -> SETUP pd = 8 callref = 0x01

Bearer Capability i = 0x8890

Standard = CCITT

Transer Capability = Unrestricted Digital

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x83

Called Party Number i = 0x80, '93XXXXXXX'

Plan:Unknown, Type:Unknown

00:01:17: ISDN BR0 Q931: RX <- CALL_PROC pd = 8 callref = 0x81

Channel ID i = 0x8A.

00:01:18: ISDN BR0 Q931: RX <- DISCONNECT pd = 8 callref = 0x81

Cause i = 0x8095 - Call rejected

Display i = 'Call is rejected'

00:01:18: ISDN BR0 Q931: TX -> RELEASE pd = 8 callref = 0x01

Cause i = 0x8095 - Call rejected

00:01:18: ISDN BR0 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x81

Cause i = 0x8095 - Call rejected

-----------------------------------------------------------------

Thanks!

spremkumar Fri, 04/20/2007 - 03:19

Hi

Can you post the config of the 3620 router too ?

Can you also get the debug details from 3620 router ?

But before doing debug/logging do make sure that your box is not loaded fully,over load may cause router to reboot.

regds

clabsaclabsa Fri, 04/20/2007 - 03:27

Here it is:

----------------

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname 3620

!

aaa new-model

aaa authentication login default local

aaa authentication ppp default local

aaa authentication ppp DIALIN group radius

aaa authorization network default local

aaa authorization network DIALIN group radius

enable secret xxx

isdn switch-type primary-net5

chat-script offhook "" "ATH1" OK

chat-script callback ABORT ERROR ABORT BUSY "" "ATZ" OK "AT" OK "ATDT \T" TIMEOUT 60 CONNECT \c

!

controller E1 0/0

pri-group timeslots 1-31

!

!

!

interface FastEthernet0/0

ip address 1.X.X.X 255.0.0.0

ip nat inside

duplex auto

speed auto

!

interface Serial0/0:15

no ip address

encapsulation ppp

dialer pool-member 28 max-link 28

isdn switch-type primary-net5

isdn incoming-voice modem

no cdp enable

!

interface Group-Async1

description Template a aplicar a totes les interfaces async, com els modems

ip unnumbered FastEthernet0/0

encapsulation ppp

async mode dedicated

peer default ip address pool DIALIN_POOL

compress mppc

ppp max-bad-auth 3

ppp callback accept

ppp authentication ms-chap chap DIALIN

ppp authorization DIALIN

group-range 33 38

!

interface Dialer1

ip unnumbered FastEthernet0/0

encapsulation ppp

dialer pool 28

dialer remote-name router803

dialer idle-timeout 300

dialer string 93XXXXXXX

dialer snapshot

dialer-group 1

snapshot server 5

compress stac

no cdp enable

ppp authentication chap

!

ip local pool DIALIN_POOL 1.0.6.1 1.0.6.6

ip nat translation timeout 259200

ip nat pool NAT_EXTERN 10.99.99.2 10.99.99.254 netmask 255.255.255.0

ip nat inside source list 10 pool NAT_EXTERN

ip classless

ip route X.X.X.X 255.255.255.0 Dialer1 permanent

logging trap warnings

dialer-list 1 protocol ip permit

snmp-server enable traps tty

line con 0

exec-timeout 0 0

line 33 38

script modem-off-hook offhook

script callback callback

modem InOut

line aux 0

line vty 0 4

transport input telnet

!

end

-------------

Actions

This Discussion