ASK THE EXPERT - COMMUNICATIONS MANAGER EXPRESS AND CISCO UNITY EXPRESS

Unanswered Question
Apr 20th, 2007
User Badges:
  • Gold, 750 points or more

Welcome to the Cisco Networking Professionals Ask the Expert conversation. This is an opportunity to get an update on Cisco Communications Manager Express (formerly CallManager Express) and Cisco Unity Express (CUE) with Cisco expert Tony Huynh. Tony Huynh is a technical marketing engineer for Cisco Callmanager Express (CME) at Cisco Systems, Inc. He is a (CCIE) Cisco Certified Internetwork Expert in routing, switching and voice with eight years of design and support experience in the information technology industry.


Remember to use the rating system to let Tony know if you have received an adequate response.


Tony might not be able to answer each question due to the volume expected during this event. Our moderators will post many of the unanswered questions in other discussion forums shortly after the event. This event lasts through May 4, 2007. Visit this forum often to view responses to your questions and the questions of other community members.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (6 ratings)
Loading.
lombitsa2 Sun, 04/22/2007 - 09:37
User Badges:

I am running two seperate VLAN's (one for data one for voice)how would my PC (VL100) to connect to my network through my 7960G IP Phone(VL200), i imagine configuring the physical switchport either for trunkin or pruning, or something to confgiure through the CME(3.3) for the phone

Tony Huynh Mon, 04/23/2007 - 08:41
User Badges:
  • Silver, 250 points or more

Hi,


The phone has a switch itself that is built it. As long as you configure the FE port (on the switch) that the phone connects to as a trunk port with dot1q encapsulation, it will detect the voice and data VLAN via CDP. Here is example of config for trunking.


http://www.cisco.com/en/US/products/sw/voicesw/ps5520/products_configuration_example09186a008037f2a9.shtml


Regards,

Tony

lombitsa2 Sun, 04/22/2007 - 09:39
User Badges:

After augmenting the AA in CUE other than changing the greeting is there any way to allow me to skip through the through when i call from an outside line straight through to the wanted extension

Tony Huynh Mon, 04/23/2007 - 08:48
User Badges:
  • Silver, 250 points or more

Hi,


Assuming I understand your situation correctly, you are using CUE AA and wish to have drop-through-mode, similar to B-ACD and go directly to a pre-defined extension. You could customize your CUE AA by using CUE Editor - which is available on CCO.


Here is a document that explains what CUE editor provides and where to download.


http://www.cisco.com/en/US/products/sw/voicesw/ps5520/products_tech_note09186a008041d950.shtml


Regards,

Tony


d.rocco Mon, 04/23/2007 - 10:07
User Badges:

Hi Tony,

i think that you can help me in caller-di block feature:

I have configured ccme 4.1 with two controller E1 for PSTN and about 50 ephone-dn in dual-line mode.


When i put caller-id block under ephone-dn, the caller-id in the outbound is not blocked.

In every outbound call i see the calling ID.


This is the voice port configuration:


!

controller E1 0/0/0

clock source internal

pri-group timeslots 1-31

!

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn overlap-receiving T302 5000

isdn not-end-to-end 64

isdn incoming-voice voice

isdn map address .* plan unknown type unknown

isdn send-alerting

isdn sending-complete

no cdp enable

!

!

voice-port 0/0/0:15

input gain 10

echo-cancel coverage 32

playout-delay nominal 100

playout-delay mode fixed

cptone IT

timeouts call-disconnect infinity

music-threshold -70

!

I tried also with "clid strip name" and "clid strip" under outbound dial-peer pots but i think that these are for voip dial-peer only!


Any idea?

Thanks'

Diego

Tony Huynh Mon, 04/23/2007 - 10:22
User Badges:
  • Silver, 250 points or more

Are you using 12.4(11)XJ2 or XJ1? Also, after you configured "caller-id block" underneath the ephone-dn, did you perform "create cnf" underneath telephony-service and reset the phone?

d.rocco Mon, 04/23/2007 - 11:19
User Badges:

Release version is 12.4(11)XJ.


I don't perform create cnf-file, but i don't think that this is necessary!

I have another customer with the same release and the same configuration. I have configured the caller-id block code underneath telephony-service, and all work fine.


Regards

phillip-wright Mon, 04/23/2007 - 11:18
User Badges:

I am attemping to load background images. It just does not seem to work for me. I am using CME and attemping to load images as outlined in the instructions but when I go to the phone and attempt to load the image it is not in the file. I turned on debug TFTP-Serv and i can see the phone attempt to find List.xml.


What am I doing wrong? I need help!

Tony Huynh Mon, 04/23/2007 - 11:25
User Badges:
  • Silver, 250 points or more

Did you make sure to add the list.xml file to the list of files that the tftp-server will serve?


tftp-server flash:list.xml



phillip-wright Tue, 04/24/2007 - 14:13
User Badges:

Tony,


I tried that with no results. Do I need to modify List.xml? or what if the TFTP debug shows that it's not asking for List.xml on restart?


lombitsa2 Mon, 04/23/2007 - 11:35
User Badges:

after changing the encapsulation and allowing all vlans i am still unable to reach the inter net from pc is there something else ie. the phone or the pc


this is what my switchport looks like

switchport trunk encapsulation dot1q

switchport mode trunk

switchport voice vlan 200

switchport port-security maximum 2

switchport port-security aging time 2

switchport port-security violation restrict

switchport port-security aging type inactivity

macro desciption cisco-phone

auto qos voip cisco-phone

spanning-tree portfast

spanning tree bpduguard enable



my PC is on vlan 1 and the phone vlan 200

Tony Huynh Mon, 04/23/2007 - 12:40
User Badges:
  • Silver, 250 points or more

Can you check to see if the port membership for data is in vlan 1? If not, may want to specifically specify that native vlan is 1 with the following command:


switchport trunk native vlan 1


Also, you could configure a vlan interface and assign it an ip address. Then from there, you could try and ping out to the internet from the switch itself. This will determine whether problem is on switch or router.

lombitsa2 Mon, 04/23/2007 - 17:06
User Badges:

i applied the switchport trunk native vlan 1 nothing up on the interface when i tried to ping the phone or anything beyond the i got destination host unreachable

dstromain Mon, 04/23/2007 - 11:49
User Badges:

hI

I recently took over as Network Manager for the SOuth Texas Public Safety E911 System and have several 2811 Routers that we do not know the Enable Password. We would like to know if there is any way to extract this password or any other means to default this router without having to get to the configuration mode (which we cannot due to lack of enable password)

THanks in advance for your help and suggestions

Dale

lombitsa2 Mon, 04/23/2007 - 11:53
User Badges:

go to google and search for cisco password recovery

Hi Tony,


I have deployed a lot of 7911's with CME 4.1/4.(0)3.


Typlically the configuration and phone loads have been very simular. The CME router is the DHCP server for the VoIP VLAN.


We are using Extension Assigner (EA) to simplify the deployment. Great application - Thanks!!


But every 7911 must have it's settings erased before it will register to CME.


It seems to ignore the DHCP option 150 (TFTP server) setting, which is the loopback address of the CME router.


It only tries to connect to the factory 10.10.200.250 address.


If I add the 10.10.200.250 as a secondary address the 7911 phones register.


Without the secondary 10.10.200.250 address 7961 and 7970 phones register fine, it only seems to be an issue with the 7911 phones and doesn't seem to be dependant on firmware versions.


Do you have any suggestions?


Regards,


Mike.



Tony Huynh Mon, 04/23/2007 - 21:07
User Badges:
  • Silver, 250 points or more

Hi Mike,


It has been reported that some of the new 7911 phones have TFTP server parameters set to false. I suspect that the TFTP server option is set incorrectly on the phone by default. Can you check and see if the TFTP server option is suppose to be received by DHCP or statically configured?


Regards,

Tony

Tony Huynh Wed, 04/25/2007 - 22:17
User Badges:
  • Silver, 250 points or more

So you are saying that the TFTP server option and IP address is populated correctly, but the CallManager 1 option is always 10.10.200.250 - unless you factory reset the phone correct?


If so, then I would recommend opening up a TAC case and have them file a defect for this.


Regards,

Tony

senolgokhan Tue, 04/24/2007 - 00:23
User Badges:

My customer has 2851 CCME router. And I created pick up groups for some ip phone users.



For example ; ip phone users userA userB userC in the same pickup group .



!



userA>> ephone-dn 23 dual-line


number 5780


pickup-group 10




ephone-dn 25 dual-line


userB>> number 5775


pickup-group 10



!


userC>> ephone-dn 26 dual-line


number 5787


pickup-group 10





problem is : if someone from outside calls userA s DID and if the userB wants to pickup the call (by pressing Grppick up and * star button. ), the call automatically answered from userB s ip phone.


But userB says that she wanna see the callerID which is calling userA, and if it is not a customer she doesnt wanna answer the call. Maybe the calling person is a friend of the userA



I mean if you pick up a call, the call is automatically answered.

but what i wanna see on the display of my ephoe callerID and calling ID.

coz think if 10 members in the same pickup group. But when i pick the call up , i dun know whose call i picked up.




In callmanager express how can I solve this issue. Or it is desing and nothing to do ,because Customer doesnt want to use hunt group number L


Thanks a lot




Tony Huynh Wed, 04/25/2007 - 07:35
User Badges:
  • Silver, 250 points or more

If I understand your question correctly, you would like to see caller-id before you choose to exercise the pick-up group option - is this correct? If so, then this is not currently available. What you could do is configure IP Phones in overlay-dn fashion, which will show caller-id on all the phones before answering.


Regards,

Tony

senolgokhan Tue, 04/24/2007 - 00:58
User Badges:

hi

"flash:c2800nm-spservicesk9-mz.124-12.bin"

ccme 3.3

cue Global 2.3.1


to which version can i upgrade my ccme and also should i upgrade CUE version if i upgrade CCME.

also the only thing that i should do is upgrading ios to upgrade ccm version. am i right?or should i upgrade phone firmware also/

what is the upgrade procedure if ccme and cue run together.

\which files exatly should i upgrade.

which ios should i use for the lates ccme/ ccme 4.1


thanks a lot

Tony Huynh Tue, 04/24/2007 - 10:04
User Badges:
  • Silver, 250 points or more

Hi,


You can upgrade your CME to any version that you like, as long as your router meets the minimum platform requirements for the CME version you wish to run. Here is list of specifications for each CME.


http://www.cisco.com/en/US/products/sw/voicesw/ps4625/prod_installation_guide09186a00805acf50.html


On the above link, click on the links on the right side that correspond to the CME you wish to upgrade to.


Also, here is roadmap of features by CME version.


http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_guide_chapter09186a00807f6f5e.html


Regards,

Tony

senolgokhan Tue, 04/24/2007 - 02:26
User Badges:

disconnect cause 1F

i got ccme 2851 router and also i have pri line.

Even the under controller E1 there is no any error , intermittenly the calls drop.

debug isdn q931 output shows Disconnect cause=1F

any idea?

output of debug q931 is below.

Also another thing happens.

scenario like that.

-some1 from pstn calls the operator and wanna talk with a person

- operator holds the calling one by pressing transfer button an operator calls the person if s/he is available

- if the person is not available the operator resumes the call

- at that time ip phone screen still show connected and time still goes on counting , there is no audio between operator and calling person

- no audio and calling person closes the phone

- caliing person calls again ans says to the operator 'i couldnt hear you'


debug isn q931 for droped calls


Mar 12 12:55:24.724: ISDN Se0/0/0:15 Q931: RX <- DISCONNECT pd = 8 callref = 0x1702

Cause i = 0x829F - Normal, unspecified

Mar 12 12:55:24.728: %ISDN-6-DISCONNECT: Interface Serial0/0/0:2 disconnected from 05325414916 , call lasted 117 seconds

Mar 12 12:55:24.728: ISDN Se0/0/0:15 Q931: TX -> RELEASE pd = 8 callref = 0x9702

Mar 12 12:55:24.736: %VOIPAAA-5-VOIP_CALL_HISTORY: CallLegType 1, ConnectionId 7FE383BC CFCF11DB A2930019 55A6CDD8, SetupTime 12:53:24.846 UTC Mon Mar 12 2007, PeerAddress 5722, PeerSubAddress , DisconnectCause 1F , DisconnectText normal, unspecified (31), ConnectTime 12:53:27.426 UTC Mon Mar 12 2007, DisconnectTime 12:55:24.736 UTC Mon Mar 12 2007, CallOrigin 1, ChargedUnits 0, InfoType 2, TransmitPackets 0, TransmitBytes 0, ReceivePackets 5773, ReceiveBytes 923680

Mar 12 12:55:24.776: ISDN Se0/0/0:15 Q931: RX <- RELEASE_COMP pd = 8 callref = 0x1702

Mar 12 12:55:24.780: %VOIPAAA-5-VOIP_CALL_HISTORY: CallLegType 1, ConnectionId 7FE383BC CFCF11DB A2930019 55A6CDD8, SetupTime 12:53:24.840 UTC Mon Mar 12 2007, PeerAddress 05325414916, PeerSubAddress , DisconnectCause 1F , DisconnectText normal, unspecified (31), ConnectTime 12:53:27.440 UTC Mon Mar 12 2007, DisconnectTime 12:55:24.740 UTC Mon Mar 12 2007, CallOrigin 2, ChargedUnits 0, InfoType 2, TransmitPackets 5773, TransmitBytes 969864, ReceivePackets 5864, ReceiveBytes 938240

tr#


Tony Huynh Tue, 04/24/2007 - 06:50
User Badges:
  • Silver, 250 points or more

Disconnect cause code of 31 is unspecified cause code. From the debugs, it is the PSTN side that is disconnecting the call. Please check with them and determine why intermittently, the call is dropped on the PSTN side. One possible reason could be that there is no audio cut through - causing PSTN user to hang up. Would recommend opening up a TAC case and go through troubleshooting steps.


Regards,

Tony

senolgokhan Thu, 04/26/2007 - 22:36
User Badges:

Hi Tony


disconnect cause 1F not 31 :)

still do you think it is pstn side problem

? do you think that should i upgrade ccme version ?

also in switch configs i made only voice vlan and data vlan config but didnt make any mls qos config. can it be related

to disconnect issue ?


thanks a lot


Tony Huynh Fri, 04/27/2007 - 05:53
User Badges:
  • Silver, 250 points or more

1f is hex value for 31. Regardless, you may want to troubleshoot with TAC to determine what is happening to cause PSTN side to hang up - perhaps they are hearing dead air, etc. I don't believe the qos configs are the cause of the problem and I wouldn't upgrade CME versions unless there was a bug identified or I need a new feature that a newer CME version gives me.


Regards,

Tony

senolgokhan Fri, 04/27/2007 - 06:32
User Badges:

yes! sory 1F=31 i didnt notice it :)

i thought semething else with error codes.

sorry and thanks for all your answers

bye



maheshmenon Tue, 04/24/2007 - 04:24
User Badges:

Hi Tony,


Shall I get some details on CDR generation on Cisco Communications Manager Express? How can I use an external billing system to get this information from CCME?

Tony Huynh Tue, 04/24/2007 - 06:40
User Badges:
  • Silver, 250 points or more

Hi,


You can use 3rd party applications such as Stonevoice or ISI to capture CDR records for billing purposes.


Regards,

Tony

maheshmenon Tue, 04/24/2007 - 07:00
User Badges:

Thanks Tony for that reply. We use a custom built billing application which we have integrated with Callmanager 4.x. We want to use the same with CM Express. If you can tell me where the Call Detail Records are stored in a CME router and how we can extract the same, it will be helpful.


Thanks in advance


Mahesh

ngriger77 Tue, 04/24/2007 - 06:02
User Badges:

We have a facility in China. They don't have any servers, but they do have an internet connection with several static IP addresses.

They want to add some kind of NAS (or server) device in China which would copy/synchronize certain directories from our file server. Futhermore, they want to add user permissions so certain people can't delete the files.

Any ideas?


I was kind of looking at the WAFS but didn't know if this would be a right fit or what kind of hardware would be needed. If you have answers it would be greatly appreciated the owner of my company is hot to get this done.


Thank you in advance for your help!


Tony Huynh Wed, 04/25/2007 - 14:09
User Badges:
  • Silver, 250 points or more

This would not be a CME/CUE play. I'll try and research to see if I can find something, but can't make any promises.


Regards,

Tony

burlingamelupti Tue, 04/24/2007 - 09:15
User Badges:

We have a Csico2851 with telephony supports for the head office. However, I work away from the head office all the time as a single developer here. How do I set up a home office that can both VPN to head office servers and also have a VOIP to the head office router so I can make local calls to our partners at the head office location?

conkinkinconkinkin Wed, 04/25/2007 - 00:39
User Badges:

Hi Tony,

I am deploying IP telephony system for my company's customer contact center.

I installed CallManager, IP Phone 7960, VoIP Gateway( Cisco 3825 Router).

Now i want manage communication data and monitor operation of all IP Phone, so i install IPCC.

But when i follow document to config IPCC, i can't find ICM in CRA Administration->Subsystem->ICM.

I think ICM is not installed but i can't find ICM install disk.

How to install ICM? Is it one option when install IPCC?

Do you have any idea?

Thanks a lot.

Tony Huynh Wed, 04/25/2007 - 16:00
User Badges:
  • Silver, 250 points or more

Hi,


This isn't a CME/CUE play, so I would recommend posting this question on the IP Telephony (broad list). I will see if I can find out for you how to configure ICM.


Regards,

Tony

Viveck1212 Wed, 04/25/2007 - 01:33
User Badges:

hiiiiiiii,

i am vivek,

i am having three 1721 series router of cisco

i am geeting problem while being loading IOS throught TFTP server...it is showing when i am putting there ...

ROUTER>COPY FLASH TFTP

source file C1700-advsecurityk9-mz.123-5b.bin

source ip..

destination file..

accessing \\10.152.78.100\filename....

time out



plz sir as soon as possible plz reply me..on email id [email protected]


phillip-wright Wed, 04/25/2007 - 08:05
User Badges:

Vivek,


I perform a lot of IOS pushes and I have gotten that same message when the file was either too large for TFTP or my permissions to access were incorrect. Please check the log on the TFTP server.


Also, we may want to try using an FTP server instead such as WinFTP. It will not give you the size limitations that can occur with TFTP.

Tony Huynh Wed, 04/25/2007 - 08:16
User Badges:
  • Silver, 250 points or more

Just to add on what was said here, make sure that you can ping TFTP server first. Secondly, I would recommend using JouninTFTP (freely available for download), as it allows large file size downloads.


Regards,

Tony

Viveck1212 Thu, 04/26/2007 - 04:36
User Badges:

dear sir

,,

i had downloaded throught also Winftp server

..still i am geeting same problem..


i am mentioning below all detail with attached



Attachment: 
Tony Huynh Thu, 04/26/2007 - 10:33
User Badges:
  • Silver, 250 points or more

Can you try the Jounintftp server?

Alltimed Wed, 04/25/2007 - 10:11
User Badges:

Tony,


First of all thanks for taking the time to answer these questions. Now for my question.


I work for an MSP and we are just breaking into IPT monitoring and reporting. I currently send the CDR records from a CME router at a customer's site to a Radius server on my network. The customer's local IP address is NAT'd before it gets to my network. This is causing a problem for routers that are not on the same network as the firewall (branch routers). Is there a way to force the source interface for the CDR records to be sent from? So I could force them to send from the LAN side and not the connection to the main location?


Thanks again,


Bryan

Tony Huynh Wed, 04/25/2007 - 14:11
User Badges:
  • Silver, 250 points or more

Hi Bryan,


You could try using this command: "logging source-interface "

Tony Huynh Wed, 04/25/2007 - 14:25
User Badges:
  • Silver, 250 points or more

Hi Tailoc,


(1) CME 3.2 and later is required for the 7920 support and CME 4.1 is required for the 7921g.


(2) I have attached a document on how to upgrade CME. Please refer to the following link to upgrade CUE.


http://www.cisco.com/en/US/products/sw/voicesw/ps5520/products_tech_note09186a008064172a.shtml






http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_documentation_roadmap09186a0080189132.html



henry.patterson... Wed, 04/25/2007 - 14:00
User Badges:

We have multiple divisions of our company going into a single building and they do not want to answer each other?s calls. Can a single CCME/CUE 2821 router be setup to divide the phone system (incoming PRI)so that a call to a number or a set of rollover number use a specific automated attendant greeting and/or go to a specific operator? If so how can this be setup?

Actions

This Discussion