SDM 2.4 and IPS V5

Answered Question
Apr 20th, 2007

Does V5 IPS not work with SDM? I get the message "IPS not supported" using IOS 12.4(11)T1. CLI show IPS working.

I have this problem too.
0 votes
Correct Answer by ymzhang about 9 years 6 months ago

SDM need 12.4(11)T2 or later image to support IOS IPS in 5.x signature format due to some issues in IOS.

For 12.4(11)T1, the best option is to use CLI for now.

Also please refer



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
juan_m_12 Mon, 04/30/2007 - 17:20

hi, i got the same issue, with IOS c2800nm-advipservicesk9-mz.124-11.T1.bin image, i will need to read the full document mentionated above


scottyd Thu, 05/03/2007 - 14:04


Is anyone else having high memory issues when using ver 5? I have installed on a 1801 with 128 M memory. It only has 4 M free now. Is there a way to reduce the active signatures? I have disbaled some but the number of active is still at 338.



ymzhang Thu, 05/03/2007 - 15:26

you can use IOS IPS CLI to retire un-needed signatures.

ip ips signature-definition

signature 3307 0


retired true

Be sure to answer yes to the prompt when exiting the CLI configuration.

Do you want to accept these changes? [confirm]y

Once a signature is retired, it wont be compiled by IOS IPS.


jeremy_liao Tue, 07/24/2007 - 09:08


what is different between "retired ture/false" and "enabled ture/false", thanks

nicksmi Tue, 07/24/2007 - 10:41

When a signature is retired, it is no longer processed by the engine, saving memory.

When a signature is disabled, it is still processed by the engine, but will not display alerts when it is triggered.


This Discussion