CORE HSRP CONFIG

Unanswered Question
Apr 22nd, 2007

COULD ANYONE TELL ME WHATS WRONG WITH THIS HSRP CONFIGURATION?


THANKS.


NOTE:

interface GigabitEthernet1/1 OF CORE SW 1&2 connected to edge switch 1

interface GigabitEthernet1/2 OF CORE SW 1&2 connected to edge switch 2

VLAN 100 IS THE MANAGEMENT VLAN




CORE SWITCH A

spanning-tree vlan 10 priority 8192


interface GigabitEthernet1/1

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,100

!

interface GigabitEthernet1/2

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,100


interface Vlan10

ip address 172.20.0.252 255.255.255.0

standby 10 ip 172.20.0.254

standby 10 priority 115

standby 10 preempt

standby 10 track vlan 10





CORE SWITCH B

spanning-tree vlan 10 priority 12288


interface GigabitEthernet1/1

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,100

!

interface GigabitEthernet1/2

no ip address

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10,100


interface Vlan10

ip address 172.20.0.253 255.255.255.0

standby 10 ip 172.20.0.254

standby 10 priority 115

standby 10 preempt

standby 10 track vlan 10

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
royalblues Sun, 04/22/2007 - 06:06

Friend,


i would have configured different HSRP priorities on the core switches.

i.e standby 10 priority 115 on core sw1

and standby 10 priority 110 on core sw2


this would ensure that core switch 1 will be the HSRP active which should be the case as core switch 1 is also your spanning tree root for VLAN 10


As you are tracking vlan 10, whenever there is any problem the priority would be reduced by 10 which will cause the other switch to take the HSRP active role.


HTH, rate if it does

Narayan

cfajardo1_2 Sun, 04/22/2007 - 11:30

sorry that was a typo error.

standby 10 priority 110 is on core switch B.



What about the tracking of vlan 10..Is this right? When Int G0/1 goes down, will vlan 10 goes down too in this case? If not, then what will happen to the edge switch connected to core sw A?


thanks


thanks

jason.plank Sun, 04/22/2007 - 14:04

Tracking logical interfaces isn't a good idea. You would be MUCH better off tracking the physical interface.

Richard Burts Sun, 04/22/2007 - 17:04

And it especially does not make sense that configuration of HSRP on VLAN 10 should track VLAN 10.

interface Vlan10

ip address 172.20.0.253 255.255.255.0

standby 10 ip 172.20.0.254

standby 10 priority 115

standby 10 preempt

standby 10 track vlan 10

the purpose of track is that if the specified interface goes protocol down then you change your priority. But if VLAN 10 goes protocol down then it will not be possible for interface VLAN 10 to change its priority. If you are going to track interfaces you need to track something other than your own interface.


HTH


Rick

cfajardo1_2 Sun, 04/22/2007 - 21:24

so am i ryt if i do the ff;


interface Vlan10

ip address 172.20.0.252 255.255.255.0

standby 10 ip 172.20.0.254

standby 10 priority 115

standby 10 preempt

standby 10 track int g0/1

standby 10 track int g0/2



thanks



Anand Narayana Sun, 04/22/2007 - 21:48

you can also include the "timers" for hello packets & Hold time.


interface Vlan10

ip address 172.20.0.252 255.255.255.0

standby 10 ip 172.20.0.254

standby 10 priority 115

standby timers 5 15

standby 10 preempt

standby 10 track int g0/1

standby 10 track int g0/2

Actions

This Discussion