disconnection from network

Unanswered Question
Apr 22nd, 2007

i have some new computer with intel network card Intel(R) 82566DC Gigabit Network and some time i get this message

Intel(R) 82566DC Gigabit Network Connection :Spanning Tree Protocol has been detected on the device your network connection is attached to.

and they disconnect and connnet from the lan i have cisco 3500xl stp is enable

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Anand S Sun, 04/22/2007 - 21:45

Any changez has been made recently on the network(physically or made any changez in the config), because that might occur loop on the network.

gattererm Thu, 05/31/2007 - 06:23


I Have also a BIG Problem with HP SFF PC's with Intel 82566 Gigabit Network Cards (OnBoard) with the same message.

My Problem is also a DISCONNECT (Layer1 LINK DOWN) and followed by a CONNECT (Link UP) after 1 Second.

My Switches are all 3500XL - With 3550 No Problem.

Configured PORTFAST and AUTO Negotiation

Fix Speed SET - No Change


Sometimes it helps when i change the Port or Patch to another Switch in the same Cabinet.

Please HELP - About 800 PC's (with about 20 with this Problem)


jesusdamian Thu, 05/31/2007 - 09:48

We're running into very simliar problems.

You have Portfast disabled on ports connecting to switches or routers right?

are there updated drivers for the nics?

gattererm Thu, 05/31/2007 - 23:00

I have portfast enabled.

But it doesn't make sense if i disable it.

NIC Driver Update to 9.8.20 (Latest) doesn't help...

mark.j.hodge Fri, 06/01/2007 - 02:18

Have you tried setting the ports to "access" or "host"? This will stop the port from trunking.

gattererm Fri, 06/01/2007 - 02:34

I use "switchport access vlan xxx"

I don't use TRUNKING at HOST ports.

mark.j.hodge Mon, 06/04/2007 - 07:25

I suspect that your Computer NIC supports trunking. I believe that the default trunk configuration on the 3550 switch is "dynamic desirable", therefore if the NIC tries to setup a trunk the switch will comply.

If you run the command "switchport mode access" on the swith interface, it will rule this out as a possibility.

You might also want to run "no switchport nonegotiate" to turn off Dynamic Trunking Protocol (DTP)

craig.eyre Thu, 12/13/2007 - 11:11


Just wondering if anybody came up with anything further regarding this issue?




This Discussion