Frame Relay Congestion

Unanswered Question

Hello,

We have 12 remote sites connecting to our main building via frame relay. The 12 sites all have T1 connections and the main site connects to the frame relay with a T1 as well. We are noticing delays with our POS applications and are trying to determine if the network is to blame. The delays are consistent and not specific to either facility.

Could our "over subscription" at the main site cause this delay? Anyway for me to determine if we've maxed out our network?

Thanks in advance.

Dan Cox

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mounir.mohamed Mon, 04/23/2007 - 11:15

Dear,

Check the traffic load on the main branch T1, via any monitroing apllication or via show interface.

Best Regards,

Mounir Mohamed

sundar.palaniappan Mon, 04/23/2007 - 11:21

Dan,

It's very possible over subscription of the T1 at the main site may be causing the delay. I don't know if the remote sites all are fractional or full T1 but it sounds as if the CIR of all the remotes might exceed the capacity of the T1 bandwidth at the main site.

Execute the command 'show frame-relay pvc' on the hub routers and look at the PVC stats for DE/FECN/BECN's. DEs' indicate packets that exceed the CIR value of the DLCI and FECN/BECNs' indicate congestion in the frame relay network.

There are couple of options available for you to deal with this situation. Of course adding more bandwidth, adding a 2nd T1 or getting a fractional DS3, is probably the ideal thing to do to address excessive congestion. However, if that's not possible configure traffic shaping on all the routers to do adaptive shaping on sensing congestion in the network.

HTH

Sundar

Actions

This Discussion