Can not register to CCM 5.x after power off !

Unanswered Question
Apr 23rd, 2007

Hi all !

I have a system including:

- a cluster : one PUB & one SUB (CallManager 5.0.4.2000-1 )

- 80 IP Phones (20 7940G & 60 7911 )

- 15 Switches 2950, one 4507 for VTP Server.

- 12 VG224 for analog phones

Trunks between Switches using Etherchannel, everything is working properly.

I found a problem that:

when electric is lose, IP Phone can not register to CallManager when electric is come back. The status of IP Phones always display " Registering". Howerver, VG224 (analog phone) work normally and some IP Phones can register with CallManager after 4 minutes.

To solve problem with Unregister IP Phone, I must log-in to Switches, "shutdown" port and after that is "no shutdown".

Any ideas to solve this problem ?

Here is my configuration:

Switch:

...

interface FastEthernet0/5

switchport access vlan 5

switchport trunk native vlan 5

switchport mode trunk

switchport voice vlan 150

mls qos trust cos

.....

SWITCH 2950 IOS: c2950-i6q4l2-mz.121-22.EA8a.bin

CALLMANAGER VERSION: 5.0.4.2000-1

IP PHONE FIRMWARE:

- OS LOAD ID: cnu11.3-1-2-26.sbn

- BOOT LOAD ID: tnp11.3-0-1-20.bin

- DSP Load ID: dsp11.1-1-2-26.sbn

- Load file: sccp11.8.-0-3s

- App load ID: jarsccp.8-0-2-25.sbn

- JVM Load ID: cvm11sccp.8-0-2-25.sbn

I think problem can relate to Switch ?? (IOS version of Switch???)

Do I need to open a TAC for this situation ?

Thanks !!

Chidd

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
thisisshanky Mon, 04/23/2007 - 19:50

Can you try a different firmware and see if this makes any difference ? I have seen certain phone loads on 7941/7961 having similar issues, and i have had to unplug the cable (equivalent to shutdown on switch port) to bring the phone back to normal.

chidd Mon, 04/23/2007 - 19:58

Can you suggest the firmware for IP Phone that work properly for CallManager 5.0.4 ?

(Exactly, Unplug the cable is a solution that I used to bring the phone back to normal).

Thanks

MarkMonteleone Mon, 04/23/2007 - 20:03

Don't think its the switch, as I have a similar Vlan setup.(Unless there is an issue with STP) Show log and see if there is any messages...

But I think it has more to do with TFTP/DHCP scope configs or Phone firmware.

Log into Cisco and download and install the lastest Firmware build, and make sure that your TFTP/DHCP scope is setup correctly.

chidd Mon, 04/23/2007 - 20:20

Thanks

I used DHCP/TFTP on Voice Gateway Router.

Here is my configuration:

ip dhcp pool ABC

network 10.65.0.0 255.255.248.0

domain-name abc.com.vn

netbios-node-type p-node

default-router 10.65.0.1

option 150 ip 10.65.0.3 10.65.0.2

dns-server 10.64.16.2

lease 0 5

Description:

- 10.65.0.1 : IP Address of VLAN for voice

- 10.65.0.3 : IP Address of Subscriber

- 10.65.0.2 : IP Address of Publisher

- 10.64.16.2: IP Address of DNS Server (Win2k3)

MarkMonteleone Mon, 04/23/2007 - 20:26

Looks right

So then its either the firmware or SR with CCM5. Call TAC, but if unit is unsupported, try to install the latest firmware on the CCM5 and initiate your own 'power loss'

If at all possible, have your laptop into a port on same switch with same Vlan assignment. Setup as DHCP client and put a continous ping (ping -t)on 4X00. Pull power on 2950 and restore. If the Laptop comes up fine and starts pinging again, then its likely the CCM and/or phone firmware.

Actions

This Discussion