TCL Script Audio Help

Unanswered Question
Apr 24th, 2007

I have a tcl script running on my VG that refences a .au recording prompt located in flash. I need to update the file, but I am having a problem getting the new file to play. I simply deleted the old file, squeezed flash and uploaded the new one. My questions are: 1. What format (encoding, compression, etc.) is required for the file. 2. Is there anything else I need to do to get it going?

Will rate reply.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (5 ratings)
Paolo Bevilacqua Tue, 04/24/2007 - 07:51


the files must be encoded as .au audio, 8 bit, 8KHz, G711u mono. Cisco recommends Adobe Audition as recording software. If you use is, there is a screen where you need to set "16 bit" encoding to make it work. The IVR TCL also specifies an alternate WAV or raw format.

Because all the above is quite complicated I've developed my own script to record messages directly from the phone to a tftp server.

Hope this helps, please rate post if it does!

twissam Sat, 05/05/2007 - 07:56

Looks intresting...

Can we have a copy of this script ;-)

Good day

Paolo Bevilacqua Sat, 05/05/2007 - 10:24

Sure, here it is.

MAIN MENU: 1 to listen, 2 to record.

LISTEN and RECORD MENU: Enter message number (two digits).

Leave any menu with *.

It is working, however there are few things to consider:

1. The recording function is supposed to emit a beep, but it doesn't. So just record after the message ends. Any key to end recording.

2. You cannot re-record messages already played, using the same number - there is something in the audio handling that caches the original file and changes the file names when you try "audio-prompt reload".

So just pick a new number each time and then rename the file as needed.

3. The accompanying audio messages are in Italian :) - You can record your own, subject to 2.

Hope it helps, let me know!

rob.huffman Sun, 05/06/2007 - 07:32

Hi Paolo,

I really thought that this was great that you would share your hard work with the community! You have been a wonderful addition to NetPro since you started participating :) 5 points from me on this one for sure!

Thanks again,


Paolo Bevilacqua Sun, 05/06/2007 - 08:47

Hi Rob,

Thank you, sincerely. I'm also impressed by your exceptional attitude toward everyone. As a consequence, the forum is always an highly recommendable place to pose questions or just have frank, no-nonsense technical talk.

aciscolook Mon, 05/05/2008 - 23:08


I was wondering if you could explain how to use your script?

Do you load it into the CME flash and then configure it as an application? If this is the case can you include a sample of the configs?



This Discussion