Switchport goes down when moving from auto to 1000/Full

Unanswered Question
Apr 25th, 2007

Hi - I have got 2 3560s runnning 12.2(25)SEB4 connected to each other over 2 Gig TX links in a channel. Config of each is below;

Switch 01

!

interface GigabitEthernet0/47

description *** Etherchannel to Switch 02 ***

channel-group 1 mode auto

!

interface GigabitEthernet0/48

description *** Etherchannel to Switch 02 ***

channel-group 1 mode auto

Switch 02

interface GigabitEthernet0/47

description *** Etherchannel to Switch 01 ***

channel-group 1 mode desirable

!

interface GigabitEthernet0/48

description *** Etherchannel to Switch 01 ***

channel-group 1 mode desirable

!

This works fine. However, if I then hard code Switch 01's speed and duplex to 1000/Full for port g0/47, and do the same on Switch 02, the link goes down. The port status says not connected. It remains like that even if I remove the channel-group config so the config is as follows;

Switch 01

!

interface GigabitEthernet0/47

description *** Etherchannel to Switch 02 ***

duplex full

speed 1000

Switch 02

interface GigabitEthernet0/47

description *** Etherchannel to Switch 01 ***

duplex full

speed 1000

Can anyone tell me the possible cause of this?

Many Thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
ankbhasi Wed, 04/25/2007 - 03:05

Hi Friend,

When you just change the speed and suplex settings for one single port on port channel it brings an inconsistency in etherchannel configuration.

Etherchannel confiog guidelines says

Configure all ports in an EtherChannel to operate at the same speeds and duplex modes

Can you try changing the speed and duplex settings on all 4 ports?

Regards,

Ankur

Amit Singh Wed, 04/25/2007 - 03:23

All the ports in the channel have to be with the same config. All the ports settings related to speed/duplex,STP,trunking have to be eaxctly same on all the ports. If its not the switch detects it as a ether-channel mis-configuration and brings the channel down.

However, if you have removed the channel config, the link come up fine. What if you take the channel config out, set all the ports to auto and then hardcore the speed and duplex on the switchports.One of the port should go to STP blcoking mode as you are not running ether-channel config on the switches.

HTH,

-amit singh

d-fillmore Wed, 04/25/2007 - 03:57

Hi guys, thanks for your responses.

With all etherchannel configuration removed, the configs look like this;

Switch 01

interface GigabitEthernet0/47

description *** Etherchannel to Switch 02***

duplex full

speed 1000

!

interface GigabitEthernet0/48

description *** Etherchannel to Switch 02 ***

duplex full

speed 1000

!

Switch 02

interface GigabitEthernet0/47

description *** Etherchannel to Switch 01 ***

duplex full

speed 1000

!

interface GigabitEthernet0/48

description *** Etherchannel to Switch 01 ***

!

At soon as the settings were hard coded on Switch 02's port g0/47, the port went down.

As the port is down (not connected) so spanning tree didn't shut it down.

I want to hard code the settings on Switch 02's port g0/48, but I am doing this remotely and accessing Switch 02 through Switch 01 so I run the risk of disconnecting the switch unless I do a scheduled reload which I don't think my customer will go for.

Any other ideas?

Cheers, Dom

Actions

This Discussion