Monitoring Bandwidth on Switch

Unanswered Question
Apr 25th, 2007

Is there an way to monitor the bandwidth per port on a 4506?? I know that CNA lets you monitor the overall bandwidth and you can do link bandwidth monitoring but is there a way to track it by IP or MAC address back to the source??

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
pciaccio Wed, 04/25/2007 - 06:06

If you are running CATOS then the SHOW TOP command will help you. If you are running IOS based switch then you can enable CEF and Route Cache Flow on the interface. and use the Show Cache Flow as well as Show Accounting commands to assist you.

gzbrowniii Wed, 04/25/2007 - 06:39

Here is my config file - I think I have an IOS switch. I have the SUP II-Plus eng in it.

sh run

Building configuration...

Current configuration : 3815 bytes

Last configuration change at 15:33:52 EST Mon Apr 23 2007

NVRAM config last updated at 15:33:24 EST Mon Apr 23 2007

version 12.2

no service pad

service timestamps debug uptime

service timestamps log datetime

no service password-encryption

service compress-config

service sequence-numbers

hostname tfg4506


boot system flash bootflash:


enable password ************

no aaa new-model

clock-timezone EST -5

qos dbl

qos map dscp 24 25 26 27 28 29 30 31 to tx-queue 4

qos map dscp 32 33 34 35 36 37 38 39 to tx-queue 4

qos map cos 3 to dscp 26

qos map cos 5 to dscp 46


ip subnet-zero

ip name-server

ip name-server

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

power redundancy-mode redundant

vlan internal allocation policy ascending

policy-map autoqos-voip-policy

class class-default


interface GigabitEthernet1/1

interface GigabitEthernet1/2

interface GigabitEthernet2/1

description Uplink to IDF1

service-policy output autoqos-voip-policy

qos trust cos

auto qos voip trust

tx-queue 3

bandwidth percent 33

priority high

shape percent 33

macro description cisco-switch

spanning-tree link-type point-to-point

interface GigabitEthernet2/2

interface GigabitEthernet2/3

interface GigabitEthernet2/4

interface GigabitEthernet2/5

interface GigabitEthernet2/6

interface GigabitEthernet3/1

description Uplink 3Com 2848-1

interface GigabitEthernet3/2

description Uplink 3Com 2848-2

interface GigabitEthernet3/3

description Uplink 3Com 2848-3

interface GigabitEthernet3/4

description Uplink VPN

interface GigabitEthernet3/5

description Uplink AFW Router

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

service-policy output autoqos-voip-policy

qos trust dscp

auto qos voip trust

tx-queue 3

priority high

shape percent 33

macro description cisco-router

spanning-tree portfast

spanning-tree bpduguard enable

interface GigabitEthernet3/6

interface GigabitEthernet3/7

interface GigabitEthernet3/8

interface GigabitEthernet3/9

interface GigabitEthernet3/10

interface GigabitEthernet3/11

interface GigabitEthernet3/12

interface GigabitEthernet3/13

interface GigabitEthernet3/14

interface GigabitEthernet3/15

interface GigabitEthernet3/16

interface GigabitEthernet3/17

interface GigabitEthernet3/18

interface GigabitEthernet3/19

interface GigabitEthernet3/20

description Uplink Netgear

interface GigabitEthernet3/21

interface GigabitEthernet3/22

interface GigabitEthernet3/23

interface GigabitEthernet3/24

interface GigabitEthernet3/25

interface GigabitEthernet3/26

interface GigabitEthernet3/27

interface GigabitEthernet3/28

interface GigabitEthernet3/29

interface GigabitEthernet3/30

interface GigabitEthernet3/31

interface GigabitEthernet3/32

interface GigabitEthernet3/33

interface GigabitEthernet3/34

interface GigabitEthernet3/35

interface GigabitEthernet3/36

interface GigabitEthernet3/37

interface GigabitEthernet3/38

interface GigabitEthernet3/39

interface GigabitEthernet3/40

interface GigabitEthernet3/41

interface GigabitEthernet3/42

interface GigabitEthernet3/43

interface GigabitEthernet3/44

interface GigabitEthernet3/45

interface GigabitEthernet3/46

interface GigabitEthernet3/47

interface GigabitEthernet3/48

interface Vlan1

ip address

ip default-gateway

ip route

ip route

ip route

ip route

ip route

ip http server

line con 0

line vty 0 4

no login

length 0

royalblues Wed, 04/25/2007 - 07:46

Configure SNMP on the switches and use a network monitoring tool like solarwinds, MRTG


These will give you the utilization statictics.

If you want to view the protocol statistics, then enable netflow but that would depend whether your SUP supports netflow features

HTH, rate if it does



This Discussion