Lossing BGP neighbourship on applying VRF Forward interface cmd.

Unanswered Question
Apr 26th, 2007
User Badges:

Hi,

I am trying to setup a lab to understand send IP traffic over MPLS cloud.


The problem is, I loose BGP neighbourship with the CE once I applied "ip vrf forward xyz" at the PE interface to the CE. I re-enter the IP address after applying the cmd.


I have attached a drawing shows the lab setup, as well as text file for each router, show the running-config and show ip bgp.



Appreciate your advise, on why do I loose connectivity between PE and CE on applying VFR Forward interface cmd..


Thanks


Sami





  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Harold Ritter Thu, 04/26/2007 - 14:24
User Badges:
  • Cisco Employee,

Sami,


On the PE, the "show ip bgp summary" will not show you the bgp session between the PE and CE as this command only shows the sessions for address-family IPv4.


You need to do a "show ip bgp vpnv4 vrf 23:2 summary" to see it.


Please refer to the follwoing documentation section for more information on this command:


http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124tcr/tmpls_r/mpl_s6ht.htm#wp1013288


Hope this helps,

ssalem Thu, 04/26/2007 - 22:20
User Badges:

Thanks, definite it helped, but I hasn't reached the objective of setting the lab, yet.


I want to see the Lo0 of CE1 shows up at CE2 routing table and vise versa. I believe this is the IP/MPLS.


Can you tell me what I am missing.


Again, thanks

mohammedmahmoud Fri, 04/27/2007 - 00:20
User Badges:
  • Green, 3000 points or more

Hi there,


When doing "show ip bgp vpnv4 vrf 23:2 summary" on PE1, do you get any State/PfxRcd from CE1, and please try the same on PE2.


BR,

Mohammed Mahmoud.

ssalem Fri, 04/27/2007 - 00:39
User Badges:

Thanks Mohd.,

I do get 2 prefixes from the CEs.


I have attached a text file shows the output at the PEs, as well as the show ip route at one of the CEs.


Please advise on, why the routes hasn't been installed at the CEs routing table.


Thanks



mohammedmahmoud Fri, 04/27/2007 - 00:50
User Badges:
  • Green, 3000 points or more

Hi there,


I think the problem is between PE1 and PE2, they are not exchanging the routes, can you please attach the full configuration of PE1 and PE2.


HTH,

Mohammed Mahmoud.

mheusinger Fri, 04/27/2007 - 01:47
User Badges:
  • Green, 3000 points or more

Hi, can you check the route-targets attached on both PEs with

"show bgp vpnv4 unicast all 24.24.24.0"

Additionally check the existance of a VPNv4 BGP session between PEs

"show bgp vpnv4 unicast all summary"


The config looks more or less ok (some commands are irrelevant or obsolete in your setup).

What are the results of the above show commands?


Regards, Martin



ssalem Fri, 04/27/2007 - 02:06
User Badges:

Hi Martin,

I am glad you become involved. The cmd you recommended (show bgp vpnr4 unicast) is not supported in my IOS ver.


Please see below:-

r2_PE1#sh ip bgp vpnv4 ?

* Display information about all VPNv4 NLRIs

all Display information about all VPNv4 NLRIs

rd Display information for a route distinguisher

vrf Display information for a VPN Routing/Forwarding instance


r2_PE1#sh ip bgp vpnv4 all su

r2_PE1#sh ip bgp vpnv4 all summary

BGP router identifier 2.2.2.2, local AS number 23

BGP table version is 13, main routing table version 13

2 network entries using 242 bytes of memory

2 path entries using 128 bytes of memory

6 BGP path attribute entries using 360 bytes of memory

1 BGP AS-PATH entries using 24 bytes of memory

1 BGP extended community entries using 24 bytes of memory

0 BGP route-map cache entries using 0 bytes of memory

0 BGP filter-list cache entries using 0 bytes of memory

BGP using 778 total bytes of memory

BGP activity 8/3 prefixes, 13/7 paths, scan interval 15 secs


Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd

24.24.24.4 4 45 293 289 13 0 0 04:06:03 2

r2_PE1#


mohammedmahmoud Fri, 04/27/2007 - 03:07
User Badges:
  • Green, 3000 points or more

Hi there,


From your output, PE1 is receiving the routes from CE1, can you do the same on PE2 (show ip bgp vpnv4 all summary).


It seems that you've not added the neighbor activate command under the address-family vpnv4 to enable MBGP between both PE routers (disabled by default).


HTH, please rate if it does,

Mohammed Mahmoud.

mheusinger Fri, 04/27/2007 - 03:49
User Badges:
  • Green, 3000 points or more

Hi,


The somewhat older IOSes use "show ip bgp vpnv4 [all|rd|vrf] ..." instead of "show bgp vpnv4 unicast [all|rd|vrf] ...".

The problem is, as Mohammed pointed out, that there is no VPNv4 address-family exchanged between your two PE routers. Corrected BGP config:


PE1

no router bgp 23

router bgp 23

no synchronization

no bgp log-neighbor-changes

no bgp default ipv4-unicast

neighbor 3.3.3.3 remote-as 23

neighbor 3.3.3.3 update-source Loopback0

neighbor 3.3.3.3 soft-reconfiguration inbound

no auto-summary

!

address-family vpnv4

neighbor 3.3.3.3 activate

neighbor 3.3.3.3 next-hop-self

neighbor 3.3.3.3 send-community extended

exit-address-family

!

address-family ipv4 vrf ONE

neighbor 24.24.24.4 remote-as 45

neighbor 24.24.24.4 activate

neighbor 24.24.24.4 send-community extended

neighbor 24.24.24.4 as-override

! neighbor 24.24.24.4 allowas-in !not needed in your current setup

no auto-summary

no synchronization

exit-address-family


PE2


no router bgp 23

router bgp 23

no synchronization

no bgp log-neighbor-changes

no bgp default ipv4-unicast !remark1 below

neighbor 2.2.2.2 remote-as 23

neighbor 2.2.2.2 update-source Loopback0

neighbor 2.2.2.2 soft-reconfiguration inbound

no auto-summary

!

address-family vpnv4

neighbor 2.2.2.2 activate

neighbor 2.2.2.2 next-hop-self

neighbor 2.2.2.2 send-community extended

exit-address-family

!

address-family ipv4 vrf ONE

neighbor 35.35.35.5 remote-as 45

neighbor 35.35.35.5 activate

neighbor 35.35.35.5 send-community extended

neighbor 35.35.35.5 as-override

!neighbor 35.35.35.5 allowas-in !not needed in your current setup

no auto-summary

no synchronization

exit-address-family


remark1: This turns off address-faily IPv4, which is not needed for MPLS VPNs. The result is, that you will not get any output f.e. from "show ip bgp summary". This forces you to use the proper commands to troubleshoot VPNv4.


Hope this helps! Please rate all posts.


Regards, Martin

ssalem Fri, 04/27/2007 - 07:30
User Badges:

Thanks martin, Lab objective is met.

Actions

This Discussion