CTI application failed to open provider

Unanswered Question
Apr 27th, 2007
User Badges:

Error: kCtiProviderOpenFailure - CTI application failed to open provider

CTIconnectionId: 34233

Login User Id: CCMSysUser

Reason code.: -1932787616

IPAddress:

App ID: Cisco CTIManager

Cluster ID: StandAloneCluster

Node ID: 10.64.224.100

Explanation: Application is unable to open provider.

Recommended Action: Check the reason code and correct the problem. Restart CTIManager if problem persists..



After reload of Call Manager I get this error on CCM. Before reload everything works well.

I have tried to change pass for CCMSysUser with CCMPWDChanger but I got error:

ERROR: 53 - The network path was not found


Account CCMSysUser is locked out on AD.


What to do?

Where is a problem?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mchandak Fri, 04/27/2007 - 16:42
User Badges:
  • Gold, 750 points or more

Sounds like there is some issue with CallManager being able to access this account in AD. Make sure that you have network connectivity working fine between CM and AD and also ensure that this account is not disabled. It always has to be enabled

vjemin Sat, 04/28/2007 - 07:32
User Badges:

Everything is fine with network connectivity.


On what account you think dcdadmin or CCMSysUser?


dcdadmin is fine, I can log on AD with that password. When I unlock CCMSysUser for half minute it get locked . CCMSysUser is trying to access to AD and it get locked because of wrong password.

mchandak Sun, 04/29/2007 - 00:57
User Badges:
  • Gold, 750 points or more

looks like u have a password policy which is getting applied to this account. It is always recommended not to apply any security policy, esp account lockout policy the 3 CCM* accounts. Once the lockout policy is removed, run CCMPwdChanger and reset the password for this account

vjemin Sun, 04/29/2007 - 11:02
User Badges:

Well I have tried to do that but in the meantime user get locked. Do I need to stop some services?

mchandak Sun, 04/29/2007 - 13:29
User Badges:
  • Gold, 750 points or more

if the user is getting locked that means the policy changes have not taken affect. AFAIK, you dont need to restart any service to get around this. Once the Policies applied on the user is changed it should take affect. One more thing you can try is, use your CCM Sysuser password to get an encrypted value using the tool PasswordUtils (C:\dcdsrvr/bin). Once you get this password, Update Registry (HKLM/Software/Cisco Systems, Inc/Directory Configuration/AppUsers/CCMSysUser and modify this registry field with the encrypted field and then unlock the accunt for AD.


If you are not comfortable playing the Registry, open a TAC case.

vjemin Mon, 04/30/2007 - 03:10
User Badges:

Hi,


I have tried like you said and it didn't work!

I have changed encrypted pass in Registry and I have changed again password on AD and unlock user. After that, the user get locked again.


mchandak Mon, 04/30/2007 - 04:08
User Badges:
  • Gold, 750 points or more

How many CallManagers are connected to this AD ?? Remember that all callmanagers connected would use the same CCMSysUser account and therefore if you have any other server sitting in the network which could be causing this issue.


Incase this does not help, open a TAC case. That would have it easy to troubleshoot the issue.

vjemin Mon, 04/30/2007 - 05:30
User Badges:

hehehe

What to say!!!??


Thanks a lot. I have forgot on my subscriber.

Thanks a lot with registry things, that was very helpful!


Now, I have some processes in memory which are open and I have lost memory. Hm, I must trace situation these days.

mchandak Mon, 04/30/2007 - 05:57
User Badges:
  • Gold, 750 points or more

For Memory Loss, I think it would be good to start a new thread with the following info, so that we can get the right response.


1. Processes which are consuming Memory and the amount of memory being used

2. CallManager version

3. OS Version

vjemin Mon, 04/30/2007 - 06:17
User Badges:

1. regsvc.exe; sqlservr.exe

2. 4.1(2)

3. OS Image: 2000.2.6

OS SR: 2000.2.6sr6



Maybe it was problem with passwords and CCMSysUser and lot of open connections toward AD?

Actions

This Discussion