What's a good way to mark DSCP values for a vlan in a 3750?

Answered Question
Apr 27th, 2007
User Badges:

On a 3750 switch I want to mark all packets on our data vlan, vlan 10, to dscp '0', before they get to the upstream router. I'm having trouble finding the right commands to do this....something that will both match on a vlan #, and also be able to 'set dscp 0'.


What is the best way to do this?

Correct Answer by royalblues about 10 years 2 months ago

Friend,


You can modify the class-map i suggested and mark the vocie packets to DSCP EF


ip access-list extended data

permit ip any


ip access-list extended voice

permit ip any range 16384 32767


class-map match-all set-dscp

match access-group name data


class-map match-all set-dscp-voice

match access-group name voice


policy-map upstream-QoS

class set-dscp-voice

set ip dscp ef

class set-dscp

set ip dscp 0


apply this policy inbound to the switch ports


int g0/1

service-pollicy input upstream-QoS


HTH, rate if it does

Narayan


Correct Answer by wochanda about 10 years 3 months ago

policy-map Vlan10

class class-default

set ip dscp 0


interface gi0/1

mls qos vlan-based


interface Vlan10

service-policy input Vlan10


For more info:

http://www.cisco.com/univercd/cc/td/doc/product/lan/cat3750/12225see/scg/swqos.htm#wp1552680


Will

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Loading.
royalblues Sat, 04/28/2007 - 08:17
User Badges:
  • Green, 3000 points or more

There is another way to do it though the method suggested by Will is more suited


Since the data vlan will be having a seperate subnet you can also match that subnet and set the DSCP to 0


ip access-list extended data

permit ip any


class-map match-all set-dscp

match access-group name data


policy-map upstream-QoS

class set-dscp

set ip dscp 0


apply this policy inbound to the switch ports


int g0/1

service-pollicy input upstream-QoS


HTH, rate if it does

Narayan



jkeeffe Mon, 04/30/2007 - 08:42
User Badges:

When I apply your suggestion, it removes the interface command 'mls qos trust dscp' which I need to trust the dscp values of the phone.


Here is what I originally have on the interface:


interface FastEthernet1/0/11

description IP Phone and PC

switchport access vlan 10

switchport mode access

switchport voice vlan 910

speed 100

duplex full

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust dscp

auto qos voip trust

spanning-tree portfast

end


Here is the config after applying the vlan-based Qos:


interface FastEthernet1/0/11

description Phone/PC w/o trunk to lab PBX

switchport access vlan 10

switchport mode access

switchport voice vlan 910

speed 100

duplex full

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos vlan-based

auto qos voip trust

spanning-tree portfast

end


How would I make sure that the DSCP values of the IP phone were kept intact?

Correct Answer
royalblues Mon, 04/30/2007 - 08:50
User Badges:
  • Green, 3000 points or more

Friend,


You can modify the class-map i suggested and mark the vocie packets to DSCP EF


ip access-list extended data

permit ip any


ip access-list extended voice

permit ip any range 16384 32767


class-map match-all set-dscp

match access-group name data


class-map match-all set-dscp-voice

match access-group name voice


policy-map upstream-QoS

class set-dscp-voice

set ip dscp ef

class set-dscp

set ip dscp 0


apply this policy inbound to the switch ports


int g0/1

service-pollicy input upstream-QoS


HTH, rate if it does

Narayan


Actions

This Discussion