got my rack

Answered Question
Apr 28th, 2007
User Badges:

ok I just invested on some cisco equip

here is what I have

3 x 2610

12 port 2900 xl

24 port 2900 xl

2511 access server

2501


I would like to access all the swithces and router w/ out removing the cable using the access server 2511 .. can I do that ? or I have to configure each device then see how I can connected then w/ Asynchronous Serial Interface Breakout Cable ..thanks




Correct Answer by mohammedmahmoud about 9 years 12 months ago

Hi Karim,


Can you please configure the loopback interface and use it instead of the ethernet interface.


And can you please post your configuration if the problem persists.



HTH, please rate all helpful posts,

Mohammed Mahmoud.

Correct Answer by mohammedmahmoud about 10 years 1 day ago

Hi,


If i understand you correct, you are trying to do reverse telnet from the 2511 to your devices, accordingly you'll need this configuration:


under the serial interface (If A/S):

physical-layer async


under the async line:


transport input telnet

stopbits 1


and connect the cables to the console of your devices.


Issue this command to establish a reverse Telnet connection from your 2511:


telnet x.x.x.x 2yyy or [2000+yyy]


The x.x.x.x represents the IP address of any up/up interface on the Cisco router (recommended to be a Loopback) and yyy is the line number to which you want to connect. If you have already configured the TTY line, you can issue the telnet command from anywhere on the network that can ping the x.x.x.x interface.


To disconnect, hit Ctrl-Shift-6 and then x to get back to the router prompt and then type in disconnect to close the connection.

Note: Make sure you close the connection or it will not work.


HTH, please rate if it does help,

Mohammed Mahmoud.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.6 (5 ratings)
Loading.
balajitvk Sat, 04/28/2007 - 21:09
User Badges:
  • Silver, 250 points or more
cisco steps Sun, 04/29/2007 - 06:15
User Badges:

this was not clear, I think I still have to config each router separatly w/ each one have new Ip address, once that done then I can access the 2511 access server and give it the info on each router in the network..pls correct me if I am wrong .. thanks for the reply...

Correct Answer
mohammedmahmoud Sun, 04/29/2007 - 06:42
User Badges:
  • Green, 3000 points or more

Hi,


If i understand you correct, you are trying to do reverse telnet from the 2511 to your devices, accordingly you'll need this configuration:


under the serial interface (If A/S):

physical-layer async


under the async line:


transport input telnet

stopbits 1


and connect the cables to the console of your devices.


Issue this command to establish a reverse Telnet connection from your 2511:


telnet x.x.x.x 2yyy or [2000+yyy]


The x.x.x.x represents the IP address of any up/up interface on the Cisco router (recommended to be a Loopback) and yyy is the line number to which you want to connect. If you have already configured the TTY line, you can issue the telnet command from anywhere on the network that can ping the x.x.x.x interface.


To disconnect, hit Ctrl-Shift-6 and then x to get back to the router prompt and then type in disconnect to close the connection.

Note: Make sure you close the connection or it will not work.


HTH, please rate if it does help,

Mohammed Mahmoud.

cisco steps Sun, 04/29/2007 - 07:42
User Badges:

Mohamed thanks for the input..


I am not near my lab, but I will be later on, If i understand you correct..


I need to use the async cable that have a 8 rj 45, connect scsi to 2511 and then each ethernet cable from the same cable to eacn router.. then go to my 2511 access server and telnet to 172.1.1.1 2yyy.. what is 2yyy and how I can find it.. I am about the hit the books once I get the devices working and talking to each other .. Thanks Mo


karim

mohammedmahmoud Sun, 04/29/2007 - 09:28
User Badges:
  • Green, 3000 points or more

Hi Karim,


You have got it right, since the CAB-OCTAL-ASYNC cable is itself rolled, you can connect each cable directly to the console ports of devices with the RJ-45 interfaces.


After adding "transport input telnet" and "stopbits 1" under the lines, all that you have to do next is to do "show line" and then add the number to 2000 thats how you get the 2yyy number (port number) to use to reverse telnet, ex: for line 5 use 2005.


Each line corresponds to an RJ-45 cable and thus to one of your devices.


you can add an Alias for each of your devices:


ip host

ex: ip host 2611 2013 172.21.1.1


Enjoy :)


HTH, please rate if it does help,

Mohammed Mahmoud.

cisco steps Sun, 04/29/2007 - 10:38
User Badges:

Mo

Thanks a lot...I think I got it, if any question will let you know, can wait to go home and play .

mohammedmahmoud Sun, 04/29/2007 - 10:43
User Badges:
  • Green, 3000 points or more

Hi Karim,


You are more than welcomed, and i hope you'll enjoy your lab, and please don't hesitate for any further questions.


BR,

Mohammed Mahmoud.

cisco steps Mon, 04/30/2007 - 07:23
User Badges:

Hi Mo


I just tried to telnet to 2610 router from the 2511 access server but got this msg. I can see the console light green in the back flashing time to time, am I missing anything..


Thanks


R3#telnet 172.1.1.1 2008

Trying 172.1.1.1, 2008 ...

% Destination unreachable; gateway or host down




show line

*****************


Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns

* 0 CTY - - - - - 0 0 0/0

1 TTY 9600/9600 - - - - - 0 0 0/0

2 TTY 9600/9600 - - - - - 0 0 0/0

3 TTY 9600/9600 - - - - - 0 0 0/0

4 TTY 9600/9600 - - - - - 0 0 0/0

5 TTY 9600/9600 - - - - - 0 0 0/0

6 TTY 9600/9600 - - - - - 0 0 0/0

7 TTY 9600/9600 - - - - - 0 0 0/0

* 8 TTY 9600/9600 - - - - - 0 0 41/127



shillyar Mon, 04/30/2007 - 08:01
User Badges:
  • Cisco Employee,

Hello,


You can do that fine just make sure your main ip address is up up or you will not be able to telnet to the console ports.


telnet 172.1.1.1 2008 172.1.1.1 need to be an up up interface and the console will cable will be on port 8. Many people just create a loop back for comservers. Then you can create an host for every console port or you can do a manual telnet to each port.


Im assuming you are using the octupus cable. The cable will be labeled with each async port #.


make sure under your lines you have "transport inpu


Thanks Steve

cisco steps Mon, 04/30/2007 - 09:45
User Badges:

Hi shillyar


when you say main ip address is up up ? is this on the server or on the 2600... Thanks

mohammedmahmoud Mon, 04/30/2007 - 09:57
User Badges:
  • Green, 3000 points or more

Hi Karim,


All that you need is a loopback ip on your 2511 (comm-server), these 2 lines under your lines:



transport input telnet

stopbits 1


Before doing the reverse telnet, do the "show line" and make sure that there is no * beside your desired line (* means that it is in use), accordingly do a "clear line x" until the * disappears, and then try your reverse telnet.



HTH, please rate if it does help,

Mohammed Mahmoud.

cisco steps Mon, 04/30/2007 - 10:09
User Badges:

Hi Mo


how are you ?


so once the 2511 is up I will type


#transport input telnet

#stopbits 1


is that what you mean ?


Thanks again , I know I am asking lot of questions for newbie .. but I am just eager to get my lab up so I can start preping for my CCNA..



Thank you all that responded


karim



mohammedmahmoud Tue, 05/01/2007 - 01:19
User Badges:
  • Green, 3000 points or more

Hi Karim,


No these 2 lines, must be configured under the line configuration mode, when you do sh run it should look something like this:


line 65 80

transport input all

stopbits 1


You are very welcomed, and i hope you'll enjoy your lab :)


HTH, please rate all helpful posts,

Mohammed Mahmoud.

cisco steps Tue, 05/01/2007 - 16:37
User Badges:

I am so confused, I try to do it myself and was not able too.I do not want to give up . I am sure once ITS UP I can proceed but for now still no comunication b/w comm-server and 2610 router/ I did #show user all command as well as #show line 8 here is what i got




**********************************************

3#show line 8

Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns

* 8 TTY 9600/9600 - - - - - 0 0 1/7


Line 8, Location: "", Type: ""

Length: 24 lines, Width: 80 columns

Baud rate (TX/RX) is 9600/9600, no parity, 2 stopbits, 8 databits

Status: Ready, Active

Capabilities: none

Modem state: Ready

Special Chars: Escape Hold Stop Start Disconnect Activation

^^x none - - none

Timeouts: Idle EXEC Idle Session Modem Answer Session Dispatch

0:10:00 never none not set

Session limit is not set.

Time since activation: 0:05:08

Editing is enabled.

History is enabled, history size is 10.

Full user help is disabled

Allowed transports are pad telnet rlogin. Preferred is telnet.

No output characters are padded

No special data dispatching characters

Modem hardware state: CTS* DSR* DTR RTS


**********************************************


R3#show run

Building configuration...


Current configuration:

!

version 11.0

service password-encryption

service udp-small-servers

service tcp-small-servers

!

hostname R3

!

enable secret xxx

enable password xxx

!

no ip domain-lookup

!

interface Ethernet0

ip address 172.23.23.3 255.255.255.0

shutdown

!

interface Serial0

no ip address

shutdown

no fair-queue

!

interface Serial1

no ip address

shutdown

!

ip name-server 10.10.10.10

!

line con 0

password xxx

login

line 1 16

transport input all

line aux 0

transport input all

line vty 0 3

login

line vty 4

password xxx

login

!

end

mohammedmahmoud Tue, 05/01/2007 - 22:44
User Badges:
  • Green, 3000 points or more

Hi Karim,


All that you'll need is:


interface loopback 0

ip address x.x.x.x y.y.y.y


line 1 16

transport input telnet

stopbits 1


and then do the reverse telnet:


telnet x.x.x.x 2nnn


where nnn = the line number, ex: if 8 then nnn = 008.


Before doing this do show line, and make sure that there is no * beside the line before doing this, and if there is a * do clear line x until the * disappear.



Be calm and take it easy and it will work.



I hope that i've been informative for you.


HTH, please rate if it does help,

Mohammed Mahmoud.

CSCO10892433 Wed, 05/02/2007 - 01:37
User Badges:
  • Silver, 250 points or more

Hi, ocporbust


All the interfaces on the 2511 are shutdown. In that case, it is impossible to create any successful telnet session. Please type the following command sequence and see if it works for you?


config t

int lo0

ip address 172.16.1.1 255.255.255.255

line 1 16

transport input telnet

no exec

end

telnet 172.16.1.1 2008


HTH

SSLIN

cisco steps Wed, 05/02/2007 - 10:44
User Badges:

R3#telnet 172.16.1.1 2008

Trying 172.16.1.1, 2008 ...

% Connection refused by remote host

Correct Answer
mohammedmahmoud Wed, 05/02/2007 - 10:48
User Badges:
  • Green, 3000 points or more

Hi Karim,


Can you please configure the loopback interface and use it instead of the ethernet interface.


And can you please post your configuration if the problem persists.



HTH, please rate all helpful posts,

Mohammed Mahmoud.

cisco steps Wed, 05/02/2007 - 11:01
User Badges:

yah mohammed wald mahmoud . you did it .. I am in :-) .. what is a diffence b/w your config and the previouse helper ,, now I can go head and configure the rest of the routers. Thanks a million/

mohammedmahmoud Wed, 05/02/2007 - 11:07
User Badges:
  • Green, 3000 points or more

Hi Karim,


I am glade that you've done it ... please do enjoy :)


And please don't hesitate for further questions.


BR,

Mohammed Mahmoud.

Actions

This Discussion