How to disable the speaker for one IP phone?

Unanswered Question
Apr 30th, 2007

CME 4.1

one 7961, several 7941 and 7911

The 7961 is for reception. The customer wants only disable the speaker on 7961.

But the service parameters in the telephone-service configuration are applied to all phones. How can I disable only one phone's speaker?

Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
MikeTomasko Mon, 04/30/2007 - 11:03

I'm running CCM 4.1(3) and if you pull up a device you can click the checkbox to disable the speaker phone. And since you are pulling up a device to do it, it's only gonna affect that one device.

michaelzhq Mon, 04/30/2007 - 11:24

Yes, it is easy to disable a speaker on any IP Phone in CCM4.x or 5.x.

But my system is CallManager Express 4.1, I have no idea how to disable one(only one) phone's speaker.

rob.huffman Mon, 04/30/2007 - 11:40

Hi Michael,

This can be done on CME on a phone by phone basis. Have a look;

service phone

To modify the vendorConfig parameters in the configuration file, use the service phone command in telephony-service or ephone-template configuration mode. To disable a setting, use the no form of this command.

service phone parameter-name parameter-value

no service phone parameter-name parameter-value

This command in telephony-service configuration mode modifies vendorConfig parameters in the configuration file for phones in a Cisco Unified CME system.

In Cisco Unified CME 4.0 and later versions, support for creating configuration files at a per-phone level was supported and this command in ephone-template configuration mode creates an ephone-template of vendorConfig parameters which can then be applied to an individual Cisco Unified IP phone in Cisco Unified CME.

disableSpeaker {true | false}

Enables and disables the speakerphone.

true Enabled (default).

false Disabled.

Router(config)# telephony-service

Router(config-telephony)# service phone disableSpeaker false

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_command_reference_chapter09186a008061137f.html#wp1123331

The following example shows how to disable the Speakerphone on an individual IP phone (ephone 15) using an ephone template:

Router(config)# ephone-template 8

Router(config-ephone-template)# service phone disableSpeaker false

Router(config-ephone-template)# exit

Router(config)# ephone 15

Router(config-ephone)# ephone-template 8

Router(config-ephone)# exit

Router(config)# telephony-service

Router(config-telephony)# create cnf-files

Router(config-telephony)# exit

Router(config)# ephone 15

Router(config-ephone)# reset

Hope this helps!

Rob

michaelzhq Mon, 04/30/2007 - 13:27

Thanks a lot Rob.

I tried the configuration but it doesn't work. The speaker is always enabled.

I also tested the configuration with the settingsAccess key(0--disable), same problem(always enabled). Maybe there are other problems which I don't know.

Michael

neesharm Mon, 04/30/2007 - 22:52

On a physical phone, press settings- go to network configuration - enter 45 or 44 depending upon model (handset

only mode) - press **# you see your options on the soft key. handset only mode=Yes will

disable speaker phone. Save - exit.

michaelzhq Tue, 05/01/2007 - 07:17

Thanks.

The solution works with 7940/7960, but there is no "handset only mode" configuration on 7941/7961. I can see "Handset Enable Yes" and "Speaker Enable Yes" in the "Media Configuration", which is one of sub-menu of "Device Configuration". It looks like I can't change the setting because there is no softkey available on the display.

smithgrs Thu, 07/12/2007 - 10:37

Hi,

I had the exact same problem that you have. I resolved this issue by doing two things.

First, the Cisco documentation with regards to "disableSpeaker {true | false}" seems to be backwards or my thinking is, not sure which. Anyhow, I found that changing it to "true" actually disabled the speaker.

Example:

Router(config-ephone-template)# service phone disableSpeaker true

Secondly, by default CME 4.0 and above ignores vendorcfg entries when using the default phone profile located on default file system (system:). To use ephone templates with CME 4.0 and above you have to reconfigure so CME uses per phone profiles located on another files system such as flash:.

Example:

Router(config)# telephony-service

Router(config-telephony)#cnf-file location flash:

Router(config-telephony)#cnf-file perphone

This enables CME to create individual cfg files for each phone. Vendorcfg entries assigned by the ephone templates are placed in these files where it can correctly be read by the phones.

Here is what I ended up using and everything seems to be working fine:

Router(config)# telephony-service

Router(config-telephony)#cnf-file location flash:

Router(config-telephony)#cnf-file perphone

Router(config)#ephone-template 10

Router(config-ephone-template)#service phone disableSpeaker true

Router(config-ephone-template)#exit

Router(config)#ephone 2

Router(config-ephone)#ephone-template 10

Router(config-ephone)#exit

Router(config)#telephony-service

Router(config-telephony)#create cnf-files

Router(config-telephony)#exit

Ref docs:

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_command_reference_chapter09186a008061137f.html#wp1123331

http://www.cisco.com/en/US/products/sw/voicesw/ps4625/products_configuration_guide_chapter09186a00808777f8.html#wp1028761

I hope this helps.

Gary

Paolo Bevilacqua Thu, 07/12/2007 - 16:01

Great info Gary, especially the about hot to make the custom settings work properly in per-phone mode. I've rated this post a'5'.

Actions

This Discussion