FRR with Auto tunnel Primary and Explicit Backup

Unanswered Question
May 1st, 2007
User Badges:

Hi

Is it possible to setup a Automesh for Primary TE tunnel and explicit

backup tunnels for FRR.I was trying to configure this,but FRR doesnt

seem to be working,though both the tunnels are up. when I break the

primary path,the traffic does on the explicit tunnel but does not

switchover once the primary path is restored.The FRR is not working.Any

inputs would be of great help.

Regards

Sunil

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
swaroop.potdar Tue, 05/01/2007 - 12:13
User Badges:
  • Blue, 1500 points or more

Can you please send your configurations, may be we can take it ahead on unicast.


HTH-Cheers,

Swaroop

bjornarsb Tue, 05/01/2007 - 23:22
User Badges:
  • Bronze, 100 points or more

Hi,

You might be aware of this but check the following command:

tunnel mpls traffic-eng priority setup-priority [hold-priority]


Configures setup and reservation priority for a tunnel.


The setup-priority argument is the priority used when signaling an LSP for this tunnel to determine which existing tunnels can be preempted.


Valid values are from 0 to 7. A lower number indicates a higher priority. An LSP with a setup priority of 0 can preempt any LSP with a non-0 priority.


The hold-priority argument is the priority associated with an LSP for this tunnel to determine if it should be preempted by other LSPs that are being signaled.


Valid values are from 0 to 7, where a lower number indicates a higher priority.


Regards

Bjornarsb


menon.sunil Wed, 05/02/2007 - 08:22
User Badges:

I have done that.I changed the priority 7 7 o n the autotemplate and manually set the backup tunnels to priority 1 1 on all the routers....it still does not switchover to the primary lsp after the primary link has been restored.


Regards

Sunil

bjornarsb Wed, 05/02/2007 - 12:26
User Badges:
  • Bronze, 100 points or more

Hi again,


a lower number indicates a higher priority so I think you should change to 1 1 for the autotemplate and 7 7 for the backup tunnel to allow preemption.


Regards

Bjornarsb

oettls Thu, 05/03/2007 - 00:40
User Badges:

Hi Sunil,


the switchover back to the primary path is triggered by the TE reoptimization process. The default for periodic reoptimization is 3600s (== 1h) ...

You can check if it's the reason for not switching back by manually triggering the process on the tunnel headend:


router#mpls traffic-eng reoptimize


If you want to switch back faster you can check out 'mpls traffic-eng reoptimize events link-up' - but this could cause some oscillation ...


cheers,

Stefan

menon.sunil Thu, 05/03/2007 - 05:05
User Badges:

The problem when I configure Automesh with Explicit backup tunnel,the FRR promotion does not happen.

Test_rtr1#show mpls traffic-eng tunnels property backup-tunnel brief

Signalling Summary:

LSP Tunnels Process: running

Passive LSP Listener: running

RSVP Process: running

Forwarding: enabled

auto-tunnel:

backup Disabled (0 ), id-range:65436-65535

onehop Disabled (0 ), id-range:65336-65435

mesh Enabled (10), id-range:1000-2000

Periodic reoptimization: every 10 seconds, next in 2 seconds

Periodic FRR Promotion: Not Running

Periodic auto-bw collection: disabled

TUNNEL NAME DESTINATION UP IF DOWN IF STATE/PROT

***USED AS BACKUP FOR AUTO-T... 10.0.0.43 - PO2/0/0 up/up

Displayed 1 (of 18) heads, 0 (of 16) midpoints, 0 (of 12) tails

Test_rtr1#

Regards

Sunil



Actions

This Discussion