WAE & email

Unanswered Question
May 1st, 2007

We have installed the WAE's (4.01) on several sites and, even though, it's working well by and large, we are experiencing some problems with e-mail. ....The e-mail in question is Microsoft Exchange 2003 and the problem manifests itself in very slow opening of the Exchange client, and, in some cases, even coming to a complete halt...Both, the client site and the server site have WAE installed. When we disable the WCCP, the problem disappears, so the WAE looks like the culprit... Yet, I am a bit skeptical because first, I have been told that no e-mail traffic was going to be optimized and, secondly, I did not see the port 135 (outlook client) among the ports(protocols) in the default policy. Can someone please shed the light on what could be going on here?

thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Zach Seils Wed, 05/02/2007 - 23:04

Alex,

There is a known issue with the EPM Adapter (see CSCsg11506) that may be causing your problems. In 4.0.1, you can prevent traffic from being passed to the EPM Adapter by disabling the following policy-map:

name Other classifier MS-EndPointMapper action accelerate MS-port-mapper

In later version of WAAS you can disable the adapter using the command:

no adapter epm enable

I would also recommend that you upgrade to version 4.0.5 or later.

Thanks,

Zach

axfalk Fri, 05/04/2007 - 10:20

Thanks, everybody, for your responses...I could not find any MAPI related policies as well...What exactly the EPM Adapter do?

thanks again

Zach Seils Sun, 05/06/2007 - 22:02

The EPM Adapter monitors MSRPC requests to determine the dynamic TCP port that will be used for the client connection. Once we know the port, we can dynamically apply the correct policy to that traffic.

Zach

axfalk1 Fri, 05/11/2007 - 06:30

make sure you're running the latest code level, which, I believe is 4.09..it makes a huge difference...

c.stockwell Thu, 10/18/2007 - 15:24

How is everyone configuring their WAAS environment to optimize Exchange connections? At the moment when we turn on 'epm classification' the Exchange client/server connection fails. So at the moment we are leaving it off.

Do I have to modify any Policy Definitions from defaults (eg. mapi) to get it to work?

Cheers

JHaynes4 Mon, 10/22/2007 - 06:17

I'm not sure what code you are running (the latest is 4.0.13.b23) but the newer code disables EPM by default. The major problem being that EPM does not handle asymmetric routing issues very well. We have EPM disabled and the new feature of GRE Return as the egress method for our core WAE's and all of our issues have gone away. With EPM off the Exchange connections should fall under the Other policy and be optimized.

artem_oliynyk Tue, 05/05/2009 - 06:58

We have the similar problem on version 4.1.3(55). But with old version 4.0.19 we haven't any problem with Exchange connections.

I tried to disable EPM and set Passthrough on "MS-EndPointMapper". It doesn't help.

dstolt Tue, 05/05/2009 - 12:59

Artem,

The forum thread you posted to is for a very old bug with End Point Mapper in the 4.0 train. In 4.0.13 and later, EPM was disabled and we manually mapped exchange servers for statistics so not to cause any disruptions in Exchange traffic.

EPM was completely re-written in 4.1 so what you are seeing is quiet possibly a completely different issue that may, or may not be related to EPM. You say that this worked with the same exact setup in 4.0.19? If you disabled EPM globally, then I would examine interception and validate that you are not seeing issues like routing loops, etc. What you may also want to try is disabling the MAPI AO and see if that helps.

Dan

artem_oliynyk Wed, 05/06/2009 - 00:59

Hi Dan,

thanks a lot for your answer. I found this thread via search.

Anyway. I tried to disable MAPI vie command line with "no accelerator mapi enab". And it seems it helps. But I'll test it again with another site and than I'll let you know.

Thanks a lot.

Actions

This Discussion