Unity Tomcat service startup problems

Unanswered Question
May 2nd, 2007
User Badges:

We just finished loading Unity v 4.2(1) (for the 2nd time) and all


appears OK, except that the Tomcat service refuses to start.

Trying a restart brings up the message: 'Could not start Tomcat service


on local computer. Error 1067:The process terminated unexpectedly'

Launching the service from the cmd. prompt returns:

Asked <given> winsock 1.1

Error StartServiceCtrlDispatcher failed


Tomcat is version 4.1 JSDK is version 1.4.0


Any help would be appreciated


Denis Harrison

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
neesharm Thu, 05/03/2007 - 01:50
User Badges:
  • Bronze, 100 points or more

search for a log file stderr.log on the server .

You might see something like


"Error initializing endpoint java.net.BindException: Address already in use:

JVM_Bind:8080"


Now verify witn "netstat -an" output and see if there is something listening on port 8080.

Now check the services and find if they are listening on port 8080.

Try Stoping that service and then start tomcat.


t070335 Thu, 05/03/2007 - 07:02
User Badges:

Hi neesharm


Thanks for your reply. I did check the log and the error you describe is there.

The netstat cmd. shows TCP 0.0.0.0:8080 listening, which I don't quite undestand.

Why would this happen on a completely new install?

Can I have Tomcat listen on a different port without causing problems in Unity?


Denis


I have this same issue..I had four unity boxes 2 were just upgrades...to 4.21 and all is fine with ciscopca...2 were migrated to new hardware so it was basically a new install...I am having this exact error..Ive tried uninstalling ciscopca and reinstalling...I dont understand how to find out what service is using port 8080..

t070335 Tue, 05/15/2007 - 07:53
User Badges:

Hi Amy


I don't know what hardware platform you are using. Ours is an IBM and Cisco TAC had us disable the ServeRAID FlashCopy Agent service, which uses port 8080. We did this and Tomcat came up fine. I'm not clear on what the role of that service is and whether it is required. I know that we could restart it after Tomcat came up, but I don't know if this would have any comsequences either.


Denis

Frederick Nielsen Wed, 05/16/2007 - 16:18
User Badges:
  • Bronze, 100 points or more

had a similar problem on this end, thanks for the tip

binu.john Sun, 11/25/2007 - 22:33
User Badges:

Yes!i too have the same problem.After shut down the service and restart the tom cat it worked.THANX.

Actions

This Discussion