E1 R2 - call setup and troubleshooting

Unanswered Question
May 2nd, 2007

Router: Cisco 3725

IOS Version: 12.4(10a)

IOS image loaded: "flash:c3725-spservicesk9-mz.124-10a.bin"

Sometimes the E1 doesn't put channels in idle status, so it doesn't stay ready to receive next call.

I saw a lot of good information in CCO doc - E1 R2 Signaling Configuration and Troubleshooting, but the IOS version running in 3725 router do not have the same debugs from doc at URL:


The carrier told us: therea are a bit ABCD error when the call has been diconnected (here in Brazil only bits CD matter to signaling).

When carrier sends "CLEAR_FORWARD" the router should be answer with CD=01 bits, but it never happens. In vision of carrier (Voice Service Provider).

Anybody knows how can I see the E1 signaling bits using IOS 12.4(10a)?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (4 ratings)
Paolo Bevilacqua Wed, 05/02/2007 - 15:52


E1 R2 has got many bug fixes, could you upgrade to 12.4(13b) first and then if the problem continues we can look at your configuration any why the brazil country settings do not work ?

You could also try a latest 12.4T that is not less stable than 12.4 mainline.

gogasca Fri, 05/04/2007 - 11:39

R2_Q421_CLR_BWD_OUT 0x0C /* 1100 */

Could you please post your controller config and cas-custom...make sure you use country defaults.

Once this is done, you can troubleshoot using:

'debug voip vtsp all'

'debug vpm signal'

'debug voice ccapi inout'

teodorgeorgiev Mon, 05/07/2007 - 23:08

Does the "debug cas" command work?

Usually the AB bits matter. And Cisco give you the opportunity to change the CD bit values your gateway is sending.

dcobra Tue, 05/08/2007 - 05:15


In this particular IOS version some debug haven't present like "debug cas". :-(

But after several customization test with carrier, we reach a good one configuration where the carrier is glad with all signaling information.

This gateway handles calls together a CCM (4.1(3)) cluster with 2 servers.

The end configuration for this case (connected to Brasil Telecom carrier) is:


! All configuration related with

! voice signaling


voice class h323 1

h225 timeout tcp establish 3



controller E1 1/3

framing NO-CRC4

clock source line primary

ds0-group 1 timeslots 1-15,17-31 type r2-digital r2-compelled ani

cas-custom 1

country brazil

release-guard-time 500

category 2

answer-signal group-b 1

ani-digits min 7 max 10

description CONNECTED TO 0800


interface FastEthernet0/0


ip address

no keepalive

h323-gateway voip interface

h323-gateway voip bind srcaddr


voice-port 1/3:1

no vad

no comfort-noise

cptone BR

description 0800


dial-peer voice 800 pots

incoming called-number 912


port 1/3:1


dial-peer voice 801 voip

destination-pattern 912

preference 1

session target ipv4:

dtmf-relay h245-alphanumeric


dial-peer voice 802 voip

preference 2

destination-pattern 912

session target ipv4:

dtmf-relay h245-alphanumeric


Thanks for all for support, and I HTH somebody in future connections with Brasil Telecom carrier.



P.S.: If this configuration sample was helpful, don't forget rate this post, please!

nosferatus Sat, 08/28/2010 - 19:33

hi, y need help for incoming calls, for e1 in mexico i try receive but not
work the tone is busy, always i try configuring dial-peer for incoming
calls but not work. The outgoing calls work fine.

controller E1 0/0/0
framing NO-CRC4
clock source internal
ds0-group 1 timeslots 1-12 type r2-digital r2-compelled ani
cas-custom 1
country telmex use-defaults
category 2
answer-signal group-b 1
description """ E1 VOICE """

voice-port 0/0/0:1
cptone MX
dial-peer voice 21 pots
description local
translation-profile outgoing CALLER_ID_TRANSLATION_PROFILE
preference 3
destination-pattern 9.......
port 0/0/0:1
forward-digits 7

dial-peer voice 1000 pots
description incoming calls
translation-profile incoming Incoming_Calls_5700
incoming called-number 467....
port 0/0/0:1
forward-digits all

voice translation-rule 10
rule 2 /4050/ /124/
rule 2 /4051/ /124/
rule 3 /4052/ /124/
rule 4 /4053/ /124/
rule 5 /4054/ /124/
rule 6 /4055/ /124/
rule 7 /4056/ /124/
rule 8 /4057/ /124/
rule 9 /4058/ /124/
rule 10 /4059/ /124/
voice translation-profile Incoming_Calls_5700
translate called 10

thanks for your help
remi-reszka Sat, 11/13/2010 - 19:33

Hi nosferatus,

Are you still having problems with incoming dial-peers on E1 Telmex?


nosferatus Sun, 11/14/2010 - 09:07

Hi remi-rezka.

thanks for you attention but the problem is Ok now

best regards.

remi-reszka Sun, 11/14/2010 - 19:28

hola nosferatus ,

I am glad you solved your issue. You know, I am setting up a trunk E1 with Telmex on my client's UC560. Telmex did not give us any parameters how to set up the trunk. I did it with "r2-compelled ani" and it works however all incoming calls from outside do not present caller ID (ANI), they appear as "Desconocido". Would you be kind to share your E1 configuration for Telmex service? Maybe I am also doing something wrong with the incoming dial-peer. It would be great if you could share your config.

Many thanks in advance.


nosferatus Sun, 11/14/2010 - 22:11

hi Remi

this is my configuration

controller E1 0/0/0
framing NO-CRC4
line-termination 75-ohm
ds0-group 0 timeslots 1-10 type r2-digital r2-compelled ani
cas-custom 0
  country telmex
  category 2
  answer-signal group-b 1
dnis-digits min 1 max 16
  ani-digits min 0 max 10
  ani-timeout 1
  timer interdigit incoming 1000
description """ E1 VOZ """

voice-port 0/0/0:0

cptone MX
translation-profile incoming Incoming_Calls_5700
translation-profile outgoing outgoing_calls

voice translation-profile Incoming_Calls_5700
translate called 10

voice translation-profile outgoing_calls
translate calling 2

voice translation-rule 2
rule 1 /^9/ //

voice translation-rule 10
rule 1 /^4060/ /7000/
rule 2 /4050/ /6000/

dial-peer voice 200 pots
description Incoming
translation-profile incoming Incoming_Calls_5700
incoming called-number .
dial-peer voice 201 pots
description Outgoing
translation-profile outgoing outgoing_calls
destination-pattern 9T
port 0/0/0:0


remi-reszka Mon, 11/15/2010 - 17:22

Hi nosferatus,

Thanks a lot for the config. Without having Telmex E1 parameters I came up with quite similar config to yours. I did the configuration and still no caller ID (ANI). Did you have similar problem while setting up the trunks? Is it possible Telmex is blocking ANI on our E1 service? Thanks for any suggestions.


This Discussion