Doubt on the routing

Unanswered Question
May 2nd, 2007
User Badges:
  • Silver, 250 points or more

Hi,

2 Locations, 2 Routers, each routers connected point to point & also each routers connected to internet.


point to point link is 2Mbps ether link i hav given the public IP given by the ISP.


internet link is 2Mbps leased line


Router-1


interface fasthernet 0/0

ip address 10.1.1.1 255.255.255.0


interface fasthernet 0/1

ip address 61.1.1.2 255.255.255.192


interface serial 0/0

ip address 201.1.1.1 255.255.255.252


ip route 0.0.0.0 0.0.0.0 serial 0/0

ip route 100.1.1.0 255.255.255.192


Router-2

interface fasthernet 0/0

ip address 192.168.1.1 255.255.255.0


interface fasthernet 0/1

ip address 61.1.1.1 255.255.255.192


interface serial 0/0

ip address 203.1.1.1 255.255.255.252


ip route 0.0.0.0 0.0.0.0 serial 0/0


now the network 100.x.x.x,203.x.x.x & 201.x.x.x & the serial interface address are all public address. now if Point to Point link fails, Router-1 users cannot reach 10.1.1.0, in that case i need to delete the route entry, so that 100.1.1.0 will reach via internet link, again if the point to point link comes up, i will be adding the route entry. so doing it manually works fine, but i wanted to do it automatically how do i configure?


i know that 100.x.x.x can be reached directly from the internet without having Point to Point, but i wanted the 100.x.x.x to give priority reach via point to point rather than reach via internet for some reason. only if point to point links fails it has to reach via internet, this is my requirement. so help me in suggesting.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
mohammedmahmoud Wed, 05/02/2007 - 22:37
User Badges:
  • Green, 3000 points or more

Hi,


You should use a floating static route (a route with a higher AD) as a backup route, and point all your static routes to both the outgoing interface and the next-hop in order to be automatically withdrawn from the routing table if the interface goes down.


HTH, please rate if it does help,

Mohammed Mahmoud.

Anand Narayana Wed, 05/02/2007 - 22:38
User Badges:
  • Silver, 250 points or more

Thanks for the reply,

can you tell me the command of that floating static route, so that i can configure.

hoogen_82 Wed, 05/02/2007 - 22:51
User Badges:
  • Silver, 250 points or more

ip route x.x.x.x y.y.y.y z.z.z.z


The AD is where you define a value of 1-255. This is how you could create a floating static route.

Anand Narayana Wed, 05/02/2007 - 22:54
User Badges:
  • Silver, 250 points or more

in my case,


always the default route should be


ip route 0.0.0.0 0.0.0.0 serial 0/0

ip route 100.x.x.x 255.255.255.192 fasthernet 0/1


only if point to point link fails it should route via internet(ip route 0.0.0.0 0.0.0.0 serial 0/0).


Note: reaching internet is primary, but for reaching 100.x.x.x network via fastethernet 0/1 is primary, only if this link fails it has to route via internet link.


i hope i am making much more clear.


so based on this, suggest me.

ankbhasi Wed, 05/02/2007 - 23:14
User Badges:
  • Cisco Employee,

Hi Anand,


I haven't tried this in my setup but written a small config for you which I believe should work



route-map PBR permit 10

match ip address 100

set interface fa0/1 serial 0/0

!

route-map PBR permit 20

match ip address 101

set interface Serial0/0



access-list 100 permit ip any 100.1.1.0 0.0.0.63


access-list 101 permit ip any any


Then you can apply policy "PBR" on your lan interface whichis fa0/0 I believe.


But as you mentioned you also have an internet connection I believe you also must be doing NAT which I do not see in your config can you please confirm the same. If NAT is there then we also have to change this config or NAT Fallback.


HTH


Ankur

mohammedmahmoud Wed, 05/02/2007 - 23:22
User Badges:
  • Green, 3000 points or more

Hi,


ip route 100.x.x.x 255.255.255.192 serial 0/0 254.



And make sure that you have enabled keepalives under the ethernet interface.



HTH, please rate if it does help,

Mohammed Mahmoud.

Anand Narayana Thu, 05/03/2007 - 00:41
User Badges:
  • Silver, 250 points or more

but will this link reach to 100.x.x.x will b primary or only if 0.0.0.0 fails it will reach 100.x.x.x ?

mohammedmahmoud Thu, 05/03/2007 - 01:06
User Badges:
  • Green, 3000 points or more

Hi,


Having a floating static route, and having all your routes pointing to both the outgoing interface and the next-hop shall solve this problem as it shall withdraw the route pointing to an interface if that interface goes down, but you must make sure that the ethernet interface has keepalives configured on it in order to go down when a problem occures, in order to further withdraw the route from the routing table, and finally the floating static route will do the backup job until the ethernet interface comes up again, and then it will replace the floating static route automatically as it has a lower AD.



HTH, please do rate if it does help,

Mohammed Mahmoud.

Anand Narayana Thu, 05/03/2007 - 03:00
User Badges:
  • Silver, 250 points or more

Thanks Mohammed,

i will try this command & will let you know.

Actions

This Discussion