Newbie - how to setup QOS on 3640, 2620, 1760

Answered Question
May 3rd, 2007
User Badges:

Dear Expert,

I am very new to CISCO, How to setup QOS on CISCO 3640, 2620 & 1760.. below are my IOS versions.


Many thanks in advance


Regards

Winanjaya



Cisco Internetwork Operating System Software

IOS (tm) 3600 Software (C3640-IS-M), Version 12.2(4)T, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2001 by cisco Systems, Inc.

Compiled Fri 28-Sep-01 05:01 by ccai

Image text-base: 0x600089A8, data-base: 0x61428000


Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IS-M), Version 12.2(4)T, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2001 by cisco Systems, Inc.

Compiled Fri 28-Sep-01 06:59 by ccai

Image text-base: 0x80008088, data-base: 0x812E7ADC



Cisco Internetwork Operating System Software

IOS (tm) C1700 Software (C1700-SV3Y-M), Version 12.2(4)XW, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright (c) 1986-2001 by cisco Systems, Inc.

Compiled Wed 14-Nov-01 01:18 by ealyon

Image text-base: 0x80008124, data-base: 0x80CA8C08

Correct Answer by mohammedmahmoud about 9 years 10 months ago

Hi,


We can classify them according to the IP addresses of the servers (once as source and once as destination), but in this case all the traffic from and to the servers will be treated the same way.



HTH, please rate all helpful posts,

Mohammed Mahmoud.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mohammedmahmoud Thu, 05/03/2007 - 01:59
User Badges:
  • Green, 3000 points or more

Hi,


What QoS parameters exactly that you require to configure, and what is the type of traffic in your network.


BR,

Mohammed Mahmoud.

winanjaya Thu, 05/03/2007 - 02:22
User Badges:

Thanks, What i need is to configure QOS for the following:


- Mail

- Client Server Application 1

- Client Server Applicaiton 2

- Internet Browsing


FYI, Our mail & proxy server are located at HO


many thanks in advance


Regards

Winanjaya


mohammedmahmoud Thu, 05/03/2007 - 02:29
User Badges:
  • Green, 3000 points or more

Hi,


What is the connectivity technology between the routers (FR, MPLS, leased, ...), what is the bandwidth of each site, and what is the bandwidth that you wish to guarantee for each traffic type.


BR,

Mohammed Mahmoud.

winanjaya Thu, 05/03/2007 - 02:40
User Badges:

Thanks,

Connectivity between routers is E1 leased line channel


HO to Branch A is 2 MB

HO to Branch B is 2 MB

HO to Branch C is 2 MB

HO to Branch D is 2 MB

HO to Branch E is 2 MB


this is for example:


Mail: 25%

Client Server Application 1 : 15%

Client Server Application 2 : 15%

Internet Browsing : 25%

Others : 20 %


Others meant undefined services.


many thanks in advance


Regards

Winanjaya




mohammedmahmoud Thu, 05/03/2007 - 03:18
User Badges:
  • Green, 3000 points or more

Hi,


Here you are a basic QoS configuration.


For your knowledge the QoS doesn't interact unless there is congestion on the link.


First Define the classes (for mail use the protocols you require from the following, for app1 and app2 use an extended ACL to define them)


!

class-map match-any mail

match protocol pop3

match protocol smtp

match protocol imap

match protocol secure-pop3

match protocol secure-imap

match protocol exchange

match protocol ldap

class-map match-all http

match protocol http

class-map match-all app1

match access-group 101

class-map match-all app2

match access-group 102



Assign each traffic class the appropriate bw:



policy-map qos

class mail

bandwidth percent 25

class http

bandwidth percent 25

class app1

bandwidth percent 15

class app2

bandwidth percent 15

class class-default

fair-queue


You then need to classifiy app1 and app2 traffic may be according to the port number used:



access-list 101 permit tcp any any eq

access-list 101 permit tcp any eq any


access-list 102 permit tcp any any eq

access-list 102 permit tcp any eq any



Apply the policy under each interface in the output direction:



interface serial 0/0

bandwidth 2048

service-policy output qos




I hope that i've been informative.



HTH, please rate using the below scroll box if it does help,

Mohammed Mahmoud.

winanjaya Thu, 05/03/2007 - 17:21
User Badges:

Hi..

You wrote:

... the QoS doesn't interact unless there is congestion on the link...


did you mean that if there is no congestion on the link then the first come class will get full bw regardless the QOS ? pls advise


thanks & regards

Winanjaya



thotsaphon Thu, 05/03/2007 - 20:54
User Badges:
  • Gold, 750 points or more

Hi Winanjaya

Whatever Mohammed told you is a congestion management which is one of many methods of QOS implementation. If your link isn't congestion(Hardware Queue full) then software queuing that you configured won't be used at all.


HTH

L.Thot

mohammedmahmoud Thu, 05/03/2007 - 22:23
User Badges:
  • Green, 3000 points or more

Hi Winanjaya,


Yes what i meant is that the congestion management tools that we've configured till now will only interact when there is congestion, which is fair, in the case that there is no congestion any traffic of them can talk more than what was guaranteed for him which is nice, but in the moment of congestion the values we configured are met, which is what we are looking for.



HTH, please rate if it does help,

Mohammed Mahmoud.

winanjaya Thu, 05/03/2007 - 23:56
User Badges:

How about for App1, App2 they don't have static service port



Correct Answer
mohammedmahmoud Fri, 05/04/2007 - 00:11
User Badges:
  • Green, 3000 points or more

Hi,


We can classify them according to the IP addresses of the servers (once as source and once as destination), but in this case all the traffic from and to the servers will be treated the same way.



HTH, please rate all helpful posts,

Mohammed Mahmoud.

Actions

This Discussion