Linkdown trap not working

Unanswered Question
May 3rd, 2007

hi,

I am trying to monitor 2621 with IOS 12.1(5)T but i discoverd that it doesn't send a link down trap.

i checked the configuration and it looks fine (It is working on other routers).

Could you help me (Configuration is attached).

Tzachi Slav

Configuration

Version 12.1

no service single-slot-reload-enable

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hosname R_X

!

no logging rate-limit

!

ip subnet zero

!

!

no ip finger

ip domain name test.sm

ip name-server 222.x.x.240

!

!

decnet routing 1.504

decnet node-type are

!

call rsvp-sync

!

interface loopback0

ip address 200.x.x.x.255.255.0

!

interface fastethernet 0/0

description LAN

ip addess 222.222.x.x.255.255.0

duplex auto

speed auto

decnet cost 1

ip rsvp bandwidth 24 24

!

interface serial 0/0

description WAN

mtu 1000

bandwidth 64

ip address 222.x.x.3 255.255.255.0

ip tcp header-compression

no ip mroute-cache

dcnet cost 2

fair-queue 64 16 1

mop enabled

ip rtp header-compression

ip rsvp bandwidth 24 25

!

router eigrp 1

....

no auto-summary

no eigrp log-neighbor-changes

!

ip classless

no ip http server

decnet host MRRTR4 1.504

!

snmp-server engineID local X

snmp-server community public RO

snmp-server community password RW

snmp-server trap-source loopback0

snmp-server enable traps snmp authentication linkdown linkup coldstart

snmp-server enable traps hsrp

snmp-server enable traps syslog

snmp-server host 222.x.x.222 password xxx config envmon syslog

!

!

...

end

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
David Stanford Thu, 05/03/2007 - 05:21

If you enable snmp debugs do you see it attempt to send the snmp link down trap?

If so, what is the network path to the trap receiver? Any chance it is getting dropped after leaving this device?

Nigel Bowden Thu, 05/03/2007 - 06:07

Hi,

Just try:

snmp-server host 222.22.211.222 password

I think the 'tty config envmon syslog' parameters are maybe stopping the link up/down traps.

David Stanford Thu, 05/03/2007 - 07:44

Sorry I missed that...your config will not send snmp linkup/down to the host based on the paramaters you added to the host command

Actions

This Discussion