3560's not routing...

Unanswered Question
May 3rd, 2007
User Badges:

Can anyone please tell me why these two 3560's are not routing?


Test#sh run

Building configuration...


Current configuration : 2605 bytes

!

version 12.2

!

no aaa new-model

ip subnet-zero

ip routing

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface GigabitEthernet0/17

no switchport

ip address 192.168.1.1 255.255.255.252

!

!

interface Vlan1

ip address 10.90.153.1 255.255.255.0

!

router eigrp 1

network 10.90.153.0 0.0.0.255

network 192.168.1.0 0.0.0.3

auto-summary

!

ip default-gateway 10.90.153.200

ip classless

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/17

!


-----------------------------------------------


E3#sh run

Building configuration...


Current configuration : 2816 bytes

!

version 12.2

!

no aaa new-model

ip subnet-zero

ip routing

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface GigabitEthernet0/17

no switchport

ip address 192.168.1.2 255.255.255.252

!

!

interface GigabitEthernet0/48

switchport trunk encapsulation dot1q

switchport mode trunk

duplex full

macro description cisco-switch

auto qos voip trust

spanning-tree link-type point-to-point

!

!

interface Vlan1

ip address 172.23.31.34 255.255.255.224

!

router eigrp 1

network 172.23.31.32 0.0.0.31

network 192.168.1.0 0.0.0.3

auto-summary

!

ip default-gateway 172.23.31.33

ip classless

ip route 0.0.0.0 0.0.0.0 172.23.31.33

!

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
chris.lepa Thu, 05/03/2007 - 11:57
User Badges:

Hi,


I'm not too sure what you're issue is, "not routing" is a pretty vague statement. Are your devices forming eigrp neighbor relationships? If so, it may be an issue with "auto-summary". In eigrp configuration, type "no auto-summary" so you're networks aren't summarized at the classful boundary.


-Chris

ricschaaf Thu, 05/03/2007 - 12:07
User Badges:

Thanks for responding.


I can't ping from the 172.23.31.32/27 net

to the 10.90.153.0/24 net


Attached is a screen shot of the routing tables of one of the switches




Attachment: 
chris.lepa Thu, 05/03/2007 - 12:26
User Badges:

Well, it seems that the 10.90.153.0 network is not in your eigrp routing table at all, meaning that anything destined for that network will use the static route you have applied (ip route 0.0.0.0 0.0.0.0 172.23.31.33). I'm not exactly sure what this route is doing... Is there more than the 2 devices stated in this network?


-Chris

ricschaaf Thu, 05/03/2007 - 13:04
User Badges:

There is a router attached to port 48 that

is the default gateway for the whole network.


I turned off auto-summarization on the switch named Test and it now shows the 172.23.31.32/27 net in it's routing table,

but when I did it on the switch E3, it did not pick up the 10.90.153.0/24 net.


?


Current configs and tables attached.


Thanks for your help,

Ric


----------------------------------------



E3#sh run

Building configuration...


Current configuration : 2819 bytes

!

version 12.2

!

no aaa new-model

ip subnet-zero

ip routing

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface GigabitEthernet0/17

no switchport

ip address 192.168.1.2 255.255.255.252


!

interface GigabitEthernet0/48

switchport trunk encapsulation dot1q

switchport mode trunk

duplex full

macro description cisco-switch

auto qos voip trust

spanning-tree link-type point-to-point

!

interface Vlan1

ip address 172.23.31.34 255.255.255.224

!

router eigrp 1

network 172.23.31.32 0.0.0.31

network 192.168.1.0 0.0.0.3

no auto-summary

!

ip default-gateway 172.23.31.33

ip classless

ip route 0.0.0.0 0.0.0.0 172.23.31.33



----------------------------------------




Test#sh run

Building configuration...


Current configuration : 2600 bytes

!

no aaa new-model

ip subnet-zero

ip routing

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface GigabitEthernet0/17

no switchport

ip address 192.168.1.1 255.255.255.252

!

interface Vlan1

ip address 10.90.153.1 255.255.255.0

!

router eigrp 1

network 10.90.153.0 0.0.0.255

network 192.168.1.0 0.0.0.3

no auto-summary

!

ip default-gateway 172.23.31.33

ip classless

ip route 0.0.0.0 0.0.0.0 172.23.31.33




Attachment: 
chris.lepa Thu, 05/03/2007 - 13:21
User Badges:

Based on your EIGRP configuration, I can't see anything wrong. I DO see a problem with your static default route on Test though.


Neither "ip route 0.0.0.0 0.0.0.0 172.23.31.33" or "ip default-gateway 172.23.31.33" should be configured on Test because that is not a next hop address this router is familiar with.


Instead, I suggest that you enter the "default-information originate" or "redistribute static" command in EIGRP on your E3 router. This maaaay fix your issues.


-Chris

chris.lepa Thu, 05/03/2007 - 13:31
User Badges:

Oh, you should also check to see if Vlan 1 is even UP on Test. This route wont get advertised by EIGRP if the SVI is down, might want to check that out too if the previous solution doesn't do anything.

ricschaaf Fri, 05/04/2007 - 05:59
User Badges:


VLAN 1 is up on Test. I can connect a client as 10.90.153.x

and ping the E3 switch at 172.23.31.34, but no other IP's

on that 172.23.31.32/27 net.


I changed the default on Test as shown below and no luck.

There's something on the E3 switch that is not right.

I even tried making VLAN 1 passive on E3 and no luck.


Thanks, Ric


---------------------------------------------------------


Test#sh run

Building configuration...


Current configuration : 2575 bytes

!

version 12.2

!

ip subnet-zero

ip routing

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface GigabitEthernet0/17

no switchport

ip address 192.168.1.1 255.255.255.252

!

interface Vlan1

ip address 10.90.153.1 255.255.255.0

!

router eigrp 1

network 10.90.153.0 0.0.0.255

network 192.168.1.0 0.0.0.3

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/17



Test#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route


Gateway of last resort is 0.0.0.0 to network 0.0.0.0


172.23.0.0/27 is subnetted, 1 subnets

D 172.23.31.32 [90/3072] via 192.168.1.2, 16:54:44, GigabitEthernet0/17

10.0.0.0/24 is subnetted, 1 subnets

C 10.90.153.0 is directly connected, Vlan1

192.168.1.0/30 is subnetted, 1 subnets

C 192.168.1.0 is directly connected, GigabitEthernet0/17

S* 0.0.0.0/0 is directly connected, GigabitEthernet0/17


-------------------------------------------------------------


E3#sh run

Building configuration...


Current configuration : 2819 bytes

!

version 12.2

!

no aaa new-model

ip subnet-zero

ip routing

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface GigabitEthernet0/17

no switchport

ip address 192.168.1.2 255.255.255.252

!

interface GigabitEthernet0/48

switchport trunk encapsulation dot1q

switchport mode trunk

duplex full

macro description cisco-switch

auto qos voip trust

spanning-tree link-type point-to-point

!

interface Vlan1

ip address 172.23.31.34 255.255.255.224

!

router eigrp 1

network 172.23.31.32 0.0.0.31

network 192.168.1.0 0.0.0.3

no auto-summary

!

ip default-gateway 172.23.31.33

ip classless

ip route 0.0.0.0 0.0.0.0 172.23.31.33



E3#show ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route


Gateway of last resort is 172.23.31.33 to network 0.0.0.0


172.23.0.0/27 is subnetted, 1 subnets

C 172.23.31.32 is directly connected, Vlan1

192.168.1.0/30 is subnetted, 1 subnets

C 192.168.1.0 is directly connected, GigabitEthernet0/17

S* 0.0.0.0/0 [1/0] via 172.23.31.33


Amit Singh Fri, 05/04/2007 - 06:42
User Badges:
  • Cisco Employee,

Its a strange situation which is happening. EIGRP is making a neighbor relationship as far as " Test " switch is concerned. What happens when you issue " show ip eigrp neighbor " on E3 switch. Do you see the test listed a neighbor.


Here are the two things that we can try:


1.Try changing the connection between the 2 switches to a vlan SVI instead of using the routed port.Let us check if the eigrp neighbor relationship comes up.


2.Try debugging thye rigrp relationship and attach the debugs.


-amit singh

ricschaaf Fri, 05/04/2007 - 10:16
User Badges:

E3>show ip eigrp neighbor

IP-EIGRP neighbors for process 1

H Address Interface Hold Uptime SRTT RTO Q Seq Type

(sec) (ms) Cnt Num

0 192.168.1.1 Gi0/17 12 21:41:42 5 200 0 12


On suggestion #1, do you mean connect them together without using the 192.168.1.0/30 net?


Thanks, Ric

chris.lepa Fri, 05/04/2007 - 10:25
User Badges:

He means:


Test#


int vlan 192

ip add 192.168.1.1 255.255.255.252

no shut


int gi0/17

switchport mode access

switchport access vlan 192


E3#


int vlan 192

ip add 192.168.1.2 255.255.255.252

no shut


int gi0/17

switchport mode access

switchport access vlan 192



At least I think he means that... Give it a shot and get back to us.


-Chris

Amit Singh Fri, 05/04/2007 - 10:45
User Badges:
  • Cisco Employee,

Yeah. I meant the same as posted by Chris. The output in your earlier post shows that E has a succesful naighbor relationship with test.Please paste the output of " show EIGRP topo " from the E3.


Also let me know the IOS version that your are running on 3560's.


-amit singh

ricschaaf Fri, 05/04/2007 - 12:20
User Badges:

E3>show ip eigrp topo

IP-EIGRP Topology Table for AS(1)/ID(192.168.1.2)


Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - reply Status, s - sia Status


P 192.168.1.0/30, 1 successors, FD is 2816

via Connected, GigabitEthernet0/17

P 172.23.31.32/27, 1 successors, FD is 2816

via Connected, Vlan1



version 12.2


E3 is not picking up the 10.90.153.0/24 net in it's routing table. Diagram is attached.


?


Thanks, Ric



Attachment: 
ricschaaf Fri, 05/04/2007 - 12:39
User Badges:

I really wnat to fihure this out....


Here's what Test looks like:


Test>show ip eigrp topo

IP-EIGRP Topology Table for AS(1)/ID(192.168.1.1)


Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,

r - reply Status, s - sia Status


P 192.168.1.0/30, 1 successors, FD is 2816

via Connected, GigabitEthernet0/17

P 172.23.31.32/27, 1 successors, FD is 3072

via 192.168.1.2 (3072/2816), GigabitEthernet0/17

P 10.90.153.0/24, 1 successors, FD is 2816

via Connected, Vlan1



Thanks very much, Ric

sundar.palaniappan Fri, 05/04/2007 - 12:57
User Badges:
  • Green, 3000 points or more

Did you at any point had an interface on router E3 configured with an IP from 10.90.153.0/24 subnet?

ricschaaf Fri, 05/04/2007 - 13:08
User Badges:


Actually, yes. Once upon a time I did config one

of the ports on E3 with an address from the

10.90.153.0/24 net. It has been long removed.

Why would that cause a problem? Does something

remain in the system?


Here's the latest from E3:



E3#sh run

Building configuration...


Current configuration : 3191 bytes

!

version 12.2

!

no aaa new-model

ip subnet-zero

ip routing

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

interface GigabitEthernet0/1

!

interface GigabitEthernet0/2

!

interface GigabitEthernet0/3

!

interface GigabitEthernet0/4

!

interface GigabitEthernet0/5

!

interface GigabitEthernet0/6

!

interface GigabitEthernet0/7

!

interface GigabitEthernet0/8

!

interface GigabitEthernet0/9

!

interface GigabitEthernet0/10

!

interface GigabitEthernet0/11

!

interface GigabitEthernet0/12

!

interface GigabitEthernet0/13

!

interface GigabitEthernet0/14

!

interface GigabitEthernet0/15

!

interface GigabitEthernet0/16

!

interface GigabitEthernet0/17

no switchport

ip address 192.168.1.2 255.255.255.252

!

interface GigabitEthernet0/18

!

interface GigabitEthernet0/19

!

interface GigabitEthernet0/20

!

interface GigabitEthernet0/21

!

interface GigabitEthernet0/22

!

interface GigabitEthernet0/23

!

interface GigabitEthernet0/24

!

interface GigabitEthernet0/25

!

interface GigabitEthernet0/26

!

interface GigabitEthernet0/27

!

interface GigabitEthernet0/28

!

interface GigabitEthernet0/29

!

interface GigabitEthernet0/30

!

interface GigabitEthernet0/31

!

interface GigabitEthernet0/32

!

interface GigabitEthernet0/33

!

interface GigabitEthernet0/34

!

interface GigabitEthernet0/35

!

interface GigabitEthernet0/36

!

interface GigabitEthernet0/37

!

interface GigabitEthernet0/38

!

interface GigabitEthernet0/39

!

interface GigabitEthernet0/40

!

interface GigabitEthernet0/41

!

interface GigabitEthernet0/42

!

interface GigabitEthernet0/43

!

interface GigabitEthernet0/44

!

interface GigabitEthernet0/45

!

interface GigabitEthernet0/46

!

interface GigabitEthernet0/47

!

interface GigabitEthernet0/48

switchport trunk encapsulation dot1q

switchport mode trunk

duplex full

macro description cisco-switch

auto qos voip trust

spanning-tree link-type point-to-point

!

interface GigabitEthernet0/49

!

interface GigabitEthernet0/50

!

interface GigabitEthernet0/51

switchport trunk encapsulation dot1q

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

queue-set 2

mls qos trust cos

macro description cisco-switch

auto qos voip trust

spanning-tree link-type point-to-point

!

interface GigabitEthernet0/52

!

interface Vlan1

ip address 172.23.31.34 255.255.255.224

!

interface Vlan192

no ip address

!

router eigrp 1

network 172.23.31.32 0.0.0.31

network 192.168.1.0 0.0.0.3

no auto-summary

!

ip default-gateway 172.23.31.33

ip classless

ip route 0.0.0.0 0.0.0.0 172.23.31.33


sundar.palaniappan Fri, 05/04/2007 - 13:22
User Badges:
  • Green, 3000 points or more

Configure the command 'no ip split-horizon eigrp 1' under g0/17 int on Test router. Then clear the eigrp neighbor and routes and see if that helps.


HTH


Sundar

Actions

This Discussion