Unity 4.0(4) - Cannot add previously deleted subscriber

Unanswered Question
May 3rd, 2007

One of our subscribers was having trouble with his MWI - it wouldn't light for new voicemail. I deleted his account and then added it again, using the sa...still no good on MWI, but that was it for troubleshooting that afternoon. Later that evening we rebooted the Unity server to address another issue (slow vm access which turned out to be a LAN problem). The next morning, the subscriber account was gone, and now when I try to re-add it as usual (in the sa with "find exchange user"), Unity cannot find the account. The mail account exists in Exchange and is working otherwise. I also tried using the Bulk Delete Tool on the server, but it doesn't bring up the subscriber account using any of the options. Any ideas? Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
ranpierce Thu, 05/03/2007 - 11:34

Try using Remove Subscriber Properties tool to clean the user account and mailbox in AD of Unity properties. Then you should be about to import the account again.

rlp

www.ciscounitytools.com

elbyte Thu, 05/03/2007 - 12:10

Thanks. I found that on the Unity server, but I get an error when I try to run it. I downloaded what appeared to be a more recent version, extracted it and get the same error... Run-time error '-2147016694(8007200a)': Automation error The specified directory service attribute or value does not exist...

Looks like some kind of

Mark Turpin Thu, 05/03/2007 - 12:21

what user are you running it as?

regarding the original problem, if you delete a user then try to add it too soon, you will have what equates to synchronization problems with AD. best practice when deleting/adding is to delete, wait for replication, then re-add. typically most replication kicks off within 15-30 minutes...

using the remove subscriber properties tool will fix the problem as the previous poster suggested.

elbyte Thu, 05/03/2007 - 12:39

I tried the tool, but only got as far as the Run-time error. I found the same property removal application as part of the Global Subscriber Manager. I removed the properties and have successfully added the problem user. Thank you all for your help!

Actions

This Discussion