can't ping out router1 from router2

Answered Question
May 3rd, 2007
User Badges:

Hello all. I have router bcbehind connected to my cable modem. I can ping out and resolve domain names. bcnetworked is connect to bcbehind via serial connect. ser0 connects to ser0. I am able to ping from bcnetworked up to the cable modem. I can't ping out. I believe it is something with bcbehind's config any help would be appreciated.


Current configuration : 1060 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

no service dhcp

!

hostname BCBehind

!

logging queue-limit 100

enable secret xxx

!

ip subnet-zero

ip domain-name lookup

ip name-server x.x.x.x

ip name-server x.x.x.x

!

partition flash 3 8 4 4

!

!

!

!

interface Serial0

ip address 10.0.0.1 255.255.255.252

!

interface Serial1

no ip address

shutdown

!

interface Serial2

no ip address

shutdown

!

interface Serial3

no ip address

shutdown

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

!

interface FastEthernet0

ip address 192.168.0.2 255.255.255.0

ip nat outside

full-duplex

!

router rip

version 2

network 10.0.0.0

network 192.168.0.0

no auto-summary

!

ip default-gateway 192.168.0.1

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.0.1

ip route 10.0.0.0 255.255.255.252 192.168.0.1

ip route 192.168.0.0 255.255.255.0 192.168.0.1

no ip http server

!

!

line con 0

line aux 0

line vty 0 4

password xxx

login

!

end


Correct Answer by mohammedmahmoud about 10 years 2 months ago

Hi,


Ok, thats the catch, you'll need to NAT bcnetworked IPs on the cable modem.



HTH, please rate if it does help,

Mohammed Mahmoud.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
mohammedmahmoud Thu, 05/03/2007 - 13:02
User Badges:
  • Green, 3000 points or more

Hi,


Can you post bcnetworked configuration.


BR,

Mohammed Mahmoud.

bruce.cowan Thu, 05/03/2007 - 13:16
User Badges:

Certainly:


Current configuration : 1290 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname BCNetworked

!

logging queue-limit 100

enable secret 5 $1$rQob$U2mhmJ0CBl6WJ8wwBh5Lv1

!

ip subnet-zero

ip domain-name lookup

ip name-server x.x.x.x

ip name-server x.x.x.x

!

partition flash 2 8 8

!

!

!

!

interface Ethernet0

no ip address

shutdown

!

interface Ethernet1

no ip address

shutdown

!

interface Ethernet2

no ip address

shutdown

media-type 10BaseT

!

interface Ethernet3

no ip address

shutdown

media-type 10BaseT

!

interface Ethernet4

no ip address

shutdown

media-type 10BaseT

!

interface Ethernet5

no ip address

shutdown

media-type 10BaseT

!

interface Ethernet6

no ip address

shutdown

media-type 10BaseT

!

interface Ethernet7

no ip address

shutdown

media-type 10BaseT

!

interface Serial0

bandwidth 64

ip address 10.0.0.2 255.255.255.252

clockrate 64000

!

interface Serial1

no ip address

shutdown

!

interface Serial2

no ip address

shutdown

!

interface Serial3

no ip address

shutdown

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.0.1

ip route 0.0.0.0 0.0.0.0 10.0.0.1

ip route 10.0.0.0 255.255.255.252 192.168.0.1

no ip http server

!

!

line con 0

line aux 0

line vty 0 4

password 7 05485723334D195B485C46405858

login

!

end


mohammedmahmoud Thu, 05/03/2007 - 13:26
User Badges:
  • Green, 3000 points or more

Hi,


If i understand you right then BCNetworked can ping both bcbehind and the cable modem, but it can't get outside, you have to consolidate one thing, routing is a 2 way process, thus for a ping to succeed the packet must know how to go from BCNetworked to outside and then back from outside to BCNetworked, does the outside (your provider) route the IPs of BCNetworked back, or are you doing NAT on the cable modem and the IPs of BCNetworked is not included.



HTH, please rate if it does help,

Mohammed Mahmoud.

Correct Answer
mohammedmahmoud Thu, 05/03/2007 - 13:59
User Badges:
  • Green, 3000 points or more

Hi,


Ok, thats the catch, you'll need to NAT bcnetworked IPs on the cable modem.



HTH, please rate if it does help,

Mohammed Mahmoud.

bruce.cowan Fri, 05/04/2007 - 09:27
User Badges:

That was very helpful. I was able to determine at the issue is my cable modem will not allow to allow any other networks other then the 192.168. network. Because of this I had to subnet the 192.168.0.0 to accommodate my needs since the cable modem would not allow me to enter the 10.0.0.0 network. Now both of my routers can ping all the way through. I appreciate the help.


B

mohammedmahmoud Fri, 05/04/2007 - 10:36
User Badges:
  • Green, 3000 points or more

Hi,


You are welcomed, i am glade that you have done it :)


BR,

Mohammed Mahmoud.

Actions

This Discussion